-   Ubuntu (
-   -   log-in screen missing. dead black screen instead (

blastradius 11-30-2006 01:25 AM

log-in screen missing. dead black screen instead
Hi all!

I've tried installing Edgy and Dapper including the alternate version of Dapper, and I still get the same problem. The system installs fine, it boots fine but then just as I expect the login screen to appear it stays as a dead black screen! The boot-up screen is fine so where is my log-in screen.

At this rate I'll have to re-install Hoary and try to upgrade from there. What the hell is going on?

My GFX card is an ATI Radeon 9600 and the monitor is a standard Relisys. I had no problems with Hoary so how come I've got them now?

Please help!


P.S. I'm having to type this on Windows!!! HELP!

Simon Bridge 11-30-2006 01:39 AM

Have you tried booting to text only? (then do startx)
Did the dapper live CD work OK?

Redeye2 11-30-2006 01:50 AM

Try to reconfigure the X server to get a working configuration. Once you hit the black screen, hit ctrl+alt+1, you'll get a text login. Login and then type sudo dpkg-reconfigure xserver-xorg and select the values you want then reboot to see if it helps.
If it doesn't, you could also try reverting to the vesa driver instead of nv. Login in the same way as before but now type sudo pico /etc/X11/xorg.conf to open a friendly editor and look for a line that reads Driver "nv" and change it to Driver "vesa", press ctrl+x and say YES to save the changes.
Finally, you could also post the output of the following command: cat /var/log/Xorg.0.log to help further debugging.

Simon Bridge 11-30-2006 02:17 AM


Originally Posted by Redeye2
look for a line that reads Driver "nv" and change it to Driver "vesa"


Originally Posted by blastradius
My GFX card is an ATI Radeon 9600

... OK, the nv driver definately won't work with this card, but shouldn't it be ati-glfx or somesuch? And, isn't the driver always going to be vesa on a fresh install (I thought the ati drivers were non-free? Has this changed?)

Don't get me wrong, it's all good stuff, I'm just curious.

blastradius 11-30-2006 07:31 AM

What confuses me is that I've had Dapper running fine before as a Breezy upgrade (which I upgraded from Hoary, which is why I have the Hoary disc). I tried upgrading to Edgy but hit these problems whci also buggered up my running system so I downloaded Dapper and the rest is history.

Thanks for your suggestions, I'll see how I go, as I said though it used to run fine as an upgraded system.

Redeye2 11-30-2006 10:06 AM

My bad about the driver. It should be ati instead of nv... it was too late :)

All times are GMT -5. The time now is 11:45 PM.