-   Ubuntu (
-   -   libusb not available to sane-find-scanner (

Simon Bridge 10-09-2005 03:22 AM

libusb not available to sane-find-scanner
I initially had a problem where sane-find-scanner would correctly find my scanner but scanimage -L didn't. However, after the initial trial, sane-find-scanner finds no scanners at all!

I did sane-find-scanner -v to see what was going on... and got the following at the end of the probe:

checking /dev/usbscanner15... failed to open (Invalid argument)
libusb not available
  # No USB scanners found.

... and so on.
Now the 1st line says "invalid argument" because /dev/usbscanner15 (and all the lesser numbers) dosn't exist: fair enough. It is the second line that is the surprise. Since libusb is not available, it is no surprise to get the last line.

lsusb shows the scanner correctly
libusb seems to be installed

this is an unmodified install of Ubuntu 5.04

ChrisTheGeek 10-10-2005 09:30 AM

Do you get the same result when running the programs as root?

If your scanner re-appears when you're root, you may need to sort out the permissions so your regular user can access the scanner. The following thread may help:

Simon Bridge 10-10-2005 08:14 PM

<sigh> yes - the same thing happens when running sane-find-scanner as root. Good attempt though - that is the most common reason something cannot be got. Normally, though, it is reported as access denied or "locked" when I check. Then I go "DOH!" and sudo...

I should have mentioned: I have read the man pages. There is a neat howto in there - which dosn't deal with the situation that libusb is not available.

I have also read through the faq and the mini-howto in

I have successfully helped other people with permissions and so on and so forth ... including getting the correct driver. However, I have not found any situation where libusb is "not available" when it is in fact installed.

I figured I may just have the wrong version - and upgraded everything with usb in it I could find. Also looked to see if there were usb packages to install. But it appears I have everything. (However I don't know what sane is expecting here.)

Perhaps libusb is in a different place - anyone with ubuntu experiencing this problem? Or perhaps there is an app which is hogging libusb so nothing else can use it?

Note: this works fine in Fedora Core 4.

Interestingly, it did work the first time I tried it - no idea what is different this time ... only thing that happened betweentimes is that my battery went flat unexpectedly. So perhaps there is a cache somewhere remembering that san-find-scanner is using libusb from the previous attempt. (In the previous attempt - sane-find-scanner detected the scanner correctly but scanimage -L didn't. Once I've got this figured out I can figure out that :) )

All times are GMT -5. The time now is 07:17 AM.