Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 02-23-2007, 02:02 PM   #1
Registered: Sep 2003
Location: Manchester UK
Posts: 264

Rep: Reputation: 30
Question libSDL install error - Ubuntu repo using CVS versions of libglu1-mesa?

Hi, I'm trying to install UFO:Alien Invasion from source, (no binaries available) and I'm meeting dependancy problems.

It fails because I don't have the SDL devel headers:

checking for sdl-config... no
configure: WARNING: cannot find sdl-config might fail to find SDL!
checking SDL.h usability... no
checking SDL.h presence... no
checking for SDL.h... no
checking SDL/SDL.h usability... no
checking SDL/SDL.h presence... no
checking for SDL/SDL.h... no
configure: error: You must have the SDL development headers
so I do sudo apt-get install libsdl-dev, and I then get the error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting libsdl1.2-dev instead of libsdl-dev
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libsdl1.2-dev: Depends: libglu1-mesa-dev but it is not going to be installed or
E: Broken packages
So, I then tried to install libglu1-mesa-dev, and I get a similar long message, but it ends with:

The following packages have unmet dependencies:
  libglu1-mesa-dev: Depends: libglu1-mesa (= 6.5.1~20060817-0ubuntu3) but 6.5.1+cvs20060824 is to be installed
                    Depends: libgl1-mesa-dev but it is not going to be installed or
E: Broken packages
So for some reason, the Ubuntu repositories have a version which is 5 CVS revisions later.

My problem is, I can't uninstall libglu1-mesa, as practically every GUI application depends on it!

Is there anything I can do, or any way I can have both versions running, or will that cause massive errors?

Many Thanks in advance,
Old 03-12-2007, 09:13 AM   #2
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
Hi morrolan,
I facing the same problem and I found both libglu1-mesa and libglu1-mesa-dev (6.5.1~20060817-0ubuntu3) at

check it out.

Good luck.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
yum -install returns error with repo giakhanh2487 Linux - Newbie 3 09-17-2006 08:54 PM
Multiple versions of xorg-x11-Mesa-libGLU Ian D Linux - Software 0 10-18-2005 03:14 PM
Cedega CVS install error speedemonV12 SUSE / openSUSE 2 08-17-2005 10:09 PM
Error in Make Depend while CVS install of WineX calmlikeabomb Mandriva 1 04-28-2004 06:46 PM
CVS, browsing commited versions TroelsSmit Linux - Software 0 04-28-2004 06:38 PM > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 12:07 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration