-   Ubuntu (
-   -   Kubuntu won't boot after power failure (

scrasun 07-20-2012 10:59 AM

Kubuntu won't boot after power failure
1 Attachment(s)

I have Kubuntu 12.04 installed on a Dell Studio 1537 laptop, which is prone to occasionally overheating and turning itself off. This has happened a few times before, but without consequence. Yesterday, this happened and I haven't been able to boot since. Some updates were being installed at the time of the crash.

The GRUB menu appears as normal, but none of the options (normal or recovery, or any of the kernels listed) will boot. The dots on the boot screen continue to move indefinitely (I've left it booting for over an hour) but the hard disk access light turns off after a short while and nothing else seems to happen. The system will then not respond to anything except turning the power off. I have a Windows dual boot which works normally, and a bootable Tinycore usb stick. I don't have a live CD, but I can make one if necessary. The following debugs are from attempting to boot in recovery mode (kernel 3.2.0-27-generic):-


Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... done.
Begin: Running /scripts/local-bottom ... done.
Begin: Running /scripts/init-bottom ... done.
fsck from util-linux 2.20.1
udevd[432]: unknown key 'BUS' in /etc/udev/rules.d/70-lego.rules:2

udevd[432]: invalid rule '/etc/udev/rules.d/70-lego.rules:2'

udevd[432]: unknown key 'BUS' in /etc/udev/rules.d/70-lego.rules:3

udevd[432]: invalid rule '/etc/udev/rules.d/70-lego.rules:3'

/dev/sda5: clean, 913656/9003008 files, 31369360/35985592 blocks (check deferred; on battery)
* Starting bluetooth daemon?[154G[ OK ]
* Starting CUPS printing spooler/server?[154G[ OK ]
(when attempting to boot, there is a pause after "Begin: Running /scripts/init-bottom ... done.")


I don't know if this information will be useful, but if anyone has any suggestions as to what i could do, then that would be greatly appreciated.


widget 07-20-2012 01:02 PM

A good place to start is to correct the package update/upgrade interuption.

Boot to recovery mode. Hopefully this will take you to a root prompt.

At the prompt;

dpkg --configure -a
If this returns an error try;

apt-get -f install
It would be a real good idea to then check for package upgrades and install them;

apt=get update

apt-get upgrade
if there are packages held back;
apt-get dist-upgrade
Assuming these end as they should hit Ctrl + d

This should take you to a user prompt (root prompt=#, user prompt=$).

At the user prompt type

You may be asked for your password at random times due to the Ubuntu "security model" which is kind of silly.

jk07 07-21-2012 01:01 AM

Once you get this problem straightened out, I would urge you to get to the bottom of your laptop overheating. I have a Toshiba laptop, and I had the same problem with it randomly turning itself off due to overheating. In the end, I had to take it apart, reseat the heat sink with new thermal past and generally clean it out. That seems to have solved the problem. I'm not suggesting that you take apart your laptop, but maybe it is worth getting it serviced. It should not be overheating.

syg00 07-21-2012 02:01 AM

The OP indicated the recovery option doesn't work. If Tinycore has a current fsck.ext3 that would be my first priority, else get a liveCD that does.

I concur on cleaning the laptop - I have a 1645 (a 2+ year old i7) and it requires the back taken off it and washed (yep, washed) twice a year. The venting is ridiculously small, and easily clogged by dust here. I also clean the fan each time.
No had it shutdown on me.

scrasun 07-24-2012 02:03 PM

Thank you for your suggestions :)

I have managed to get it fixed with the help of a live CD. I have taken my laptop apart and tried to clean it before, although this seems to make little difference. Overheating tends not to happen if I remember to prop it a few centimetres above the surface of a desk with books though.


All times are GMT -5. The time now is 07:58 PM.