LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 06-06-2008, 04:28 AM   #1
Sjonnie48
Member
 
Registered: Jun 2005
Location: Earth
Distribution: Ubuntu10.04
Posts: 308

Rep: Reputation: 43
Kubuntu: sound system not working after version upgrade


Earlier this morning I upgraded from Gutsy to Hardy.
After upgrading my sound system does not work anymore.

As I never had to do anything to get my sound system working I am not very familiar with this.
If anyone can tell me how to get my sound system working again, you will earn my eternal gratitude.

Regards,

Sjonnie48

Last edited by Sjonnie48; 06-06-2008 at 07:38 AM. Reason: question corrected
 
Old 06-06-2008, 09:41 PM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542Reputation: 542
Assuming you have a reasonably normal/common audio device in your machine, and assuming Ubuntu uses ALSA as the backend to drive your sound device, you might want to check the ALSA mixer settings to make sure the sound is not muted and the volume is turned on/up.

In a console (or as root) type "sudo alsamixer" (or "alsamixer") and using the SPACEBAR and arrow keys and the "M" key for mute/unmute make sure the PCM and master volume (as well as any other pieces that pertain to audio an your machine) are not muted and are turned up sufficiently.

When done, hit ESCAPE and then type "sudo alsactl store" (or "alsactl store") and now try the sound.

If this fails, provide us with info about the audio device, and anything else you can tell us about when it did work.

Sed fugit interea, non urinat in rectus uter.
 
Old 06-07-2008, 02:26 PM   #3
smannell
Member
 
Registered: Feb 2005
Location: Kansas City
Distribution: Kubuntu 8.04
Posts: 72

Rep: Reputation: 15
Guide to Sound System Troubleshooting

I've run into the same problem, and the previous poster's suggestions will probably do the trick if your hardware was working before. If not, check out the following guide:

http://ubuntuforums.org/showthread.php?t=205449

It will walk you through the process of checking your hardware, kernel modules, settings, etc.
 
Old 06-15-2008, 01:41 PM   #4
Sjonnie48
Member
 
Registered: Jun 2005
Location: Earth
Distribution: Ubuntu10.04
Posts: 308

Original Poster
Rep: Reputation: 43
What a nice interface! Thanks for the help, I've got my sound working again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Stopped Working on Kubuntu 8.04 TheWrldCanWait Linux - Software 1 04-30-2008 08:52 AM
CUPS : printers stoped working after a system upgrade fourat Linux - Software 8 08-01-2006 03:35 PM
Sound not working on Ubuntu version 5.4 Zealeris Linux - Hardware 2 06-02-2006 01:46 PM
Mouse stopped working after system upgrade driptray Linux - General 3 08-21-2004 04:00 AM
Sound not working after kernel upgrade krimson Linux - Software 14 07-09-2004 11:38 AM


All times are GMT -5. The time now is 10:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration