-   Ubuntu (
-   -   Kubuntu kernel upgrade to 2.6.24-23-generic mangles RAID disk partitions (

leibniz 02-09-2009 01:06 PM

Kubuntu kernel upgrade to 2.6.24-23-generic mangles RAID disk partitions
Hello all:

Tried searching and didn't find any similar problem/solution to apply, so I will ask here if anyone has experienced a similar problem to the following:

Have been running Kubuntu for a few years without any major problem, till now. Recently allowed system to update all, including kernel update, and now my system won't even boot the desktop on the new kernel, and the install has also corrupted my RAID disk partitions. (Booting off the older kernel still works fine.)

Athlon 64 X2 - 2G RAM,
Kubuntu 8.04.1
4 SATA drives: 2 simple, standard ext3 raw partitions for system (unaffected by update) and 2 x 1.5TB drives (sdc and sdd) each were partitioned with 3 type fs partitions (Linux raid auto detect)

What happened?
I allowed the system to update all. Used adept GUI manager. Included in the updates was kernel 2.6.24-23-generic (from 24-21)

The adept manager finished the installs, but before it said it was complete and returned to it's main window, it crashed.

Since it was finished installing the updates, I guessed that it was complete configuring them as well. Apparently not so.

Anyway, now when I boot, the desktop tries twice then fails to load, leaving me at the console login.

That's not too critical in and of itself - however it also mangled [only] my RAID partitions on my extra drives.

/dev/sdc and /dev/sdd were configured as RAID 1 (mirror) and each had three partitions. They were working just fine, configured as 'linux raid auto detect' type, and then a Volume Group was created on top of them. VG was fine, had lots of files in numerous LVs, and all was good.

Not now. After the attempted kernel update, sdc and sdd seemed to have simply 'lost their partitions'.

I wanted to see if the drive was toast, so I recreated a partiton on sdc, and it worked fine. sdd was not touched since the incident, and it shows this:


root@X2:/etc# fdisk -l /dev/sdd

Disk /dev/sdd: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/sdd doesn't contain a valid partition table


Can anyone point me to specific info about this kernel update - i.e. if this is a known bug or if there is a workaround? I can [and will for now] simply not use the most recent kernel, but I would like to solve this first if possible before I re-create my environment.

Is there any way to recover the RAID partition and VG ? I've done some searching and this seems to be possible, but I have yet to find something that will un-delete a linux raid partiton on a hard disk.

Thanks in advance for all assistance.


All times are GMT -5. The time now is 05:17 PM.