-   Ubuntu (
-   -   Kubuntu doesnt load desktop (

Mark_667 04-16-2006 10:35 AM

Kubuntu doesnt load desktop
I just installed Kubuntu (AMD-64) for the first time, the install went fine but after the screen with the progress bar completes it drops to a text-only view with the processes scrolling up the screen. After that I get a shell login. After login I get dropped to a command prompt and no desktop or GUI. This also happens on the LIVE CDs. Am I missing something here?

Please help,

aysiu 04-16-2006 11:10 AM

I'm not sure what happened, but you should try these commands, in this order.

sudo dpkg-reconfigure xserver-xorg
sudo apt-get update && sudo apt-get install kubuntu-desktop
sudo /etc/init.d/kdm restart

FewClues 04-17-2006 12:48 AM


Originally Posted by Mark_667
I just installed Kubuntu (AMD-64) for the first time, the install went fine but after the screen with the progress bar completes it drops to a text-only view with the processes scrolling up the screen. After that I get a shell login. After login I get dropped to a command prompt and no desktop or GUI. This also happens on the LIVE CDs. Am I missing something here?

Please help,


Your LCD display has snowed the installer. When you get to the point where KUbuntu goes blank, press CTRL+ALT+F2 (or f3,f4,f4) to switch to a terminal in the non-graphic mode {oh oh - the command line] and log in as "root" and reset the graphics to flat panel (generic) and then select VESA driver. Select the lowest frequency offered (60 usually) Save the settings and exit.

Reboot and keep your fingers crossed.

Good luck!


DarkIye 04-17-2006 03:54 AM

I had some similar problems before myself - this thread should help you out:

ht tp://

Granted, it's Gnome instead of KDE here, but the problem's basically the same. Eventually, you'll end up changing a driver somewhere to 'vesa' before being able to upgrade properly.

smileybwoy 04-17-2006 05:24 AM

that guys problem
umm... hi, i dunno if this works only on slackware/ slax - knoppix - debian - redhat... but w.e its worth a try isnt it i suppose, i used ubuntu before and hated it, too hard to use :D but listen up

if it goes blank straight after the text is gone (like you know the start up sequence where it configures all that... stuff :-\ ) and your monitor sort of goes on stand by (dunno the technical term but the power button goes orange and u sit there like wtf!? chances are youve passed the ouput range on your monitor coz its not configured properly, you need to download the driver for your graphics card and install that at the command line

(forgot how... maybe alt+F3, ctrl+F3... i mainly use linux to download and go on dodgy sites that are filled with malware, spyware, trojans coz hey, its linux, not like they can do it any damage right? right! :P most malware are built for wind0w$, guess thats the downfall of a crappy mainstream operating system... oh well :D)

anyway when youve installed that set it as the default driver and your all good (instructions usually come with the driver package you download), should work, if it doesent try making xwindow configure itself, right after you are able to access a shell (log in as root or w.e) type "xconf" and it should auto-configure your graphics hardware, then type "startx" and it should work fine, (it will prob set itself to the highest res possible so prepare for squinting) i know nothing beyond what ive just said, infact if you google "smileybwoy" i had the same problem years ago with redhat, the links like 2nd from the top, see that :D

hope it helps

Smileybwoy ;)

Mark_667 04-17-2006 07:38 AM

aysiu: thanks for the ideas but they didn't work the second one for example gave:

kubuntu-desktop is already the newest version
FewClues: I have a CRT monitor DarkIye I thin you're making the same mistake. My screen doesn't go blank it just stays there,

although I can get a terminal and login using CTRL+ALT+F1, F2 ... etc.

I did a search before posting but only found this thread after I posted and looked at the 'Similar Threads' section at the

bottom of the page where I found:
Thinking it might have been sorted out in a later version of whatever is causing it I did:

sudo apt-get dist-upgrade
which gave me a slightly newer kernel but still the same problem. Trying aysiu's commands again gave slightly different error

messages. Then I found this:
which is exactly what I'm getting except I'm using a desktop system! This thread:
links to a post which tells you how to recompile the kernel (yikes!) - they recommend method 2. Not knowing anything about

how to compile a kernel from a command line I got stuck on some steps - namely removing and purging allthe nvidia stuff and I

had to miss out steps because I couldn't figure it out and it didn't work so I gave up. Too complicated. So I tried the (much

shorter and simpler) method described in the post - or I would have if I hadn't have got a kernel panic:

run-init: /sbin/init: No such file or directory
[ 28.535717] kernel panic - no syncing: attempted to kill init:
[ 28.535732]

Given all this I done a clean install of Ubuntu so if I could get it working I could add on KDE after. Unfortunately, right

after everything had configured after restart I got:

X Window Server failed to load
X server is now disabled

Typing XInit gave unresolved symbol errors and signal caught 11 and XIO fatal error 104. The same bug I got when I tried it

the first time.

It seems to be that XServer is misconfigured, although I don't know how to reconfigure it in order to try and correct it.

sudo dpkg-reconfigure Xserver-xorg
just returned me to a prompt. I think we're starting to get to the bottom of


milanc 04-18-2006 03:19 AM

Try this
I'm not sure, and i can't test this, but it might be a problem with the input devices (especially the mouse):
# dpkg-reconfigure xserver-xorg
Don't let the setup choose the graphics card automatically
Choose the VESA card driver if the kernel doesn't have the right module
Configure everything according to your hardware (& disable framebuffer)
When you get to mouse configuration: choose /dev/psaux , protocol: auto

Good luck!

jl426 04-18-2006 08:32 AM

I had pc_linux_os and it crashed and burned.So i am trying to install Ubuntu. I also cannot get Ubuntu to go to desktop, as a matter of fact I can't even get past the login stage. After boot, i get a text only screen asking to login, so i type in the user but when i get to password it wont allow to put in anything. I'm actually curious why i get this screen, like windows dos mode. I am a casual user at best and dont understand allot of what is going on. Seems to be allot of problems with this linux stuff. I never had problems like this with Microsoft. Did i do the wrong thing by going to linux instead of back to windows? Someone please help. I have not been able to use my computer now for 2 weeks. I appreciate any help given. Thank you in advance!!!!!!

Mark_667 04-18-2006 11:05 AM

milanc: I already tried that command but it just returnedme to the command prompt. I can boot from a Knoppix disk can I alter the settings from there at all?

jl426 04-18-2006 12:53 PM

After boot it asks for:

user login:

I enter login name, hit enter than I get
but it does not allow me to enter a password, cursor does not move.

What do I do? This is getting very frustrating. I have been stuck in this same mode it seems forever and cannot figure out how to make this thing work.

BluesKaj 04-18-2006 02:12 PM

I'm in the same position as Mark667.AMD64 machines won't run Ubuntu distros despite the advertized fixes at the Ubuntu support site. The Xserver fails at the startx command, after going thru all the trouble of installation. No one so far has come up with a solution that I can find. If I find something that works I'll post it , but in the meantime I'm settling for Fedora Core 4 as my Linux fix. Good Luck to all with AMD 64s trying Ubuntu!

Mark_667 04-20-2006 10:03 AM

The startx bug seems to have been quite widely reported, although as we've seen the work-arounds don't always work. So thinking it may have been fixed in a later release, I downloaded Dapper Drake (i386 install CD) - I do not believe it to be a problem, as Blueskaj suggests with the architecture as I have tried a live i386 breezy CD and got the same problems mentioned above. Anyway when I tried Dapper I got a nice GUI login screen and no mention of Xserver or startx. Maybe others can try this - although be warned it's still under development.

BluesKaj 04-21-2006 11:45 AM

OK folks the startx command bug seems to be solved with the new Kubuntu Dapper Flight 6 offering. I DL'd the ISO install file and everything went quite smoothly with this distro installation. Being a newbie to a lot of Linux distros I find the Adept install utility somewhat lacking in terms of clear explanations of what different program packages actually do.There are a lot of rpms that don't work with Flight 6 but it's still nicer to use than FC4. AMD64 users with ATI onboard graphics will prolly have to reset the screen resolution in the system settings/ hardware/Monitor/configure , since the default is set at a very large 640x480 screen. I'm enjoying it so far but my frustration level with Linux increases directly with the length of time I use it :)
Good Luck to all with this one !

BluesKaj 04-29-2006 04:46 PM

Kubuntu (flight6) failed me again. After reinstalling the proper monitor drivers and configuring a decent screen resolution, everything seemed to be working and looking good. Oops, I spoke too soon. Upon booting up the next morning the fonts on everything on the screen were totally unreadable, and I mean everything: Thunderbird , Firefox, the desktop,...everything. Since I had tried reinstalling twice before with similar results I realized that Kubuntu flight 6 on an AMD 64 machine was too restrictive in it's graphics options (default screen reolution is a huge 640x480 on my monitor)I've given up on it til the distro is more mature.
Suse 10.0 64bit eval is now my latest struggle with linux and I'm having more luck with it than any other distro so far.

Penguin of Wonder 05-01-2006 12:29 AM

BluesKaj, have you tried Gentoo on your AMD64 machine? I use it on mine and I have no problems with it outside of the ones I create. With Gentoo have you complete freedom too, something you complained about with Ubuntu. If your a true newbie and not just one because you only have 4 posts, it'll be an excellent learning experience.

All times are GMT -5. The time now is 03:09 AM.