LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 08-27-2006, 11:18 AM   #1
broxtor
Member
 
Registered: Jul 2003
Location: The Netherlands
Distribution: Linux Mint 19.1
Posts: 99

Rep: Reputation: 16
Kubuntu and default applications


Hi,

I have tried in Kubuntu Dapper to set some default applications for various file extensions. I've done this from Konqueror. For some reason Kubuntu does remember my settings, but does not use them. E.g. I told kubuntu to play mpg files with mplayer. When I look up the settings for that, they seem fine. But when I click on a mpg file, it opens with Kaffeine.
The same thing goes for my default browser (firefox) and mail program (thunderbird). I have these defaults through the system settings thingy. They both get registered ok, but it doesn't work.
Does anyone know how to correct this?
 
Old 08-27-2006, 12:13 PM   #2
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,775

Rep: Reputation: 86
Have you tried using Open With > Other > Remember application association for this type of file?

Also, you might want to make sure you own the KDE settings directory:
Code:
sudo chown -R broxtor:broxtor /home/broxtor/.kde
 
Old 08-27-2006, 12:25 PM   #3
broxtor
Member
 
Registered: Jul 2003
Location: The Netherlands
Distribution: Linux Mint 19.1
Posts: 99

Original Poster
Rep: Reputation: 16
I tried both of those, but unfortunately it didn't work.
 
Old 08-27-2006, 06:15 PM   #4
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,775

Rep: Reputation: 86
If you create a new user, do that new user's settings stick?
 
Old 08-28-2006, 12:31 PM   #5
broxtor
Member
 
Registered: Jul 2003
Location: The Netherlands
Distribution: Linux Mint 19.1
Posts: 99

Original Poster
Rep: Reputation: 16
I have just tested this. When I create a new user everything works as it should. So what's the difference between the account I created when I installed Kubuntu and the one I added a few moments ago?
 
Old 08-28-2006, 01:05 PM   #6
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,775

Rep: Reputation: 86
Quote:
Originally Posted by broxtor
I have just tested this. When I create a new user everything works as it should. So what's the difference between the account I created when I installed Kubuntu and the one I added a few moments ago?
I don't know. Something happened to your settings in ~/.kde, I would guess.
 
Old 08-29-2006, 10:29 AM   #7
broxtor
Member
 
Registered: Jul 2003
Location: The Netherlands
Distribution: Linux Mint 19.1
Posts: 99

Original Poster
Rep: Reputation: 16
It gets a little more complicated now. I did some additional tests:
I created to links on my desktop. One with an internet address, the other with a mailto: adress. When I click the internet address it opens in Firefox, which is good. When I click the mailto link it opens a new message in Thunderbird, which is also good.
But when I click on an url in an email message in Thunderbird, the page opens in Konqueror, which it shouldn't do. Also when I try to open my hotmail inbox from Kopete, it's also opened in Konqueror.
I really don't get it......
 
Old 08-29-2006, 12:36 PM   #8
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
try the command
Code:
sudo update-alternatives --config x-www-browser
and choose firefox
 
Old 08-29-2006, 01:32 PM   #9
broxtor
Member
 
Registered: Jul 2003
Location: The Netherlands
Distribution: Linux Mint 19.1
Posts: 99

Original Poster
Rep: Reputation: 16
Well, it helped a little. Links from thunderbird are now opening in Firefox. But Kopete still tries to open hotmail in Konqueror. Could it be that that is hardcoded in Kopete?
 
Old 01-14-2007, 01:25 AM   #10
wild_willy
LQ Newbie
 
Registered: Jan 2007
Location: Halifax, NS Canada
Distribution: Kubuntu 11.10
Posts: 5

Rep: Reputation: 0
I was looking to solve the same problem in that Kopete would try to open Hotmail in Konqueror. I found the solution thanks to thanks to XstatyK over in the Kubuntu Forum.

Do the following:

In KDE control center, go to File Browsing, File Associations. Under known types choose text, then choose html. In the Application Preference Order move the browser you want to the top of the list.

It worked for me!!
Wild Willy
 
Old 01-14-2007, 03:07 AM   #11
broxtor
Member
 
Registered: Jul 2003
Location: The Netherlands
Distribution: Linux Mint 19.1
Posts: 99

Original Poster
Rep: Reputation: 16
Thank you very much! That did the trick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XFCE: set default applications to extensions senorsnor Linux - Software 4 08-24-2011 07:03 PM
Setting default applications in GNOME smiley_lauf Ubuntu 9 02-25-2006 02:12 PM
default Menu Font inconsistent in Kubuntu evilsmevil Linux - Software 3 02-19-2006 07:30 AM
using default applications from java? german Programming 2 06-21-2005 11:26 PM
Multiple desktops and default applications Andramalech Linux - Newbie 8 12-07-2004 11:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 02:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration