-   Ubuntu (
-   -   Kubuntu 6.10 Adept Manager Broken (

HeLLWiZerD 12-31-2006 12:06 PM

Kubuntu 6.10 Adept Manager Broken
I was installing the java runtime environment through adept manager, and it was 30% through the installation process when it stopped, and remained at 30% for 6 hours. In an effort to fix it, i clicked "show details" and discovered that it was waiting for user input, i tried a bunch of different things to ultimately say "ok", but whatever i did ended up botching the install.

I figured.. "ok, no big deal, I'll just restart and re-install", but this was not to be, now whenever i open adept manager, i get the following error:

"You will not be able to change your system settings in any way (install, remove or upgrade software), because another process is using the packaging system database (probably some other Adept application or apt-get or aptitude). Please close the other application before using this one"

I restarted a dozen times, tried to find some sort of process manager, but came up empty handed. I went into the system services thingy and started the killproc service, this restarted my computer but did not fix the adept manager. My only guess (now bare in mind i'm a windows guru, but still learning linux), is that something is running in the background, constantly trying to install jre, and waiting on input, but i just have no way of seeing it. Or one of the 10-ish packages comprising the jre was only partially installed, which somehow made the oem java stop working, which is somehow affecting adept manager.

My install still performs every other function as it should, but as of right now i can't install anything (unless i compile from source, which is fine, but large packages with 80 library dependencies could take a week to collect and install individually). does anyone know of a way to fix this??


Kalummm 01-14-2007 03:04 AM

Kubuntu 6.10 Adept Manager Broken
I have excactly the same problem. Can anybody help us?
Thank you.

xjlittle 01-14-2007 05:44 PM

Could you run

dpkg --audit
It searches for packages that are partially installed and makes suggestions on what to do with them. Maybe that will lead you where to go.

binary_y2k2 01-15-2007 04:24 AM

Yep, you can't install the Java packages with Adept, you'll have to do it from Konsole.
First you need to make sure Adept hasn't locked the database

sudo fuser -vik /var/lib/dpkg/lock
If it is, then kill the process using it. Then you need to start where Adept left off

sudo dpkg --configure -a
You'll be able to accept the licence there. After you have don't that other Java packages shouldn't ask you to accept the licence, but just in case I always use Konsole to install it

sudo apt-get install sun-java5-jre

Drue 02-16-2007 12:10 AM

Thanx a lot! I had the same problem with Adept manager and another broken app install and this tip solved it.

pingivishal 02-21-2007 10:50 PM

Thanks a ton !
it helped me too :)

manducasexta 03-12-2007 05:40 PM

fantastically helpful!
Thanks for asking and answering the questions. I subsequently ran into another problem, where I couldn't figure out how to accept the Java license. Just in case it will help any other folks out there, here's how: tab to highlight "OK" and then press Enter. I could kick myself now.

All times are GMT -5. The time now is 12:56 PM.