-   Ubuntu (
-   -   Kernel panic-not syncing:No init found. Try passing init=option to kernel (

cucolin@ 12-25-2008 06:40 PM

Kernel panic-not syncing:No init found. Try passing init=option to kernel
the other day i just came back to turn on my pc and i got the error message above while booting the machine. I noticed a few days ago the system was freezing and i had to manually restart it. i tried using a knoppix CD to boot from memory which makes me think is a memory problem. i also tried this: with no luck.

i'm trying to reinstall everything and i also get the same error message while trying to install ubuntu from the CD.

stress_junkie 12-25-2008 07:32 PM

If the disk has nothing important on it you might try shredding it.

shred /dev/sda
Shred takes about 24 hours on a 320 GB disk. The first pass is the longest because it is generating random numbers for each location on the disk. It usually takes about 12 hours. The last 24 passes in total take about as long as the first pass by itself. That is because shred is writing one value on each pass to all of the locations on the disk.

Your problem does have the earmarks of a hardware problem but sometimes these things are resolved easier than you might expect. Many times I've mistaken a very small "software" problem such as the wrong value in the MBR as a hardware problem. That is usually because the utilities to manage hardware devices make the same mistake.

cucolin@ 12-25-2008 09:26 PM

thanks, but how can i do this if i'm not able to get a terminal? i just turn on the machine and is idle at:
Starting up......
i don't see a way to follow your steps....thanks again...

jschiwal 12-25-2008 09:32 PM

Since you can't boot up with a live distro, it sounds like a hardware problem.

Do you not get to the post screen? Try unplugging external usb drives and SD disks. It may also be time to open up the case and clean out the dust bunnies. Be sure to clean out dust from the power supply. While there, make sure all of your IDE/SATA cables are snug.

Then if you get a post screen, enter the bios. Is the time OK? Are the drives detected?

cucolin@ 12-25-2008 10:03 PM

1. yes, i get the post screen.
2. there are NO external usb drives and SD disks.
3. there was some dust bunnies, but nothing in excess.
4. power supply dust - not much.
5. IDE/SATA cables- everything was in place.
6. Time was wrong, i fixed it and still same issue.
7. I decided to change the memory for another pair and IT BOOTED!

It works now.

thanks....jschiwal & stress_junkie!

stress_junkie 12-26-2008 06:44 AM

cucolin@, I'm glad that you had a spare set of memory to use for testing. If you had to purchase a memory set just to see if that was the problem then you might have spent a long time looking for a no-cost solution first.

jschiwal, I love your signature. I have a zero beer limit. It doesn't take much alcohol to saturate my walnut sized brain. :)

All times are GMT -5. The time now is 01:42 PM.