-   Ubuntu (
-   -   JRE on firefox 2 problem (

vcatalano 01-06-2007 03:00 PM

JRE on firefox 2 problem
I have the latest version of JRE on my Ubuntu Edgy box, however, every time I try to run a java applet, firefox2 says that I dont have the correct plugin installed (Java Runtime Environment). Even when I try to load applets on other websites I get the same error. I am sure I have all the correct java programs and utilities I but I cant find out how to get firefox2 to recognize the JRE that is already installed.

Brian1 01-06-2007 03:35 PM

Have you softlinked the java plugin to the firefox plugin directory. If not then you need to do that.


vcatalano 01-06-2007 03:46 PM


Originally Posted by Brian1
Have you softlinked the java plugin to the firefox plugin directory. If not then you need to do that.


How can I do this?

Brian1 01-06-2007 05:21 PM

I cannot give a specific command since not knowing which java was installed and where it was installed. But check out this post on the subject. It is outdated as far as version but should point you to the right location with a little searching on your drive for the plugin file. Then you need to know where the firefox plugin folder is. Again all depends on how it was installed and where.


vcatalano 01-07-2007 11:29 PM

I have tried linking every single file to my /usr/lib/firefox/plugins folder but ever time it DOES NOT RECOGNIZED THE JAVA PLUGIN

I have linked the file from:

...but none of them seem to work. Does anyone have any suggestions?

Brian1 01-08-2007 05:12 PM

Which one is it you need? The one in ns7 is the one you want.

Also if use the ln command to set did you delete the link first or use the -f option to force the over write. ln will not over write an existing link without the -f option. It will not error or complain even if you tried without the -f option. ln -sf <source file> <destination file soft link>

Post command you have been using point from the orginal file to the point where the softlink is placed.


vcatalano 01-09-2007 04:33 AM

I discovered that I could only get the plugin to work by installing it into the single user directory. This was done with the following command line.

sudo ln -s /usr/lib/j2re1.5-sun/plugin/i386/ns7/ /home/[username]/.mozilla/plugins/

Brian1 01-09-2007 04:08 PM

Glad to see you have it going. Normally plugins in /usr/lib/mozilla/plugins works on mozilla and firefox. But some of that depends on they are compiled.


FromFPan2Fire 01-21-2007 06:52 AM

Thanks - Got Java working for me now, too!
Thanks to this post! After too many hours I finally got Java running on my Ubuntu 6.06 / Firefox system. I was specifically trying to load 1.4; and the final step, provided by you'll was:

sudo ln -s /usr/lib/j2se/1.4/jre/plugin/i386/mozilla/ /home/<user>/.mozilla/plugins/

But first I had to manually create the folder plugins under .mozilla


All times are GMT -5. The time now is 01:21 PM.