LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-07-2006, 05:55 PM   #1
Lantius
LQ Newbie
 
Registered: Oct 2005
Posts: 17

Rep: Reputation: 0
intel wireless 3945


hello

i have a toshiba satellite u200 192 and a intel wireless 3945. I need to run wireless conecction but it doesn't work. I were looking for information and I found a lot

http://ipw3945.sourceforge.net/

intel created a driver for it.

In ubuntu 6.10 this driver is showed when you use

ps -A | grep ipw3945

So i thought so that it is installed.

i tried to install "ieee80211 subsystem" but it had installed, .
i put find /lib/mdules/uname-r -name 2ieee80211*" and it return some of them :
/lib/module/2.6.17-10generic/kenerl/net/ieee80211/ieee80211_crypt_tkip.ko

But wireless connection DOESN'T WORK

why? i don't know

what should i do to get to work it ?

thanks for your help

bye !
 
Old 12-10-2006, 06:53 AM   #2
calidris
LQ Newbie
 
Registered: Jan 2006
Distribution: ubuntu dapper drake
Posts: 6

Rep: Reputation: 0
wireless and linux

One advise; if you won't spend ALOT of time on 'configuring your pc', just forget about linux and wireless! I've tried to go wireless with my dapper drake (and feisty fawn) several times, without success. There just aren't no simple answers to the problem, as you can see when you google or search at wireless vs linux topics.

Actually, the big problem with unix distros, as I see it, is that it's far too complicated to get a wireless card in linux up and go.

read this, it makes thing 'clear':

http://ubuntuforums.org/showthread.php?t=272813
 
Old 12-10-2006, 06:58 PM   #3
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
By default your active network port is set to eth0. Although the device name varies your wireless port may be eth1. Assuming Gnome, do System-> Administration-> Networking and you should see how to select and configure active network ports. I'd also recommend installing wifi-radar which will help you manage available wireless connections.
 
Old 12-11-2006, 07:55 AM   #4
Lantius
LQ Newbie
 
Registered: Oct 2005
Posts: 17

Original Poster
Rep: Reputation: 0
One problem is that there is driver for this connection, so I don't want to use ndiswrapper

I found a lot of information about that, but it's very confused and there aren't solutions.

Well, If anyone doesn't know how to configure it , I'll have to use windows.

Greetings.
 
Old 12-11-2006, 12:00 PM   #5
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Have you tried any of the following commands and what do they say:

ifconfig
iwconfig
iwlist
iwspy
 
Old 12-11-2006, 04:38 PM   #6
Lantius
LQ Newbie
 
Registered: Oct 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by fragos
Have you tried any of the following commands and what do they say:

ifconfig
iwconfig
iwlist
iwspy
ifconfig :

ifconfig
eth0 Link encap:Ethernet HWaddr 00:15:B7:E8:0C:58
inet addr:192.168.0.127 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::215:b7ff:fee8:c58/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1581 errors:0 dropped:0 overruns:0 frame:0
TX packets:1687 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1102816 (1.0 MiB) TX bytes:237486 (231.9 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

root@fulgor:/home/xenon# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

root@fulgor:/home/xenon# iwlist
Usage: iwlist [interface] scanning
[interface] frequency
[interface] channel
[interface] bitrate
[interface] rate
[interface] encryption
[interface] key
[interface] power
[interface] txpower
[interface] retry
[interface] ap
[interface] accesspoints
[interface] peers
[interface] event
root@fulgor:/home/xenon# iwspy
lo Interface doesn't support wireless statistic collection

eth0 Interface doesn't support wireless statistic collection

sit0 Interface doesn't support wireless statistic collection

root@fulgor:/home/xenon#



----------------------------------------------------------------

It seem that I have no one wireless connection, but i have one. When I just installed ubuntu the ipw3945 procces was active and it run in the boot. But it happened the same.

Now I don't have any 3945 procces because I were trying to get working that.

I found a lot of information, i found a program that should configure it easyful its name is wireless installer. i found it in ubuntuforums.org, i can't link it because i dont have the direction and I couldn't find it. If you search en linuxquestion.org or ubuntu.org 3945 you'll find a lot of information about de problem, but no one is clear, evident. I read a lot of people who say that it is more easy to install wireless connection on ubuntu 6.06, but my notebook can't end the installation it always stop before that it has finished, and no, it isn't the cd, i have installed ubuntu 6.06 on other computers with that cd.

greetings and thankss !
 
Old 12-13-2006, 03:36 PM   #7
Redbone981sl
Member
 
Registered: Jul 2003
Posts: 73

Rep: Reputation: 15
wireless

I know that wireless has been hard in the past but I just installed ubuntu (edgy) on my laptop and all I had to do to get it working was to go to _system -administration -network and activate the wireless card by putting a x in the box for that card. I thougt it would be the hardest part of the setup but it turned out to be the easyist.
 
Old 12-13-2006, 03:46 PM   #8
Lantius
LQ Newbie
 
Registered: Oct 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Redbone981sl
I know that wireless has been hard in the past but I just installed ubuntu (edgy) on my laptop and all I had to do to get it working was to go to _system -administration -network and activate the wireless card by putting a x in the box for that card. I thougt it would be the hardest part of the setup but it turned out to be the easyist.
The problem is that in -system-administration-network- there isn't any wireless'option only there is two option, one for modem and one for wired connection. Because ubuntu 6.10 doesn't get my card.

Well, I will be trying to get it work in my free time.
 
Old 12-13-2006, 04:52 PM   #9
DHatherley
LQ Newbie
 
Registered: Dec 2006
Location: Manchester, UK
Distribution: Kubuntu Edgy (6.10)
Posts: 2

Rep: Reputation: 0
Hi Lantius,

The output of your ifconfig does not show a wireless network controller. It could be that your wireless controller doesn't work (I thin this is very unlikely), that your laptop has the wireless switch turned off, or that there was a problem during boot when the kernel tries to discover what devices are in the system and load the appropriate drivers.

My Lenovo laptop has a switch on the front that lets me switch on and off the wireless connectivity. Perhaps your Toshiba has one also, which you may have accidentally switched. (Sorry, I don't mean to cause offence by mentioning such simple problems, but it's usually simple stuff like this that causes me problems).

If it's not this you can try to find out where the problem is by using the lspci, lsmod and dmesg commands.

lspci shows all devices that are attached to the PCI bus (even if it's an internal on-chip device, it will almost certainly be using the PCI bus). Type lspci and if you can see an entry that says something like Intel Corporation PRO/Wireless 3945ABG Network Connection, then linux has discovered the wireless controller.

If lspci shows that linux has found the wireless controller, lsmod will help you find out whether the kernel module (i.e. the driver) was loaded for the wireless controller. Type lsmod | grep 3945 and see if the output shows something like:

Code:
ipw3945      124576  1
ieee80211     35272  1 ipw3945
If you see these lines, you should also see an ethN (where N is a number) for your wireless controller when you run ifconfig. The fact that you don't is beyond my knowledge, but might have something to do with udev not setting up the device properly.

If you don't see those lines from lsmod but lspci showed the Intel PRO/Wireless device, then there was a problem loading the driver for the controller. If you don't see the lines from lsmod and lspci did not show the Intel PRO/Wireless device, then linux is unable to see the device on the PCI bus. In both of these cases, looking at the output from the dmesg command (which can be quite a lot and quite confusing) might give you some idea as to exactly what the problem is.

I installed Kubuntu on my lenovo laptop with the intel 3945 chipset and it worked right away. I realise this is no help to you at all, but it says that the chipset does work with Linux so you should be able to get it working for you.
 
Old 12-13-2006, 05:55 PM   #10
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
This may not be your problem but here it is anyway. When I set up my first WiFi I tried the Gnome Network Manager which is intended to provide a list of available connections and help to configure for each access point. I had poor luck with it and tried WiFi-radar without first removing the pieces of the gnome-network-manager. The two managers interfered with each other resulting in no available connections. When I striped out gnome-network-manager and disabled a process "nm-gnome" I believe, Wifi-radar worked like a champ. I bring this up because in trying to make WiFi work you may have created the same problem for yourself. Definitely use the Network Monitor applet as it shows you signal strength when your active network is wireless.
 
Old 12-15-2006, 02:37 AM   #11
walkerd
LQ Newbie
 
Registered: Dec 2006
Posts: 7

Rep: Reputation: 0
Smile How did you intall it?

I am using the card without problems. Did you follow the installation procedure in the INSTALL file from sourceforge? Or are you trying to use Ubuntu clicking?

I used the first way and it is working.
 
Old 12-19-2006, 09:45 AM   #12
Lantius
LQ Newbie
 
Registered: Oct 2005
Posts: 17

Original Poster
Rep: Reputation: 0
hello,

I got it work.

I only format my computer and installed again ubuntu but, the last time I used ubuntu-alternative to install , and this time i used ubuntu installation with live cd , and a menu graphic, etc. And once time that I have finished ubuntu has identified my wireless card and that appears in network manager, so I only download wifi radar with an ethernet wire to download it and connect to my wireless network.

So if your ubuntu doesn't get your wireless, install it without alternative mode. It is strange but it is true.

Now I have others little problems which I will post in other threat.

THanks a lot for your help.

Bye.
 
Old 12-19-2006, 01:32 PM   #13
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Lantius -- Good for you. I think there's a good lesson here. We all want to be proficient with the command line but you using the GUI helps to insure a successful outcome.
 
Old 04-09-2009, 02:12 AM   #14
eventure
LQ Newbie
 
Registered: Apr 2009
Location: mauritius
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by Lantius View Post
hello,

I got it work.

I only format my computer and installed again ubuntu but, the last time I used ubuntu-alternative to install , and this time i used ubuntu installation with live cd , and a menu graphic, etc. And once time that I have finished ubuntu has identified my wireless card and that appears in network manager, so I only download wifi radar with an ethernet wire to download it and connect to my wireless network.

So if your ubuntu doesn't get your wireless, install it without alternative mode. It is strange but it is true.

Now I have others little problems which I will post in other threat.

THanks a lot for your help.

Bye.
Hi,

is there any possibility tonot reinstall Ubuntu but enable the wireless 3945 ?
I have a tosh P200 and run Ubuntu 8.10
thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Pro/Wireless 3945 mwarbeck SUSE / openSUSE 19 03-28-2007 08:38 PM
Problem for Intel pro wireless 3945 hcccc Linux - Laptop and Netbook 3 09-15-2006 06:30 AM
Need Help - Intel 3945 Wireless vishallagdev Linux - Wireless Networking 1 07-06-2006 02:34 AM
Intel PRO/Wireless 3945 Gentoo chrismiceli Linux - Wireless Networking 1 06-06-2006 07:10 AM
Intel 3945 Wireless Help - FC5 jonwatson Linux - Wireless Networking 1 05-18-2006 07:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration