-   Ubuntu (
-   -   Installing [K]ubuntu 8.04 - Kernel panic, not syncing (Unable to mount root fs) error (

TerranRich 06-13-2008 09:17 PM

Installing [K]ubuntu 8.04 - Kernel panic, not syncing (Unable to mount root fs) error
Hey all, Linux newbie here. Windows defector, and all...

So whether I'm installing Ubuntu 8.04 or Kubuntu 8.40, I get the same problems. If I just try to run the Live CD, or if I try to install [K]ubuntu, it halts with the following errors, every time:

ACPI: EC: acpi_ec_wait timeout, status = 0, expect_error = 1
ACPI: EC: read timeout, command = 128

If I press F6 and manually enter in "noapic nolapic" like the Help menu suggests, it gives the following error:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block(104,1)

I wrote it down correctly. Both ISOs do it. The Ubuntu is the Live CD obtained from, and Kubuntu is a downloaded ISO burned to a CD. I downloaded the ISO several times, and burned each several times, and still the same error.

Please be gentle and keep in mind that I'm new to all this. What can I do to help make it work? I have an Intel T2250 1.73GHz CPU with 1 GB of RAM, with Windows XP installed. I was hoping to format the hard drive with the Live CD before installing [K]ubuntu (I'm assuming that's possible), but if there is another easier way, by all means, let me know.


markliner 06-14-2008 11:25 AM

I also had problems installing Kubuntu. After some research I found that it was recommended to use an external partition editing program first. The procedure used is as follows:
I downloaded and burned a CD with Gnome Partition Editor that is bootable.
I assigned a partition with about 20 GB and formatted it with ext3 format.
I did a fresh install of Kubuntu and everything seems to be working fine now.

The install was done on an older PC, Compaq Presario 5000, with an 80GB hard drive.
I originally started with winXPPro, then added Vista Business, and added Kubuntu.
Yes that's right, a triple booted system. I just enjoy playing with this stuff to see if it is even possible.

the trick seemed to be getting the hard drive partitioned before hand.

I hope this helps. Good luck!

TerranRich 06-15-2008 11:33 AM

Thank you very much for your reply!

I would like to make my entire hard drive one partition with Ubuntu installed on it. I will try to make the hard drive one entire partition with the Gnome Partition Editor and format with the ext3 format. I'll let you know how it goes. Thanks again!

TerranRich 06-15-2008 04:16 PM

Okay, so the only way I was able to install Ubuntu was to press F6 during the Live CD boot menu and get rid of the last few options, then add generic.all_generic_ide=1, then noapic nolapic so that it read:

file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.gz generic.all_generic_ide=1 noapic nolapic

Then, it worked just fine, installed it on a brand new partition, and all seemed to be going well, until I tried to boot up my laptop normally and without the CD. All I get now is:

GRUB Loading stage1.5.

GRUB loading, please wait...
Error 15

And that's it. The system just halts and all I can do it boot up the Live CD or re-install it, both using the command parameters described above. I even tried the "Boot from hard disk" option on the Live CD menu, but even with the command parameters above, it still shows me "Error 15".

What does Error 15 and how do I fix/get around it?

markliner 06-16-2008 11:57 AM

Sorry to hear you are still having problems, I am also a linux newbee.

I did a little research and found a link on LQ that may help:

I believe linux needs at least two partitions, they should be / or "root", and swap.

I also made a mistake on my last post, I believe I used ext2 initially and then Kubuntu installer changed it to ext3.

At this point I am wondering if you have a good copy of the live CD.

I would try repartitioning the whole drive into one partition and formating it in ext2, then give your install CD one more try. The install procedure should allocate the partitions that it needs. Just accept the defaults and allow the install to run its course.

If this doesn't work I think you may need some "senior" help.


TerranRich 06-16-2008 11:11 PM

I figured out what was wrong! My Grub error meant I just had to re-install Ubuntu, and it worked perfectly. I also narrowed it all down to the "quick splash" part of the grub boot parameters. Once I got rid of that (and added generic.all_generic_ide=1 noapic nolapic) everything worked fine.

I even found a great tutorial ( that shows how to make grub boot parameters stick.

I am slowly learning my way around Ubuntu and Linux in general. This is a great learning experience, and I hope my solution helps others.

All times are GMT -5. The time now is 07:18 PM.