LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   "Installed" Ubuntu 10.10 server on Ubuntu 10.10 desktop. How to get desktop v. back? (https://www.linuxquestions.org/questions/ubuntu-63/installed-ubuntu-10-10-server-on-ubuntu-10-10-desktop-how-to-get-desktop-v-back-898242/)

nax123 08-19-2011 03:40 AM

"Installed" Ubuntu 10.10 server on Ubuntu 10.10 desktop. How to get desktop v. back?
 
Hey guys, i've been using the ubuntu10.10 desktop version (mostly web browsing and few other stuff..just wanted to feel the difference from Windows). Installed it on my S41 BenQ notebook over a year ago and it worked fine. I'm now using the harddisk as and external disk. Ubuntu could still function when running from the external disk on other computers.
My problem is this :
I THINK I must have accidentally installed/put the 10.10 server files into the harddisk when I meant to put it in another partition for a friend. At the moment, every time I try to boot in Ubuntu, it goes straight to some kind of kernel. A co-worker said that its the Ubuntu server look. A quick google didn't reveal any results that's close to my case, so I thought I'd pop in and ask.
Is there a way to get the desktop version back? Or are there any GUI addons that would make the server version function pretty much like the desktop version?(As you'd have noticed by now, I'm very new at using Ubuntu/Linux..so I don't really know what to do with the server version)
If further details are needed, please tell me how to go about getting them as well. Thanks in advance for the help and comments. Looking forward to learning a few interesting stuff on here.

cascade9 08-19-2011 03:47 AM

Sounds like you are booting to command line. Try this-

startx

If that doesnt work, then try installing ubuntu-desktop-

sudo apt-get install ubuntu-dekstop

Installing ubuntu-desktop on top of the server version should get all the standard ubuntu programs, etc. back and make it a normal 10.10 install.

nax123 08-19-2011 05:08 AM

I was just coming to update the thread on what I've done the past few hours. Found a post in ubuntuforum.org (ubuntu 10.10 GUI not loading) suggesting the same commands you've mentioned. Here's the result:

startx gave me something along the lines of "No interface found".

sudo apt-get install ubuntu-desktop gives "latest version already installed"

I might be misquoting the results as I've to keep switching between this notebook's Window XP and the Ubuntu on the ext. harddisk. Do let me know if the exact words are needed.

cascade9 08-19-2011 07:56 AM

"latest version already installed", not cool. I was hoping that you did have the server version, but if ubuntu-desktop is installed you probably didnt install the server version.

I think you probably mean this thread-

http://ubuntuforums.org/showthread.php?t=1646799

If you didnt, its worth trying some of those comamnds that I didnt remember. ;)

nax123 08-21-2011 08:29 PM

Hi. I've been busy this past weekend and was unable to give updates on the situation earlier. Anyways, the issue has been resolved. A friend of mine came over and all he did was restore the system (Windows System Restore) to an earlier date, and that completely fixed the problem. The Ubuntu desktop on the external drive is still working perfectly. I have no idea what the problem was but I guess maybe the server files were installed or existed somewhere in this notebook and thus caused problems when loading the desktop one? Anyways, thank you for your time and comments. Highly appreciated them!


All times are GMT -5. The time now is 12:35 AM.