-   Ubuntu (
-   -   I can't get permission to edit wvdial.conf no matter what I try. Help please. (

XenaneX 03-09-2009 05:39 PM

I can't get permission to edit wvdial.conf no matter what I try. Help please.
I'm using Kubuntu 8.10
For the life of me, I can't edit /etc/wvdial.conf

I tried sudo chown -R /
I tried sudo kate /etc/wvdial.conf
I tried sudo nano /etc/wvdial.conf

I keep getting "/etc/wvdial.conf is owned by uid 1000 should be 0"

I tried "chmod 755 /etc/wvdial.conf"
I tried "chmod 755 /etc/"
I tried "chmod 755 /etc"

Where am I going wrong? Thanks!!!!!!

MikRose 03-10-2009 02:29 AM

Hello, I'm using 8.04 but just found this thread to change permission for an /etc file:

Drag & Drop using "sudo"
This is a trick from the thread on the Ubuntu Forums.
Create a launcher with the following command:
gksudo "gnome-open %u"

* HowToAddaLauncher (I've pasted it here for you just in case.)

Launchers are similar to "shortcuts" in Windows or "aliases" in the Mac OS. Adding a launcher in Ubuntu is easy.
The Easy Way
* Right-click unused space in any panel (the toolbars at top and/or bottom of the screen)
* Choose Add To Panel...
* Choose Custom Application Launcher
* Fill in Name, Command, and Comment
o Name is you want to call the link, such as "Firefox" or "Gaim"
o Command is what you would type in the terminal to launch the program. You can also click the "Browse" button to find the program on your computer. (I copied and pasted gksudo "gnome-open %u" in this space.)
o Comment is for a short explanation of the program. This and the Name will appear when you hover your mouse over the launcher.
* Click the No Icon button to select an icon for your launcher. You may find icons in /usr/share/icons/crystalsvg/16x16/apps/ or elsewhere. You could also make them yourself using GIMP or any other graphic editor.
* Click OK
* Your launcher should now appear on the panel

When you drag and drop any file on this launcher (it's useful to put it on the desktop or on a panel), it will be opened as root with its own associated application. This is helpful especially when you're editing config files owned by root, since they will be opened as read only by default with gedit, etc.

XenaneX 03-11-2009 05:38 AM

Cool, thanks MikRose. This is great. I can't wait to try it out.

kasunbg 03-11-2009 12:51 PM

Can you post the error you get when you are trying to edit it?

mobinskariya 03-12-2009 05:01 AM

why did u try to change the ownership of the file???? its owner should be root by default

XenaneX 03-16-2009 06:24 AM

In trying to get permission to edit wvdial.conf I somehow messed up Ubuntu and have since uninstalled it. I might try again later. Thanks to all who helped.

All times are GMT -5. The time now is 02:33 AM.