-   Ubuntu (
-   -   HP printer scheduler could not execute the backend (

zaphod_es 10-05-2011 07:17 AM

HP printer scheduler could not execute the backend
Ubuntu 10.04 sees the HP Photosmart C4400 and marks it as available. Until recently is worked perfectly. Other than routine upgrades it is a stable system.

When I try to print it gives this message:

"Stopped: /usr/lib/cups/backend/hp does not exist". That is correct,
it does not exist. I created the directory and now see "Stopped: /usr/lib/cups/backend/hp failed"

I found this thread

and resumed the printer. This seemed to work but when I tried to print there was a new message:
"Stopping job becuase the scheduler could not execute the backend."

There are plenty of people receivng this message but they are mostly printing to pdf or having a problem with vmware. I cannot find anything that helps my problem.

Any suggestions? Part of the Cups error log is below.


fse@Desktop:$ tail /var/log/cups/error_log
E [01/Oct/2011:15:20:55 -0300] Unable to execute
/usr/lib/cups/backend/hp: No such file or directory
E [01/Oct/2011:15:20:55 -0300] [Job 172] Stopping job because the
sheduler could not execute the backend.

D [01/Oct/2011:16:08:59 -0300] [Job 175] <job data>
D [01/Oct/2011:16:08:59 -0300] [Job 175]
D [01/Oct/2011:16:08:59 -0300] [Job 175] GPL Ghostscript 8.71:
Unrecoverable error, exit code 1
D [01/Oct/2011:16:08:59 -0300] [Job 175] renderer exited with status 1
D [01/Oct/2011:16:08:59 -0300] [Job 175] Possible error on renderer
command line or PostScript error. Check options.Kid3 exit status: 3
D [01/Oct/2011:16:08:59 -0300] [Job 175] Backend returned status 22 (unknown)
D [01/Oct/2011:16:08:59 -0300] [Job 175] End of messages
D [01/Oct/2011:16:08:59 -0300] [Job 175] printer-state=3(idle)
D [01/Oct/2011:16:08:59 -0300] [Job 175]
printer-state-message="/usr/lib/cups/backend/hp failed"
D [01/Oct/2011:16:08:59 -0300] [Job 175] printer-state-reasons=none

tronayne 10-05-2011 08:23 AM

Do you have HPLIP installed? Did you install the printer with hp-setup?

If you didn't (don't) try installing HPLIP, either from you distribution software library or directly from Hewlett-Packard: There is, I believe, a package for Ubuntu.

HPLIP provides full support for your printer and integrates with CUPS.

Hope this helps some.

zaphod_es 10-05-2011 08:47 AM

Yes, I do have hplip installed. The printer worked fine until recently so something must have changed.

tronayne 10-05-2011 09:51 AM

The only thing I know of that changed is Ghostscript (current version seems to be 9.02) -- there was a problem with second and greater page printing. The current version of HPLIP is 3.11.10; if you're not running that, might be a good idea to upgrade using the software from the H-P web site.

Also, if you look at CUPS (with http://localhost:631) do you by any chance have more than one instance of that printer installed -- sometimes happens, who know why.

All else fails, have you tried deleting the printer and reinstalling it with hp-setup? That message about missing back-end might get "fixed" by a clean install with current software? Ya never know...

Hope this helps some.

zaphod_es 10-05-2011 10:11 AM

Bingo! The reinstall with hp-setup did the trick, thanks.


All times are GMT -5. The time now is 02:06 AM.