LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 07-19-2009, 08:32 AM   #1
siawash
Member
 
Registered: Jun 2004
Location: Ireland
Distribution: Zorin 6
Posts: 589

Rep: Reputation: 32
How to turn firewall


Hello, this is a misleading title, it should how to turn OFF firewall. But how and ever, I noticed unlike the other distros ubuntu has a specific driver for my graphic card PNY nvidia GeForce under gnome system administration.

As soon as I selected that I lost my network connection. I did some trouble shooting and am concluding it has to be software setting to do with ubuntu more than likely some sort of firewall.

I was not able to ping anything. I could not even get my router's browser.

The very act of setting up the graphic must have thrown off the router settings.

I booted into the dual boot windows setup on the same system and WAS able to log into router ( no firewall installed ). True to enough, the router password and username were taken off. Now I can get a network with windows but the ubuntu that is on my hard drive still wont connect.

I can also use ubuntu live dvd to log in to network.

I have checked gnomes system authorizations but have not found anything helpful.

I have setup a static ip in /etc/network/interfaces and name server in /etc/resolv.conf

If this was windows I would reset tcp/ip but don't how this is done in Linux.

Can anyone help?

Last edited by siawash; 07-19-2009 at 09:19 AM. Reason: misleading title
 
Old 07-19-2009, 06:00 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 6, KDE Neon
Posts: 4,313

Rep: Reputation: 212Reputation: 212Reputation: 212
The firewall is iptables the frontend that's used in ubuntu is Firestarter.
 
Old 07-19-2009, 11:38 PM   #3
chigurh8
Member
 
Registered: Jul 2009
Distribution: Ubuntu, Gentoo
Posts: 102

Rep: Reputation: 18
It's not really used by default, it's just in the help and support as an example of what to do download, where it talks about firewalls.
By default, according to their site where I read this, and also my computer, they include ufw as the "standard" sort of Ubuntu firewall - it's included and installed by default, for the last couple/few releases.
Firestarter is not a bad firewall, it does work with iptables. By default, Ubuntu does not set iptables in any way that I'm aware of, unless they did before they started including ufw or something.

Code:
ufw --version
ufw 0.27-0ubuntu2
Copyright (C) 2008-2009 Canonical Ltd.


I've used Firestarter, it seems good ... if you enable ICMP filtering, though, you will be tinkering with things like ping.

Last edited by chigurh8; 07-19-2009 at 11:43 PM.
 
Old 07-20-2009, 12:38 PM   #4
siawash
Member
 
Registered: Jun 2004
Location: Ireland
Distribution: Zorin 6
Posts: 589

Original Poster
Rep: Reputation: 32
Well, it's been a bit of a pain. I rebuilt ubuntu from scratch ( format reinstall ). I set up everything including favorite packages, static LAN and it was fine and dandy for four hours. This morning i fire up my PC and am back to square one. I cannot ping anything including my router. i.e. host unreachable.

I am using my Centos 5 on same system using different hdd.

I will certainly look into ufw --version. Surprised I have not received any other feedback on this. Must be a major pain with the rest of the community.

Any more detail in how to manage this firewall would be appreciated. Do you know how to reset TCP/IP on Linux?
 
Old 07-20-2009, 01:43 PM   #5
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 6, KDE Neon
Posts: 4,313

Rep: Reputation: 212Reputation: 212Reputation: 212
Start a terminal session and type man ufw for options available to manage the firewall.
 
Old 07-20-2009, 01:58 PM   #6
chigurh8
Member
 
Registered: Jul 2009
Distribution: Ubuntu, Gentoo
Posts: 102

Rep: Reputation: 18
If you don't know much about iptables, and think maybe iptables is already doing something to interfere with what you're trying to do, you could use
Code:
sudo iptables -L
to list all the settings you have right now, and see if something is set strangely ...
 
Old 07-20-2009, 06:06 PM   #7
siawash
Member
 
Registered: Jun 2004
Location: Ireland
Distribution: Zorin 6
Posts: 589

Original Poster
Rep: Reputation: 32
Here are the results;

ufw --version


siawash@ubuntu:~$ man utf
No manual entry for utf



Also tried

sudo iptables -L


siawash@ubuntu:~$ sudo iptables -L
[sudo] password for siawash:
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

*************]




I ping my gateway


siawash@ubuntu:~$ ping 192.168.0.1
connect: Network is unreachable
siawash@ubuntu:~$
 
Old 07-20-2009, 06:18 PM   #8
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 6, KDE Neon
Posts: 4,313

Rep: Reputation: 212Reputation: 212Reputation: 212
Quote:
Originally Posted by siawash View Post
siawash@ubuntu:~$ man utf
No manual entry for utf
Not surprised you got nothing, it's ufw I sometimes have to add the host ips, address to the /etc/hosts file when I couldn't reach machines on my network.
 
Old 07-20-2009, 06:30 PM   #9
chigurh8
Member
 
Registered: Jul 2009
Distribution: Ubuntu, Gentoo
Posts: 102

Rep: Reputation: 18
Well, then iptables isn't what's causing the problem ... I don't know.
 
Old 07-20-2009, 06:31 PM   #10
siawash
Member
 
Registered: Jun 2004
Location: Ireland
Distribution: Zorin 6
Posts: 589

Original Poster
Rep: Reputation: 32
oops! sorry...will get back to you with results soon..
 
Old 07-20-2009, 06:51 PM   #11
siawash
Member
 
Registered: Jun 2004
Location: Ireland
Distribution: Zorin 6
Posts: 589

Original Poster
Rep: Reputation: 32
OK, but I am still getting the same results

man utw
no manual entry for utw
 
Old 07-20-2009, 06:52 PM   #12
chigurh8
Member
 
Registered: Jul 2009
Distribution: Ubuntu, Gentoo
Posts: 102

Rep: Reputation: 18
U F W

You could install Firestarter as a firewall, it works with iptables and it's very easy to use, but your problem isn't with the iptables settings also, because the ones you showed are the default settings and don't change anything. I'm sure it's something else ...

Last edited by chigurh8; 07-21-2009 at 02:28 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I turn off my Firewall in FC4? ArthurDent Fedora 8 01-06-2006 02:10 AM
How to turn off firewall Eileen Linux - Networking 4 10-24-2005 03:40 AM
How do I turn off the firewall? regularguy123 Linux - Newbie 2 07-15-2004 04:06 PM
How do you turn off my firewall? phoenix07 Linux - Networking 3 04-11-2004 04:20 AM
Can't turn firewall off nocternalone Linux - Security 11 04-01-2002 02:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 08:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration