-   Ubuntu (
-   -   How to install ZRP (Zone routing protocol) patch in ns-2.34 (

hassan329 09-26-2011 04:25 AM

How to install ZRP (Zone routing protocol) patch in ns-2.34
I am new in ns, I want to install the patch of zrp in ns-2.34 on ubuntu 10.10. Did anyone know how to do that. Thanks.

hassan329 10-04-2011 04:01 AM

no reply. please anyone help me in this problem

hassan329 10-05-2011 12:10 AM

I download the patch from the following link ( but it did not install

knudfl 10-05-2011 06:16 AM

The code from
.. is for the ancient ns-allinone-2.1b6a.
Ns-allinone-2.1b6a cannot be used, unless you have an old computer
with a 10 year old Linux OS.

The only hints, I have found about zrp for a later ns2, is this
The headline says "ZRP Agent for NS2 (NS-2 v2.33) ..."


hassan329 10-05-2011 11:58 PM

Thank you for your reply.I read that manual, but when i install it i get error after writing the command
administrator@ubuntu:~/ns2/ns-allinone-2.34/zrp$ patch -p1 < && ./configure && make
bash: No such file or directory

and if i run it from root i get error
root@ubuntu:~# patch -p1 < && ./configure && make
-bash: No such file or directory

root@ubuntu:/home/administrator/ns2/ns-allinone-2.34/zrp# patch < && ./configure && make
patch: **** Only garbage was found in the patch input.

knudfl 10-06-2011 04:38 AM

#5 :

It is assumed, that you have a working ns-allinone-2.33,
i.e. the './install' command was run with no errors.

""Section 3.2 Instructions :
1. First put following files into NS-2 home's parent directory:
* ns-allinone-2.33_ZRP.tar.gz (This contains my code)
* PatchZRP.patch
This script file should be run from NS-2 home' parent directory)
2. Run from shell."" ( Like 'sh' ).

But the script isn't working, easier to do manually :
a) cd ns-allinone-2.33/ && patch -p1 < PatchZRP.patch
b) touch ns-2.33/common/packet.h && touch ns-2.33/trace/cmu-trace.h
c) cd ../ && tar xvf ns-allinone-2.33_ZRP.tar.gz
d) cd ns-allinone-2.33/ns-2.33 && make -k
... Tested this morning on Ubuntu 10.10, 32bits : OK.


hassan329 10-09-2011 01:38 AM

Thank you for the installation instruction. I am installing this ZRP patch in ns-2.34.

knudfl 10-09-2011 06:08 AM

1) A patch / modification will most often only work for
the version of ns-2.xx, that it was meant for.

2) The Zrp files do not work with ns-2.34 .

3) You can have as many versions of ns-allinone-2.xx
as you want, installed at the same time.
But do not add any of them to a PATH, LD_LIBRARY_PATH.
( I have up to 10 version installed on each OS.)


hassan329 10-10-2011 12:38 AM

Then how that version works if we do not set its path.

knudfl 10-10-2011 02:59 AM

1) nam is a separate application. One 'nam' in /usr/local/bin/ will do.

2) The binary 'ns' is coded to know or find the path by itself. Usually.
All binary ns can have a copy in /usr/local/bin/ns-<version> ,
like this real life example

/usr/local/bin/ns*            /usr/local/bin/ns229-LTE*
/usr/local/bin/ns227*        /usr/local/bin/ns233*
/usr/local/bin/ns227-dtn*    /usr/local/bin/ns233-lte*
/usr/local/bin/ns227-leach*  /usr/local/bin/ns234*
/usr/local/bin/ns228*        /usr/local/bin/ns-234-vbr*

And ns can also be used inside ns-2.xx/ as ./ns


knudfl 10-10-2011 03:38 AM

A little more information about where ns looks for its libraries.

Imagine an "ns-allinone-2.34" built in /home/name/tmp-1 : The binary
ns will use libtcl* etc. from /home/name/tmp-1/ns-allinone-2.34/lib/

Then we try moving the whole application ns-allinone-2.34/ away from
/home/name/tmp-1/ .... .... to : /home/name/tmp-0

Now an 'ns command will reply :
This ns was built with /home/name/tmp-1/ns-allinone-2.34/lib/,
not present, instead using "/home/name/tmp-0/ns-allinone-2.34/lib/*

Conclusion : There is no reason to write any path for ns in .bashrc.


hassan329 10-11-2011 05:56 AM

1 Attachment(s)
Thank for such useful information. i have install the ns-2.33 and also the zrp patch. but when i run the example which i attach it give me this error "ns: Agent/ZRP set radius_: can't read "radius_": no such variable
(Object set line 1)
invoked from within
"Agent/ZRP set radius_"

could help me in this
Thank you.

knudfl 10-11-2011 10:32 AM

1 Attachment(s)
I found another "example-?-zrp.tcl" : with "Agent/ZRP set radius_"

Your file : Added to line 68 : Agent/ZRP set radius_ 2 ;
And a couple more edits ( See for yourself )
and the file seems to be usable ? :
1) touch example.scen ( Will create an empty file 'example.scen'.)
2) touch example.traffic
( May be you have those 2 files ? )
3) ns example-zrp.tcl.txt : Will create, pktdemo.nam.
4) nam pktdemo.nam ; Click the 'Play button' : Will display "something".

hassan329 10-12-2011 01:59 AM

Thank you it runs. i delete the line 51 and add this line (Agent/ZRP set radius_ 2 ;# Setting ZRP radius=2)after line 81.
and also delete these line if u do not have these lines ( #set val(cp) "example.scen" ...#set val(trfile) "example.traffic") and also their source.

but one problem in the trace file their is no zrp is showing instead AOMDV and cbr traffic is generating.

i also install ZRP in ns-allinone-2.34 successfully according to above instruction in post#6 but i did not follow write the command which is in step a; i copy it by myself in every file.

Thank you alot for your help

numusz 02-05-2012 02:01 AM

hey hassan329,,
need your help,
can you explain me , step by step to install zrp in ns-2.34 ??

All times are GMT -5. The time now is 03:34 PM.