LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 09-24-2011, 01:38 PM   #1
benali72
Member
 
Registered: Aug 2007
Posts: 32

Rep: Reputation: 0
How to install Canon MP130 printer on Ubuntu 10.04 ?


Does anyone know how to install a Canon MP130 printer on Ubuntu 10.04? I've found several "how to" pages on this but they're for older Ubuntu releases like 8.x (see here or here).

This blows up with a bad package dependency in 10.04, as per these error messages --

> sudo apt-get install libcnbj-2.5 bjfilter-2.5 pstocanonbj

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pstocanonbj: Depends: libcupsys2 (>= 1.2.3)
E: Broken packages


Anyone know how to fix a dependency like this? If I can cover the dependency I bet this will work.

Thank you for your help.
 
Old 09-24-2011, 07:05 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
Quote:
Originally Posted by benali72 View Post
pstocanonbj: Depends: libcupsys2 (>= 1.2.3)
That's your problem; Have you used apt-get to see what version is installed of libcupsys2, let a lone if it is even installed? I would try the following:
Code:
apt-get install libcupsys2
And see what happens. You may need to go online and find a newer version that satisfies pstocanonbj to be installed.

Cheers,

Josh
 
Old 09-24-2011, 07:42 PM   #3
benali72
Member
 
Registered: Aug 2007
Posts: 32

Original Poster
Rep: Reputation: 0
Thanks, Josh, for your reply. Here's what I get --

> sudo apt-get install libcupsys2

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting libcups2 instead of libcupsys2
libcups2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>


I think this is telling me that I have LIBCUPS2 installed instead of LIBCUPSYS2. I take it that LIBCUPS2 is a newer package that replaced the older LIBCUPSYS2. Unfortunately, the install of the driver looks for and requires the older package.

Is there any way to fix this?

I tried adding symlinks pointing from LIBCUPSYS2 to LIBCUPS2, but this didn't work.

Am I stuck?

Thank you.
 
Old 09-24-2011, 07:59 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
After doing some research, you should be able to get it up and running by installing the ip1500 driver; I know this following link is dated back a bit, but it might work for you - http://swik.net/Ubuntu/Only+Ubuntu/H...r+Driver/b4fu3
I do recommend however searching on google for more up to date links. I started to look around, but since I am at work, most links were blocked for me.
 
Old 09-25-2011, 02:18 AM   #5
benali72
Member
 
Registered: Aug 2007
Posts: 32

Original Poster
Rep: Reputation: 0
Thanks, @corp769. That is the approach I'm taking now ... using the ip1500 driver. I've just found some good doc here that I will try for installing the ip1500 driver for 32-bit Ubuntu 10.04 and my Canon MP130 printer. Thanks!
 
Old 09-25-2011, 02:23 AM   #6
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
Not a problem! Let me know how it goes, thanks!

Cheers,

Josh
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Install Canon MP568 Network Printer (All-In-One) in Ubuntu and Fedora dhruv17singhal Linux - Hardware 4 11-17-2010 12:54 AM
Help Needed to Install Canon PIXMA MP130 Inkjet Printer to Ubuntu 8.10 lgp Ubuntu 5 05-20-2009 01:59 PM
canon mp130 + gentoo = ?? unknownmosquito Linux - Hardware 1 09-26-2006 08:58 PM
phantom printer with FC4 and Canon mp130 alexwinolj Linux - Hardware 0 06-19-2006 10:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 01:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration