Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 07-08-2010, 05:45 AM   #1
LQ Newbie
Registered: Jun 2009
Posts: 10

Rep: Reputation: 1
how to hide gnome menu bar icons


I'm looking for a way to hide the icons in the Gnome menu bar.
Searching on the net didn't help me ...

The only thing i've found is the gconf-editor and unchecking /desktop/gnome/interface/menus_have_icons, but that only affects the System menu and not Applications and Places...

Must be like:

Anyone knows how to disable them ?

I'm running Ubuntu 10.04LTS with Gnome 2.30

Thanks in advance.
Old 07-08-2010, 10:15 PM   #2
LQ Newbie
Registered: Jun 2010
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Re: how to hide gnome menu bar icons

I just had a play around on my Ubuntu 10.04 system and it seems you can remove the menu completely by right clicking on it and choosing "Remove from panel". It isn't obviously possible to remove individual menus, though I might guess if you remove all the items from a menu in the menu editor (right click the menu title and choose "Edit menus") it will disappear. I didn't like to try it myself... :-)

Failing that, the Help button in the edit menus dialog brings up "Customising the Panel Menubar" which includes a link to a System Administration Guide which has lots of information. I suspect you need to hand-edit some *.menu files.

I hope this is some help at least.

Old 11-20-2012, 04:09 AM   #3
Registered: Oct 2011
Location: Central Europe
Distribution: ubuntu 14.04
Posts: 45

Rep: Reputation: Disabled
Lightbulb disable icons gnome menu| right click menu | ubuntu 10.04 |


I have been facing this issue after I have installed multiboot utility for usb keys. Multi-system.
It has asked me something like " do you want to enable gnome icons" ? And I have been thinking that it is for the bootable usb stick. So I didm yes! But no, it has twisted my ubuntu desktop settings.

Because the normal way from CLI,did not work, sudo gconf-editor, tick, and un-tick some fields in /desktop/gnome/interface/menus_have_icons

I have installed UBUNTU-TWEAK
    sudo add-apt-repository ppa:tualatrix/ppa
    sudo apt-get update
    sudo apt-get install ubuntu-tweak
and I have "un-selected" one field with icons in menu. Please see attached picture. And it has worked so far fine, the stupid icons from ubuntu right-click are gone!!!
Attached Thumbnails
Click image for larger version

Views:	154
Size:	121.1 KB
ID:	11278  


gnome, icons, menu

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How can i prevent the gnome task bar icons from rearranging themselves when i reboot? Stevithen Debian 1 04-10-2010 05:10 PM
Fixing the menu bar?? Accidently removed some icons.... Dimitriy Debian 1 10-29-2005 10:06 AM
Possible to hide KDE icons in Gnome 2.8? tisource Linux - Software 5 03-15-2005 03:48 PM
How to hide menu bars in gnome joelanders Linux - Newbie 2 11-22-2004 06:21 PM
Menu bar icons gone in Mandrake 9.2 and other problems bg4533 Mandriva 8 11-25-2003 09:55 AM > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 04:49 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration