LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 06-15-2016, 11:50 AM   #1
Larry James
Member
 
Registered: Jun 2000
Location: Buffalo, New York
Distribution: Ubuntu, Raspbian
Posts: 381

Rep: Reputation: 40
How to configure networkmanager to auto connect on startup without a user logging in (Wifi)


On a current install of 16.04 the wireless network doesn't connect until someone logs into the computer.

In the past the only thing that was necessary for network connection was to connect to the Wireless. Then every time you reboot the computer it would automatically connect without logging in.

At present, the connection only becomes active once a user logs in. It doesn't matter which user, or whether it's a GUI lightdm login or a console login via one of the Alt-FKeys. Once there is a login the wireless network connects without any other action.

The problem with this is that the computer is in a remote location. Managing it is next to impossible because some maintenance requires rebooting the computer.

Thanks in advance for anyone who has a suggestion.

By the way, I know I can configure a connection via /etc/network/interfaces. However, this disables the networkmanager control. I'm hoping to be able to have an autoconnection on startup and also have the interfaces controlled by networkmanager.

-- L. James

--
L. D. James
ljames@apollo3.com
www.apollo3.com/~ljames
 
Old 06-15-2016, 12:39 PM   #2
thesnow
Member
 
Registered: Nov 2010
Location: Minneapolis, MN
Distribution: Ubuntu, Red Hat, Mint
Posts: 172

Rep: Reputation: 56
Have you tried something like this http://askubuntu.com/questions/46182...m-command-line, either in rc.local or from cron (@reboot)?
 
1 members found this post helpful.
Old 06-15-2016, 06:40 PM   #3
Larry James
Member
 
Registered: Jun 2000
Location: Buffalo, New York
Distribution: Ubuntu, Raspbian
Posts: 381

Original Poster
Rep: Reputation: 40
Quote:
Originally Posted by thesnow View Post
Have you tried something like this http://askubuntu.com/questions/46182...m-command-line, either in rc.local or from cron (@reboot)?
Yes. It was something that I had never needed to do in the past. I guess from your response, a default action of auto wireless connect is no longer possible with Ubuntu. At present, only the Wired connection type automatically connects when using NetworkManager?

As a programmer, I can perform the script workaround, but it seems a pity that this default functionality has been removed.

It seems like the developers have lost sight of the importance of network connectivity.

Thank you kindly for the input.

-- L. James

--
L. D. James
ljames@apollo3.com
www.apollo3.com/~ljames
 
Old 06-15-2016, 06:52 PM   #4
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,316

Rep: Reputation: Disabled
Not sure if it helps, but wicd will establish wireless connection without user logging in.
 
Old 09-05-2016, 03:10 PM   #5
Larry James
Member
 
Registered: Jun 2000
Location: Buffalo, New York
Distribution: Ubuntu, Raspbian
Posts: 381

Original Poster
Rep: Reputation: 40
For anyone interested, I have found out how to perform this connection with NetworkManager. The reason I wanted to do this with Network Manager is for the GUI connection interface. This way a user having physical access to the computer can easier connect to the best network of the network access point changes.

Using a commandline option disables NetworkManager.

The way to perform this automatic connection is:

Bring-up NetworkManager -> (Click on) Edit Connections -> Select the current connection From the list of connections -> (Click) Edit -> (Click) General -> (Checkmark) Automatical connect to this network & All users may connect to this network

-- L. James

--
L. D. James
ljames@apollo3.com
www.apollo3.com/~ljames
 
1 members found this post helpful.
  


Reply

Tags
networkmanager


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Networkmanager don't connect automatically to wifi. lensilvan Slackware 13 10-25-2014 11:15 AM
[SOLVED] Can't connect to wifi through NetworkManager Didier Spaier Slackware 16 10-27-2013 03:49 PM
How do disable wifi auto connect joboy Ubuntu 2 04-01-2013 11:20 PM
How to auto-connect to network when logging in without password? skykooler Linux - Wireless Networking 1 04-19-2012 09:32 AM
[SOLVED] How to get networkmanager to connect wifi in bootup. john.wythe@activant.com Linux - Networking 2 01-02-2011 04:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 06:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration