-   Ubuntu (
-   -   How to be sure grub2 is uninstalled (

enrico_dvchp 01-31-2013 01:15 PM

How to be sure grub2 is uninstalled
2 Attachment(s)
Hi all,
I've tried without success to install ubuntu 12.04.1 LTS in dual boot with win8. My system is a 64 bit/uefi and since only grub2 is recognized by this system, my attempt to create a dual boot with grub1.99 resulted in a black screen "unable to find a bootable device".
So I've used my live-usb flash with Precise and I've installed Boot-repair.
I've used it to fix the mbr without reinstall grub. Actually now win 8 works well.
To avoid mistakes, I'd like to be sure grub is totally uninstalled from my system. in a second time, I'll try again with the suitable boot loader I can find in 12.10 or later in 12.04.2 LTS as Canonical will provide a really stable release.
I know my Dell XPS 8500 has a boot partition. It is ESP fat 32 , size 500 mb. As a result of a partition viewer, I see this first partition has Microsoft but even grub entries too.
Can you suggest me how to have a grub-clean system in order to reinstall the correct Grub without problems?

yancek 01-31-2013 04:28 PM


I see this first partition has Microsoft but even grub entries too.
You might but we can't see Grub entries. No sign of anything grub related in the images you posted. Was windows 8 pre-installed? Did you have secure boot, was it disabled before you tried to install Ubuntu? How did you try to install Ubuntu? Is windows 8 the only operating system currently on the system?

I'm not sure what your statement about version 12.04 and 12.10 is about. 12.04 is LTS and will have support long after 12.10 support ends, 12.04 is 5 years.

enrico_dvchp 02-01-2013 11:02 AM

1 Attachment(s)
Actually, the last action i've done with boot-repair is to restore mbr unchecking the reinstall grub option.
Sorry, I've overlooked that.
The idea grub esixts depends on the boot partition os listed. I expected ubuntu was no more in the list. On the contrary it is still there. See my attach jpg.
I premise I have a very little experience in system setup and UEFI is something new for me: probably the presence of the ubuntu folder does not matter. I don't know. Do you know I can proceed in a new ubuntu installation regardless the ubuntu folder in my boot partition?
To answer your questions, as i changed my computer i've experienced 64 bit computer and the secure boot.
I've found windows 8 pre installed, and I need it for particular software, so I've tried to dual-boot Windows 8 and ubuntu 12.04 because I need also a stable and durable LTS release. In fact I've done it other times before.
I've read in some articles / forums that Grub2 is the better choice for an UEFI system. Actually Precise 1.04.1 has only the

Grub1.99. So I've upgraded ubuntu to the 12.10 release in order to make Grub2 as boot loader. The result was a Grub2 boot loader with odd entries, whose only those fit for ubuntu work not those for Windows. This the reason I've used boo repair. At first to uninstall-fixmbr-reinstall grub. After fail attempts, I've only repaires mbr and obtained a windows system. I think I had dualbooted some system years ago I can learn to do it now.
Bye soon,

enrico_dvchp 02-02-2013 01:19 PM

Additional information
ubuntu@ubuntu:~$ sudo parted -l
Model: ATA ST2000DM001-1CH1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
1 1049kB 525MB 524MB fat32 EFI system partition boot
2 528MB 570MB 41.9MB fat32 Basic data partition hidden
3 570MB 705MB 134MB Microsoft reserved partition msftres
4 705MB 1229MB 524MB ntfs Basic data partition hidden, diag
5 1229MB 199GB 198GB ntfs Basic data partition
8 199GB 924GB 725GB ext4
7 924GB 1993GB 1069GB ntfs
6 1993GB 2000GB 7358MB ntfs Microsoft recovery partition hidden, diag

Error: /dev/sdb: unrecognised disk label

Model: SAMSUNG HD103SI (scsi)
Disk /dev/sdc: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 1000GB 1000GB primary fat32 lba

Model: SanDisk U3 Cruzer Micro (scsi)
Disk /dev/sdd: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 65.5kB 16.0GB 16.0GB primary fat32 boot, lba

Model: WD Ext HDD 1021 (scsi)
Disk /dev/sde: 3001GB
Sector size (logical/physical): 4096B/4096B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 3001GB 3001GB primary
----------------- Guid Partition Table --------------------------------------------------------------------
ubuntu@ubuntu:~$ sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 3907029168 sectors, 1.8 TiB
Logical sector size: 512 bytes
Disk identifier (GUID): 0FF7F015-4185-4E5A-8BBC-98945CDB443E
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 3907029134
Partitions will be aligned on 2048-sector boundaries
Total free space is 14694 sectors (7.2 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 1026047 500.0 MiB EF00 EFI system partition
2 1032192 1114111 40.0 MiB FFFF Basic data partition
3 1114112 1376255 128.0 MiB 0C01 Microsoft reserved part
4 1376256 2400255 500.0 MiB 2700 Basic data partition
5 2400256 388349951 184.0 GiB 0700 Basic data partition
6 3892652032 3907022598 6.9 GiB 2700 Microsoft recovery part
7 1804087296 3892652031 995.9 GiB 0700
8 388349952 1804087295 675.1 GiB 0700
Othr tests suggested?

All times are GMT -5. The time now is 02:14 AM.