LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 05-28-2008, 11:38 AM   #1
farzadfedora
Member
 
Registered: Jul 2007
Distribution: kubuntu
Posts: 80

Rep: Reputation: 15
Question ????How I Can Configure Google Earth Proxy ?????


hi.
i have downloaded google earth and installed it on my pc.
it works well...
but when i installed it on an other system with a LAN Network Connection , google earth could not connect to the server (system connects to the internet by a LAN Network with a proxy)
i dont know where i have to configure google earth network proxy settings...
please guide me to do this...

Thanks...
 
Old 05-29-2008, 08:16 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594
As far as I know not from within Google Earth, but it does honour environment variables. if you export a line like 'HTTP_PROXY="http://some.hostort/"' manually, from your shells resource file or through one of those GUI tools, it should work.
 
Old 05-30-2008, 03:27 AM   #3
farzadfedora
Member
 
Registered: Jul 2007
Distribution: kubuntu
Posts: 80

Original Poster
Rep: Reputation: 15
thanks my friend for your reply ...
but it didnt help me...

SO I need help YET...
 
Old 05-30-2008, 04:47 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594
Quote:
Originally Posted by farzadfedora View Post
but it didnt help me...
Saying "doesn't work" doesn't help us to help you. Please be specific and post the steps you took and how you tested it.
 
Old 05-31-2008, 10:32 AM   #5
farzadfedora
Member
 
Registered: Jul 2007
Distribution: kubuntu
Posts: 80

Original Poster
Rep: Reputation: 15
hi.
"Doesn't Work" means it didn't use the proxy servers...
and was not able to connect to the server ...
I hope someone be able to help me...
thanks.
bye.

Last edited by farzadfedora; 05-31-2008 at 10:33 AM.
 
Old 05-31-2008, 01:37 PM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594
OK. So what did you do? Did you use one of the KDE or GNOME tools to set your proxy? Or did you export it from the commandline? Or did you add the line to /etc/profile?
 
Old 06-01-2008, 03:38 AM   #7
farzadfedora
Member
 
Registered: Jul 2007
Distribution: kubuntu
Posts: 80

Original Poster
Rep: Reputation: 15
I entered this command in a shell:

googleearth HTTP_PROXY="10.1.1.2:8080"

but it didn't set the proxy (I Think) because it didn't connected to the server...
 
Old 06-01-2008, 06:34 AM   #8
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594
Quote:
Originally Posted by farzadfedora View Post
I entered this command in a shell:

googleearth HTTP_PROXY="10.1.1.2:8080"

but it didn't set the proxy (I Think) because it didn't connected to the server...
I can see it didn't. If you would have read the replies a bit more carefully you would have seen there's a few options and none of those match what you did. So here's three examples.

A. Use these steps if you are the only human using this machine, and you want *all* applications (that adhere to the PROXY environment variables) used by unprivileged users to use the same proxy all of the time:
0. Find out which shell you use (in a terminal window type "echo $SHELL", without the quotes). If it is not Bash or if it does not source /etc/profile, then find out which central resource files your shell sources.
1. Become root and see if you have the "/etc/profile.d" directory. If you do, create a file there called "/etc/profile.d/proxy.sh" and fill it with these contents:
Code:
CHKUID=`awk '/^UID_MIN/ {print $2}' /etc/login.defs`
if [ `id -g` -ge ${CHKUID:=500} ]; then 
 export HTTP_PROXY=http://10.1.1.2:8080/
 export HTTPS_PROXY=http://10.1.1.2:8080/
fi
save changes then close the file and make it have octal mode 0644 ("chmod 0644 /etc/profile.d/proxy.sh").
2. Log out of root and log out of your shell.
3. Log in again, open a terminal window and type "env|grep PROX" to verify the variables got set. Ready.


B. Use these steps if you are just one of the users on this machine, and you want *your* applications (that adhere to the PROXY environment variables) to use the same proxy all of the time:
0. Find out which shell you use (in a terminal window type "echo $SHELL", without the quotes). If it is not Bash, then find out which personal resource files your shell sources.
1. Open your .bash_profile and add the lines
Code:
export HTTP_PROXY=http://10.1.1.2:8080/
export HTTPS_PROXY=http://10.1.1.2:8080/
save changes then close the file.
2. Open a terminal window and type "env|grep PROX" to verify the variables got set. Ready.


C. Use these steps if you are just one of the users on this machine, and you want *only* applications (that adhere to the PROXY environment variables) to use a proxy when you select it:
0. Open a terminal window or use your Desktop Environments "run" command, type "env HTTP_PROXY=http://10.1.1.2:8080/ /path/to/googleearth". Ready.


* N.B. In your XFCE, KDE, GNOME or other Desktop Environment you might have GUI tools to help you set a proxy for other applications.
 
Old 06-02-2008, 01:33 AM   #9
farzadfedora
Member
 
Registered: Jul 2007
Distribution: kubuntu
Posts: 80

Original Poster
Rep: Reputation: 15
Thanks a lot My Friend...
I can run googleearth with proxy now...
but i dont have a /etc/profile.d directory (only have a profile text file in my /etc directory) and my shell is bash... now how i can use a global proxy for all the applications as you told?

Please guide me about this if you can....

and at last thanks a lot... because you solved my problem with google earth...
 
Old 06-02-2008, 05:08 AM   #10
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594Reputation: 3594
Quote:
Originally Posted by farzadfedora View Post
but i dont have a /etc/profile.d directory (only have a profile text file in my /etc directory) and my shell is bash... now how i can use a global proxy for all the applications as you told?
If you want *all* applications (that adhere to the PROXY environment variables) used by unprivileged users to use the same proxy all of the time you can add the code under "A" to /etc/profile. If you want *all* applications (that adhere to the PROXY environment variables) of *all* users (inclluding root) to use the same proxy all of the time you can add the code under "B" to /etc/profile.
 
Old 06-03-2008, 01:15 AM   #11
farzadfedora
Member
 
Registered: Jul 2007
Distribution: kubuntu
Posts: 80

Original Poster
Rep: Reputation: 15
Thanks A LOT My Friend...
you solved all of my problems with proxy...
Thanks A LOT.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no 'Earth' on Google earth blastradius Linux - Software 19 02-01-2009 12:05 PM
Google Earth taj Ubuntu 4 05-25-2008 11:19 AM
google earth mortal *BSD 2 09-07-2007 09:53 PM
google earth - running under proxy sailu_mvn Linux - Software 2 07-27-2006 11:09 PM
Google Earth produces 'holes' in planet earth greengrocer Linux - Newbie 5 07-18-2006 10:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 12:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration