-   Ubuntu (
-   -   How do i get the ubutnu Gui up, i seem to be stuck in CLI :o (

rawplug89 05-08-2006 03:53 PM

How do i get the ubutnu Gui up, i seem to be stuck in CLI :o
Ok a few questions, which may seem stupid but hey, A-level computing only teaches you so much.
I have just installed Ubuntu 5.10 (Breezy Badger), after lots of issues with logins and things i have created a user profile, unfortunately i'm still in CLI. Does Ubuntu come with a GUI preinstalled or is it something i have to add over the top? I've tried to do a clean re-install but the partition manager comes up and won't let me keep my setup.

Please help me get the GUI up, i'd look on the Ubuntu forums but their down for maintainance

A few minutes later- Does pressing ctrl- alt-f7 get me into it?

nadroj 05-08-2006 04:03 PM

try typing 'startx'
did you install the full system or just the server setup?

rawplug89 05-08-2006 04:09 PM

tried startx- command not found

btw am i litterally just typing startx, do i not need a run command or directory name?

as i just pressed enter at install, i assume i ran the normal instal(rather than typing server ect.)

voger 05-08-2006 04:53 PM

You probably didn't install any desktop. Try with your installation CD-ROM mounted

sudo apt-get install gnome-desktop
if you have Ubuntu or kubuntu-desktop if you have Kubuntu

rawplug89 05-08-2006 04:59 PM


Originally Posted by voger

sudo apt-get install gnome-desktop

Just to confirm., i boot up and login, then insert the CD and type the above code

rawplug89 05-08-2006 05:03 PM

i do that and it says
reading package lists... Done
Building dependency tree... Done
E: couldn't find package gnome-desktop

Wartz 05-08-2006 05:06 PM

Are you sure you have a real copy of ubuntu 5.10? :confused:

voger 05-08-2006 05:16 PM

Try to mount the CD-ROM first


sudo mount /dev/hdc /media/cdrom -t iso9660
where /dev/hdc could be /dev/hdb or /dev/hdd. It depends on where is you CD drive.

Oh and also that gnome-desktop should be ubuntu-desktop. That happens when fingers work faster than the brain. Sorry :o

rawplug89 05-08-2006 05:19 PM


Originally Posted by Wartz
Are you sure you have a real copy of ubuntu 5.10? :confused:

its the one they sent me in the post...

rawplug89 05-08-2006 05:28 PM

i get hundereds of file not fetched, file not found errors?

voger 05-08-2006 05:37 PM

Try in this order


sudo mount /dev/hdc /media/cdrom -t iso9660
sudo apt-get update
sudo apt-get install ubuntu-desktop

I am not sure if the second line is necessary but try it anyway.

rawplug89 05-08-2006 05:43 PM

same file not found errors... anyother ways of getting the files
Downloads perhaps?

rawplug89 05-08-2006 05:54 PM

Looking at the files on the CD under windows, i can see thery're their, just need a way to point at them. When i try to mount the CD i'm not sure if its sucessful, it just comes up with some comments about extra commands you can use... does it matter that i have 2 CD drives?

voger 05-08-2006 06:00 PM

You can try to go to this link and follow their directions. that will give you a file named sources.list. Save that file somewhere and copy it with


sudo mv /etc/apt/sources.list /etc/apt/sources.list-backup
sudo cp sources.list /etc/apt/

Then follow their directions about GPG keys


sudo apt-get update
sudo apt-get install ubuntu-desktop

I hope you have a fast connection ;).

voger 05-08-2006 06:11 PM

Can you post here the error message? And yes it does matter. The CD-ROM should be in the drive you installed it first. An the success message is


mount: block device /dev/hdc is write-protected, mounting read-only
If you don't see that you can try with hdb or hdd or maybe with hda if you hard disk is SATA.

Alternatively you can try the easier way


sudo mount /media/cdrom
sudo mount /media/cdrom1

And then

ls /media/cdrom/
ls /media/cdrom1/

One of them should list the files in you disc. Just remember that you have to put the disc in the drive you used during installation.

All times are GMT -5. The time now is 03:35 AM.