-   Ubuntu (
-   -   How do I choose a resolution for GRUB2 when it resists all changes? (

Melodiesonmusic 02-02-2013 12:09 PM

How do I choose a resolution for GRUB2 when it resists all changes?
I'm using Gnome 3.6.2 with Ubuntu 12.10, my screen resolution is currently 1680x1050, but in GRUB it was something different. First I used /etc/default/grub to uncomment the resolution line and change it to the same resolution I usually use. When that didn't work I downloaded GRUB customizer and changed it there. That didn't work so I ran this:


sudo hwinfo --framebuffer
and got this output:


Mode 0x0382: 320x200 (+320), 8 bits
Mode 0x030d: 320x200 (+640), 15 bits
Mode 0x030e: 320x200 (+640), 16 bits
Mode 0x030f: 320x200 (+960), 24 bits
Mode 0x0320: 320x200 (+1280), 24 bits
Mode 0x0392: 320x240 (+320), 8 bits
Mode 0x0393: 320x240 (+640), 15 bits
Mode 0x0394: 320x240 (+640), 16 bits
Mode 0x0395: 320x240 (+960), 24 bits
Mode 0x0396: 320x240 (+1280), 24 bits
Mode 0x03a2: 400x300 (+400), 8 bits
Mode 0x03a3: 400x300 (+800), 15 bits
Mode 0x03a4: 400x300 (+800), 16 bits
Mode 0x03a5: 400x300 (+1200), 24 bits
Mode 0x03a6: 400x300 (+1600), 24 bits
Mode 0x03b2: 512x384 (+512), 8 bits
Mode 0x03b3: 512x384 (+1024), 15 bits
Mode 0x03b4: 512x384 (+1024), 16 bits
Mode 0x03b5: 512x384 (+1536), 24 bits
Mode 0x03b6: 512x384 (+2048), 24 bits
Mode 0x03c2: 640x350 (+640), 8 bits
Mode 0x03c3: 640x350 (+1280), 15 bits
Mode 0x03c4: 640x350 (+1280), 16 bits
Mode 0x03c5: 640x350 (+1920), 24 bits
Mode 0x03c6: 640x350 (+2560), 24 bits
Mode 0x0300: 640x400 (+640), 8 bits
Mode 0x0383: 640x400 (+1280), 15 bits
Mode 0x0384: 640x400 (+1280), 16 bits
Mode 0x0385: 640x400 (+1920), 24 bits
Mode 0x0386: 640x400 (+2560), 24 bits
Mode 0x0301: 640x480 (+640), 8 bits
Mode 0x0310: 640x480 (+1280), 15 bits
Mode 0x0311: 640x480 (+1280), 16 bits
Mode 0x0312: 640x480 (+1920), 24 bits
Mode 0x0321: 640x480 (+2560), 24 bits
Mode 0x0303: 800x600 (+800), 8 bits
Mode 0x0313: 800x600 (+1600), 15 bits
Mode 0x0314: 800x600 (+1600), 16 bits
Mode 0x0315: 800x600 (+2400), 24 bits
Mode 0x0322: 800x600 (+3200), 24 bits
Mode 0x0305: 1024x768 (+1024), 8 bits
Mode 0x0316: 1024x768 (+2048), 15 bits
Mode 0x0317: 1024x768 (+2048), 16 bits
Mode 0x0318: 1024x768 (+3072), 24 bits
Mode 0x0307: 1280x1024 (+1280), 8 bits
Mode 0x0319: 1280x1024 (+2560), 15 bits
Mode 0x031a: 1280x1024 (+2560), 16 bits
Mode 0x0340: 1400x1050 (+1400), 8 bits
Mode 0x0341: 1400x1050 (+2800), 15 bits
Mode 0x0342: 1400x1050 (+2800), 16 bits
Mode 0x0343: 1400x1050 (+4200), 24 bits
Mode 0x0344: 1400x1050 (+5600), 24 bits
Mode 0x0372: 1600x1200 (+1600), 8 bits

The resolution I have GRUB set to now doesn't appear on that list. Maybe that's why it's resisting my changes? Is this a list of all the resolutions my video card can handle, or just a list of resolutions? I tried out a couple of them to see if they looked okay but none of them seem to be anywhere close to the ratio I use now (16:10). The only thing that bothers me is that the words are cut off. I'm just looking for a resolution that'll show both boot options.

kedarp 02-03-2013 06:09 AM

How bout you run this script and try, but it will give you the same resolutions that are listed above.

tommcd 02-03-2013 09:57 AM


Originally Posted by Melodiesonmusic (Post 4883133)
... First I used /etc/default/grub to uncomment the resolution line and change it to the same resolution I usually use. ...

Just to rule this out as the source of your problem, and because you did not mention it in your post, after you uncommented the GRUB_GFXMODE= line and changed the resolution to what you want it to be, did you be sure to run from the terminal:

sudo update-grub
You must run sudo update-grub any time you make changes to grub2 for the changes to take effect.

Also, note that the resolution you set must be supported by your graphic card via VBE:
You can find out if the resolution you want is supported by hitting the "c" key when the grub2 menu displays and running vbeinfo to get the resolutions that are supported.

Melodiesonmusic 02-04-2013 03:07 PM

@kedarp You're right, it did give me the same list. I didn't seem to work either. Do you recommend the second solution?

@tommcd Yes, I ran sudo update-grub every time I tried to change anything. vbeinfo is actually one of the first things I tried, oddly enough it said my preferred mode was 1680x1050, which is what I have it set to, but not what it was set to originally. The resolutions hwinfo and vbeinfo return don't fit my monitor. vbeinfo returned 200,240,300,350,384,400,480,600,768 and 1024 all by either 8, 16, 24 or 32.

Thanks for the help :)

kedarp 02-07-2013 05:59 AM

Try this -


#xrandr --addmode S-video 1680x1050
If xrandr is not installed, then install it first -

#apt-get install xrandr
Then restart, and see the available resolutions -

sudo hwinfo --framebuffer

Melodiesonmusic 02-09-2013 11:45 AM


When I try to install xrandr it says:

"Package xrandr is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:

E: Package 'xrandr' has no installation candidate"

Is there anywhere online I can get it's .deb file?

tommcd 02-10-2013 08:56 AM


Originally Posted by Melodiesonmusic (Post 4887710)
When I try to install xrandr it says:

"Package xrandr is not available, but is referred to by another package. ...

You should already have xrandr installed. Post the output of:

aptitude search xrandr
It should show an "i" and a "A" next to the libxrandr2 package, and an "i" next to the lxrandr package, indictating that they are installed.

Have you tried simply running the xrandr commands that kedarp posted? If so then post the output of those commands here.

kedarp 02-10-2013 12:06 PM

If you are using NVIDIA graphics card, and you have installed the nvidia drivers, then you will face problems
in the GRUB resolution.

This page may help you -

My experience tells me that you should edit /etc/default/grub and not use any tool to change GRUB settings.

Melodiesonmusic 02-11-2013 02:21 PM

Sorry, I typed it in wrong. When I ran

xrandr --addmode S-video 1680x1050
I got

xrandr: cannot find output "S-video"
. When I ran just xrandr it outputted this

Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
VGA-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
  1680x1050      60.0*+
  1680x945      60.0 
  1400x1050      60.0 
  1600x900      60.0 
  1280x1024      75.0    60.0 
  1440x900      75.0    59.9 
  1280x960      60.0 
  1366x768      60.0 
  1360x768      60.0 
  1280x800      74.9    59.8 
  1152x864      75.0 
  1280x768      74.9    59.9 
  1024x768      75.1    70.1    60.0 
  1024x576      60.0 
  832x624        74.6 
  800x600        72.2    75.0    60.3    56.2 
  848x480        60.0 
  640x480        72.8    75.0    66.7    60.0 
  720x400        70.1

tommcd 02-12-2013 03:41 AM

Here is an Ubuntu wiki file with a detailed tutorial on xrandr:

All times are GMT -5. The time now is 11:15 AM.