LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 07-29-2015, 04:30 PM   #1
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 720

Rep: Reputation: 47
Cool How can I get a hold of install libv8 version 3.24.6 in Ubuntu LTS


I'm trying to setup v8js for I can use PHP to render Javascript but am stuck at this part of the process. During the install it tells me that I must have libv8 at version 3.24.6.

Any ideas?
 
Old 07-29-2015, 05:47 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, Manjaro
Posts: 8,885
Blog Entries: 14

Rep: Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081
Hi:

I looked in the Ubuntu Repository pkg search and I could only find libv8 3.14.5.
I even tried a pkg search for libv8 3.24.6.
http://packages.ubuntu.com/trusty/libs/libv8-3.14.5

Maybe the scripts in this link will help.
https://github.com/preillyme/v8js/blob/master/README.md

Using Ubuntu 12.04 with PHP 5.4 works great.
http://www.codeotel.com/CNVVVPVWee/h...-on-php55.html

Sorry I don't know more.

http://upstream.rosalinux.ru/compat_...at_report.html
https://www.marc.info/?l=pecl-cvs&m=142625180307942&w=4
http://neqatively.com/____________i_...v8js_on_php5_5
 
1 members found this post helpful.
Old 07-30-2015, 05:43 AM   #3
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 720

Original Poster
Rep: Reputation: 47
Quote:
Originally Posted by Ztcoracat View Post
Hi:

I looked in the Ubuntu Repository pkg search and I could only find libv8 3.14.5.
I even tried a pkg search for libv8 3.24.6.
http://packages.ubuntu.com/trusty/libs/libv8-3.14.5

Maybe the scripts in this link will help.
https://github.com/preillyme/v8js/blob/master/README.md

Using Ubuntu 12.04 with PHP 5.4 works great.
http://www.codeotel.com/CNVVVPVWee/h...-on-php55.html

Sorry I don't know more.

http://upstream.rosalinux.ru/compat_...at_report.html
https://www.marc.info/?l=pecl-cvs&m=142625180307942&w=4
http://neqatively.com/____________i_...v8js_on_php5_5
Thanks, I'll try setting up a VM for 12.04.
 
Old 07-30-2015, 12:57 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, Manjaro
Posts: 8,885
Blog Entries: 14

Rep: Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081
Quote:
Originally Posted by wh33t View Post
Thanks, I'll try setting up a VM for 12.04.
Your Welcome.

I use VBox, it runs well.-

-::-Let us know how a VM works with 12.04.-::-
 
1 members found this post helpful.
Old 07-30-2015, 06:34 PM   #5
wh33t
Member
 
Registered: Oct 2003
Location: Canada
Posts: 720

Original Poster
Rep: Reputation: 47
It worked, I downloaded the 32bit 12.04 LTS, installed in VMware. Installed Tasksel, installed Lamp stack, installed v8js, installed pecl by installing php-pear, run the pecl install command, rant the test script. It all went off without a hitch.

This experience has seriously got me questioning holding off on upgrading to the latest LTS every time they come out. Thanks for help.
 
1 members found this post helpful.
Old 07-30-2015, 07:18 PM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, Manjaro
Posts: 8,885
Blog Entries: 14

Rep: Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081Reputation: 1081
Quote:
Originally Posted by wh33t View Post
It worked, I downloaded the 32bit 12.04 LTS, installed in VMware. Installed Tasksel, installed Lamp stack, installed v8js, installed pecl by installing php-pear, run the pecl install command, rant the test script. It all went off without a hitch.

This experience has seriously got me questioning holding off on upgrading to the latest LTS every time they come out. Thanks for help.

Wow, that's great that it worked for you.

I never upgrade to the LTS I wait about 3 to 5 months for the developers to get the bugs out.

Your Welcome; always glad to help.-

Last edited by Ztcoracat; 07-30-2015 at 07:39 PM.
 
1 members found this post helpful.
  


Reply

Tags
v8js


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to Update a Ubuntu LTS release to the next LTS Version (dist upgrade) LXer Syndicated Linux News 0 02-19-2015 09:00 AM
LXer: Ubuntu 10.04.2 Released - LTS Version Gets Second Maintenance Update LXer Syndicated Linux News 0 02-18-2011 03:40 PM
troubles starting with ubuntu 10.04 Lts version kuchito Linux - Newbie 1 01-19-2011 11:01 AM
how do I download latest version of Scibuntu with Ubuntu 8.04 LTS? cigtoxdoc Linux - Software 1 06-14-2008 04:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 03:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration