-   Ubuntu (
-   -   How can a laptop screen be an "Unknown Monitor"? (

SilversleevesX 08-19-2010 05:39 PM

How can a laptop screen be an "Unknown Monitor"?
Mine is, ever since I installed the (wrong) opensource video driver for my Ubuntu 9.04 & Lenovo ThinkPad T41 (the one model, imho, they should never have let out the door!), uninstalled it by far-less-than-recommended means (ie, I used Synaptic and sudo apt-get remove and apt-get purge). End up is now my screen has a max resolution of 800 x 600, and Display panel insists that this laptop's screen is an "Unknown" Monitor.

Any tweaks to /etc/X11/xorg.conf (adding vertical refresh and horizontal sync rates for example) has resulted in its own weird behavior. On having my password accepted at login, there's a half-second of white that "rolls" over the screen horizontally. The next thing I see is a diagonal broken streak of white about 2 1/2" down from the top of the screen and 3 inches in from the right-hand side. The next thing I see is a buzzed,jagged rendition of my normal desktop. Nothing at all is clear, and the jags seem to redouble themselves the further one scans down on the screen. The only thing one can do in this situation, and I've done so enough times to know, is a hard reboot (power button for ten seconds or however long it takes).

And as I don't rate sh*t for a shilling on the Ubuntu forums, and as Google has been worse than useless every time I search for problems as detailled as these (it's like K-Mart: it has what you want until you go to look for it!), and as my one self-styled "Lunix-Geek" friend (now in the UK) has only briefly battled the xserver-xorg beasts, I'm coming here to see if anyone knows something else I could do besides bite the bullet, say goodby to my accumulated goodies, and reinstall Ubuntu.


RockDoctor 08-19-2010 07:08 PM

Once you've logged in, open a terminal window and run gtf to get the modeline command you need, then add it to your xorg.conf file in the monitor section and add the appropriate resolution in the Screen section.

SilversleevesX 08-19-2010 09:19 PM


Originally Posted by RockDoctor (Post 4071754)
Once you've logged in, open a terminal window and run gtf to get the modeline command you need, then add it to your xorg.conf file in the monitor section and add the appropriate resolution in the Screen section.

Tried it. No change. Still "unknown" and still stuck at 800 x 600 for max resolution.

Correction: Putting in a Modeline and a preferred Resolution resulted in exactly the same behavior as I described in the second paragraph of my OP. This is what I was trying to get around by posting here. If I could post a picture of the way my laptop screen looks at this moment (20010819:2132 EDT), I would. Unfortunately I've only one digital still camera and it's on loan to a relative. :|


RockDoctor 08-20-2010 05:19 PM

Can you reinstall the proprietary driver, and if so, can you get back to the proper screen resolution? If not, you might want to try the vesa driver - it may not give you the full resolution of your screen (it won't if you've got the 1400x1050 screen), but it might give you 1440x900. On my desktop w/ onboard nvidia 9100, and my 1680x1050 lcd monitor, the vesa driver lets me have 1600x1200 or 1440x900, but 1680x1050 isn't a standard vesa mode

SilversleevesX 08-21-2010 04:52 AM

Desktop, laptop, different animals.
Particularly when the zookeeper is X11 server. 8)

Strangely, booted from a 40gb with Kubuntu (identical version - 9.0.4) plugged into an external enclosure whose power link is dying out, I get 1024x768 -- nothing higher, of course, but the desktop, folder windows and app windows all draw correctly, as they should by now with all the purging and cleaning I've done on the boot drive for GNOME.

So why not "migrate" the K onto the laptop, or do a fresh LiveCd install of same?

I suppose I could for a short time, except my own brother (IT for 13 years and 2 or three EMC Unix certs to his name) tried it a few months back.

Apparently KDE 4 and the T-series ThinkPads don't play well together -- he described running it as his boot OS as analogous to "a drunken dog with a missing leg in a sleetstorm."

Might my problem have something to do with using a non-standard (please read and read twice: did not come from the repositories and was not installed with the OS) login screen.

At any rate, it's probably making the difference between these jagged lines and a blank -- white or black -- screen.

I'll take either-or at this point (read carefully and read twice:
EITHER 1024x768@16 drawn correctly OR a blank white or blank black screen).


All times are GMT -5. The time now is 10:04 AM.