LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 09-28-2008, 11:05 AM   #1
KWTm
Member
 
Registered: Jan 2004
Distribution: Kubuntu 10.04 (Dell Linux-preinstalled laptop + a desktop); Maemo 5 (N900 phone computer)
Posts: 116

Rep: Reputation: 21
Here's how to disable tap-to-click on laptop touchpads


I find it very annoying that the touchpad on my laptop (the "built-in mouse") treats a tap on the touchpad as the same as a mouse click. Sometimes when I am typing, my thumb will accidentally brush the touchpad; the effect is that I move my mouse cursor to somewhere random and then click it. If I'm in the middle of typing, I might end up typing the second half of my sentence into a different part of the window (or different window). Since there is already a button next to my touchpad for actually clicking the mouse button, the "tap-to-click" function on the touchpad is unnecessary and is begging for accidents.

I found out how to turn off the "tap-to-click" feature. This is part of the X windowing system common to all graphical Linux interfaces. We need to change the file '/etc/X11/xorg.conf'. Here's how to do that on an Ubuntu system (for other systems, switch to root and omit the 'sudo' before the commands):

1. First make a backup copy of the file using the command

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

2. Then edit the file with the command 'gksudo gedit /etc/X11/xorg.conf'; on a Kubuntu system it would be 'kdesu kwrite /etc/X11/xorg.conf'; or if you like nano, then it's 'sudo nano /etc/X11/xorg.conf'.

Find the section that starts with

Section "InputDevice"
Identifier "Synaptics Touchpad"


After that, the next few lines start with "Driver" or "Option". We need to add these lines to that section (before the line that says "EndSection", of course):

Option "TapButton" "0"
Option "MaxTapMove" "0"
Option "MaxTapTime" "0"

Some people may also want to add:

Option "HorizScrollDelta" "0"
Option "VertScrollDelta" "0"

I haven't tried those extra two lines, but I guess they turn off the scrolling when you drag along the edge of the touchpad.

That's all! The next time you start the X Windowing System (for example, if you reboot), your changes will take effect. If you want to restart just X without having to reboot, try Ctrl-Alt-Backspace. (It's faster than rebooting but it still kills any programs you see on screen. Save everything; you may lose all your data.)

Optional: If you want to do this more automatically, you can use a short script program that I wrote instead. Type "cat >disable_tap_to_click" on a command line, which will let you enter the program. Then cut&paste the following program, including the first and last lines which start with the '#' character. Then press Ctrl-Z to finish. Then type "source disable_tap_to_click", which will run the script program. (You don't have to type "sudo" since that's already inside the script.) Hope that helps!

Here is the script program:

Code:
#!/bin/bash

ORIGINAL_CONFIG_FILE="/etc/X11/xorg.conf"
grep 'MaxTapTime.*0' $ORIGINAL_CONFIG_FILE
if [ 0 = $? ]; then :
	echo "There is already a TapButton setting in $ORIGINAL_CONFIG_FILE --aborting. Modify the file manually if you really want to change it."
else :
sudo cp $ORIGINAL_CONFIG_FILE ${ORIGINAL_CONFIG_FILE}.backup
sed -e '
/ouchpad/,/EndSection/ {
	/EndSection/ i\
	Option 		"TapButton" "0"
	/EndSection/ i\
	Option 		"MaxTapMove" "0"
	/EndSection/ i\
	Option 		"MaxTapTime" "0"
	/EndSection/ i\
	\# Option 		"HorizScrollDelta" "0"
	/EndSection/ i\
	\# Option 		"VertScrollDelta" "0"
	/EndSection/ i\
	\# Sets touchpad so that a tap on the touchpad does NOT mean clicking the mouse button
}
' <$ORIGINAL_CONFIG_FILE >xorg.conf.temp
sudo mv xorg.conf.temp $ORIGINAL_CONFIG_FILE
fi

### END OF THE SCRIPT
I found this info at http://tech.slashdot.org/comments.pl...5&cid=24390167. It works for my Dell e1505n laptop running Kubuntu8.04.

Last edited by KWTm; 10-14-2008 at 01:20 AM. Reason: corrected "fruit$ORIGINAL_CONFIG_FILE" to "$ORIGINAL_CONFIG_FILE" (how did "fruit" get in there!?)
 
Old 09-28-2008, 12:43 PM   #2
johnson_steve
Senior Member
 
Registered: Apr 2005
Location: BrewCity, USA (Milwaukee, WI)
Distribution: Xubuntu 9.10, Gentoo 2.6.27 (AMD64), Darwin 9.0.0 (arm)
Posts: 1,152

Rep: Reputation: 46
Wish I had found this a few weeks ago the taping makes no sense when you have mouse buttons. and the horizontal scroll goes back/forward in firefox which is also annoying. I find the vertical scroll nice though I missed not having a scroll wheel on my laptop and it's very convenient.
 
Old 10-13-2008, 11:39 AM   #3
Henry Higgins
LQ Newbie
 
Registered: Oct 2008
Posts: 1

Rep: Reputation: 0
Many thanks for this. It's working, or sort of: after booting up it works correctly, but if the laptop (an Apple iBook) is set to suspend, then woken up, tap-to-click is now turned on. Does anyone know how I can completely disable tap-to-click, so it doesn't re-enable itself after a Suspend?
 
Old 09-10-2009, 10:23 AM   #4
ehrenbrav
LQ Newbie
 
Registered: Aug 2009
Posts: 11

Rep: Reputation: 0
Debian - Disabling Tap-Click

Doing this for Debian took one more additional step for me. I had to add the line in the above section of xorg.conf:

Option "CorePointer"

I couldn't get it to work without this line.

I think one should also add the following to make sure the touchpad is using the synaptics driver if not already there:

Driver "synaptics"

All the other options you can use with the symantics driver are listed in the "man symantics" page.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable touchpad's tap click? fastestOS Slackware 3 08-26-2008 02:59 AM
Tap to click removal and Firefox question Wardub Slackware 3 05-24-2008 10:10 AM
Laptop tap to click prh Ubuntu 1 05-17-2006 09:03 PM
laptop touchpad - how to disable 'tap to click'?? Adrian Baker Linux - Laptop and Netbook 2 01-17-2006 06:15 PM
Touchpad won't tap-click Detour Linux - Laptop and Netbook 3 11-08-2004 09:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 12:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration