-   Ubuntu (
-   -   Hardware Drivers not detecting hardware correctly in Hardy (

adanedhel728 04-25-2008 10:47 PM

Hardware Drivers not detecting hardware correctly in Hardy
I installed Hardy and been messing around with it today and yesterday. I was having annoying problems with Compiz in the 64-bit version (see another topic I made), so I decided to try the 32-bit to see if it fixed it.

I tried the 32-bit version, but the Hardware Drivers window didn't correctly detect my video card, and it didn't detect my wifi card at all. It worked fine in 64-bit and in Gutsy. So I tried to reinstall 64-bit, but now it's STILL not correctly detecting it. I have no idea why it correctly detected it the first time or why it's not working now.

My specs are in my sig, but Ubuntu detects that my card is ATI Fire GL (even though it's not). If I try to enable it, it says to restart and still doesn't enable it. My wifi card is not detected at all.

A friend of mine is having the same problem. His wifi isn't detected and neither is his ATI card (his video card is very similar to mine).

adanedhel728 04-25-2008 10:50 PM

Oh, weird, it's suddenly working... I have no idea why...

adanedhel728 04-26-2008 03:22 AM

Well, I figured out how to fix this, and I thought I'd post it in case somebody else is having this problem.

After a fresh install, I didn't bother trying to install the proprietary drivers just yet. Instead I went to System->Administration->Update Manager. Then I hit "check," knowing full well that there would be NO updates, since this was just released two days ago. (Of course, hitting "check" has to be done with a current internet connection, which means if your wifi card isn't detected yet then you have to do it through hardwire).

For some reason, this tells Ubuntu what drivers you need. After doing this, even though I didn't actually update anything, it then correctly identified my video card and wifi card. I confirmed this on a computer of a friend of mine, who had the same problem.

All times are GMT -5. The time now is 01:53 PM.