LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-30-2008, 06:28 AM   #1
ricemark20
Member
 
Registered: Aug 2003
Location: Wauconda, Illinois, USA
Distribution: Slackware, OpenSuse, Arch Linux on Pi
Posts: 106

Rep: Reputation: 46
Hard drives not automounting in Intrepid


How do I get my hard drives to mount on startup?
I tried entering the appropriate lines from /proc/mounts in fstab
Code:
/dev/sdb1 /media/disk-2 vfat rw,nosuid,nodev,uid=1000,fmask=0077,dmask=0077,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,flush 0 0
/dev/sda1 /media/disk-3 fuseblk rw,nosuid,nodev,user_id=0,group_id=0,allow_other,blksize=4096 0 0
When I did that, everytime I went to those drives, they gave an error about not having the correct permissions

BTW, disk-3 is a SATA drive

Last edited by ricemark20; 12-31-2008 at 04:35 PM.
 
Old 12-30-2008, 09:07 AM   #2
David1357
Senior Member
 
Registered: Aug 2007
Location: South Carolina, U.S.A.
Distribution: Ubuntu, Fedora Core, Red Hat, SUSE, Gentoo, DSL, coLinux, uClinux
Posts: 1,302
Blog Entries: 1

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by ricemark20 View Post
When I did that, everytime I went to those drives, they gave an error about not having the correct permissions
What is the output of "mount" after you boot?

Are you trying to mount the drives as root, or as an unprivileged user?

If the latter is true, have you tried adding the "user" or "users" option to the mount options?

What does "dmesg | tail -n 50" show when you try to mount the devices?
 
Old 12-31-2008, 04:35 PM   #3
ricemark20
Member
 
Registered: Aug 2003
Location: Wauconda, Illinois, USA
Distribution: Slackware, OpenSuse, Arch Linux on Pi
Posts: 106

Original Poster
Rep: Reputation: 46
SOLVED: Hard drives not automounting in Intrepid

Code:
/dev/sdb1                                  /media/disk-1   vfat         rw,uid=1000,fmask=0077,dmask=0077  0  0  
/dev/sda1                                  /media/disk-2   ntfs         defaults                           0  0  
/dev/sdb2                                  /media/disk-3   ext3         rw,nosuid,nodev,uhelper=hal        0  0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HAL and fmask dmask in automounting ntfs-3g drives duryodhan Slackware 2 09-23-2008 02:42 PM
Drives Automounting! hey! help! juan manuel lobos Linux - Hardware 1 06-08-2006 01:26 PM
automounting CD-ROMs USB drives kushalkoolwal Debian 28 05-14-2006 06:18 PM
automounting pen drives saini_mw Linux - Hardware 2 04-03-2006 12:33 AM
Automounting Raid drives voldermort Linux - Newbie 3 10-02-2003 09:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 02:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration