-   Ubuntu (
-   -   GTK Apps ignoring chosen GTK theme (

TheStarLion 11-28-2009 05:44 AM

GTK Apps ignoring chosen GTK theme
As the Ubuntu channel doesn't have anyone who can help with this...

Since this morning, in a normal Gnome session, all of my GTK apps, menus and icons (except, oddly for the Gnome panel) are using the same drab and boring style that they use when they're running as root. Which they're not.
No one else uses this computer, and I've made no changes to any GTK-based or affecting settings, except to try to change the GTK controls, with no effect at all. So I cannot understand why this is happening.

Does anyone have a diagnosis, solution, or both?

tommcd 11-28-2009 06:26 AM

What theme are you using? If you don't like the orange-brown "human" theme, (does anyone like it??) you can go to: system > preferences > appearance, and select from several themes there.
You can find a great many other themes at:
Just extract them and copy the theme's directory to: /usr/share/themes.
You may find that some of those 3rd party themes work better that others though. It may be the theme itself that is at fault.

TheStarLion 11-28-2009 06:32 AM

I've been using the Shiki-Human GTK control theme, from the Shiki-colors repository, and the Humanity Icons, also from a repository. Neither has an updates at all.

I've already used Appearance to try changing the theme, but except for gnome-panel, everything ignores the selection, and reverts, as said, to the theme normally only used by applications running as root.

TheStarLion 11-28-2009 06:48 AM

Update: Reloading the window manager seems to have solved the problem.

tommcd 11-28-2009 06:50 AM

The Humanity icons are installed by default on Ubuntu since I have them and I did not install them. I just tested the Humanity icons and they seem to be working for me. You may find that some applications will ignore certain icons for one reason or another.
Do you have a link to the theme you are using? I will test it.

EDIT: I just saw your last post. You don't normally need to reload the desktop to get themes / icons to work; but if that fixed it then that is fine.

All times are GMT -5. The time now is 02:34 AM.