Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 08-16-2006, 12:54 PM   #1
LQ Newbie
Registered: Jun 2006
Location: chennai , india
Distribution: ubuntu
Posts: 26

Rep: Reputation: 15
gtk+2.0 installation problem(older glib version )

i was trying to install gtk-2.0.i installed the glib,atk,pango,and cairo libraries first.there were some errors but i sorted them out.when i tried ./configure on gtk-2.0,i got:

checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.12.0 atk >= 1.9.0 pango >= 1.12.0 cairo >= 1.2.0) were not met.Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.

now,i know i have the libraries installed(i did it just now!!).i tried giving PKG_CONFIG_PATH=/usr/lib:/usr/local/lib ./configure

but it did no good.
i then checked synaptics manager to see if gtk+2.0 could be installed using it.but though there were a lot of packages using gtk,there was no gtk package as such.
while checking synaptics i found that i have (strangely)libglib1.2 and libglib2.0-0 both installed on my system.i cant remove libglib1.2(coz it then removes xmms,geda and a lot of other packages that i need).but maybe this is causing ./configure to ignore the newer version of libglib.
being a newbie,i have almost exhausted the whole of my knowledge trying to fix this problem.
plz guide.
Old 08-16-2006, 01:37 PM   #2
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Rep: Reputation: 32
In Synaptic, having the packages frame focused, I typed "gtk". The first matching package was gtk2.0-examples.

Right-click: Properties: Dependencies - I think the package you're searching for is libgtk-2.0-0.
Or install gtk2.0-examples, so the dependencies will get installed altogether.

- BTW, it's really a bad idea to install programs manually when they exist in the repositories. You can corrupt your system that way, especially, if you're not exactly knowing what you're doing.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
removing an older glib version ashlesha Linux - Software 2 07-12-2006 08:18 PM
removing an older glib version ashlesha Linux - Newbie 1 07-12-2006 05:43 PM
GIMP Toolkit - Glib/GTK+ Version Problem lucky6969b Programming 1 01-05-2006 05:16 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
how to remove an older version of glib halamazoo Linux - Newbie 2 06-14-2004 10:42 AM > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 08:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration