-   Ubuntu (
-   -   Grub trouble, can't get menu to boot from CD into windows (

hot01 12-28-2007 10:54 PM

Grub trouble, can't get menu to boot from CD into windows
As I just wrote in the Newbie forum, I have a computer with Ubuntu (for the most part) and Windows (for a very small part). This came about because I was working with open source software developers and my son, who built the computer for me, prefers Ubuntu. It seemed like a great idea at the time. I'm going to justify myself here, because I've been surrounded by Windows-haters for years. The thing is, I'm a biker chick, and accountant, and I quilt in my free time. I don't fool around on computers other than just using off-the-shelf software. I have all the respect in the world for those of you who live by Linux, but I can't deal with it. I've moved across the country and I no longer have 'round the clock, face-to-face technical support. I just want my Windows back so I can use my quilting software and all the other applications that I'm accustomed to. I don't have the time or the inclination to become as enlightened as all of you.

That being said, I have a Windows XP SP2 installation CD. It's in the drive. When I boot, Grub (or something) sees the CD and tells me to hit any key if I want to boot with the CD. Nothing. Then Grub tells me to hit <esc> to get the menu. Nothing. I can get into CMOS before Grub starts, but nothing after that. It talks a big game about the menu but then just goes into Ubuntu regardless of the buttons I push.

I've looked at many forums and many threads in those forums. I cannot find my grub.cfg file to save my life. I have, however, found a file that looks similar in content. It's called menu.lst and here it is (with about 90% of it in comments):

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

# examples
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=d1b8d46d-2733-4bef-890f-9a1c3fd01365 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 7.10, kernel 2.6.22-14-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=d1b8d46d-2733-4bef-890f-9a1c3fd01365 ro quiet splash
initrd /boot/initrd.img-2.6.22-14-generic

title Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.22-14-generic root=UUID=d1b8d46d-2733-4bef-890f-9a1c3fd01365 ro single
initrd /boot/initrd.img-2.6.22-14-generic

title Ubuntu 7.10, kernel 2.6.20-16-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=d1b8d46d-2733-4bef-890f-9a1c3fd01365 ro quiet splash
initrd /boot/initrd.img-2.6.20-16-generic

title Ubuntu 7.10, kernel 2.6.20-16-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=d1b8d46d-2733-4bef-890f-9a1c3fd01365 ro single
initrd /boot/initrd.img-2.6.20-16-generic

title Ubuntu 7.10, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin


It's entirely possible that I would keep an Unbuntu partition and maybe one day learn something, but I have to be able to boot into Windows without trouble.

Can you help?


fuzzyworm 12-28-2007 11:10 PM

Looking at your menu.lst (which is the right file, by the way), it appears that it has not been set up to boot into an existing Windows operating system.

If you're happy to go ahead with the formatting, starting from the CD should have nothing to do with GRUB. The 'Hit any key to boot from CD' is part of the Windows Setup program. It may be a problem with it recognising your keyboard - is it USB? Can you get another keyboard from somewhere? (preferably PS/2).

Windows XP is fussy, if you're installing it, it has to be installed on a CLEAN computer, i.e. if you still want Ubuntu, you have to remove it first then add it later. Make sure you backup your /home partition.

Let me know how you get on.

hot01 12-28-2007 11:14 PM

My keyboard is USB. I went out and bought a keyboard that has a ps2 adapter. The computer does not recognize that at all, which is weird, because the last time I had this problem I used an old POS keyboard with PS2 and it worked. Anyway, it "sees" the keyboard well enough so that I can hit <delete> and get into the CMOS setup. Why can't it see it when I try to hit any key to boot from the CD?

jay73 12-28-2007 11:16 PM

OK, I see it's all Ubuntu so I take it that Ubuntu is all that is installed on that computer right now. In order to install windows, you'll need to enter BIOS and modify the boot order. From what I can infer, the computer is now set the boot off the hard drive; but in order to install an operating system, it needs to boot off the cd/dvd drive. GRUB, by the way, is in no way involved in installing windows. Once you see GRUB, you're already too far into the booting process.

You can enter BIOS by pressing a specific key as your computer starts booting. On most computers, that would be F2 or DEL. If not sure, pay close attention to the first messages that roll by as the computer boots - there is normally a hint somewhere near the bottom of the screen.

Once you've entered BIOS, select the heading that deals with boot order. You may have to search around a bit using the arrows, the Enter key and ESC. It is a list of -usually - three to five items, including floppy, cd, hard drive. Select the top item, press Enter and select your cd/dvd drive, press Enter. Return to the top menu by pressing ESC and save your changes (on most systems, F11 + Enter, but there should also be a menu).

Pop in your windows cd and reboot, it should work this time. Windows will overwrite Ubuntu but that's fine, since I see you have some doubts you probably won't mind. And you can always reinstall Ubuntu later on.

jay73 12-28-2007 11:19 PM


Why can't it see it when I try to hit any key to boot from the CD?
That could hint to a problem. Ubuntu has been known in a few cases to leave some bits on the MBR that prevent a windows install cd from running. If this is correct, you'll need to do some formatting first so that you can install to a clean drive.

kzutter 12-28-2007 11:19 PM

First of all - are you sure that the Windows disk is OK?

The 'Hit any key.." should boot into the CD ROM.

Do you have 2 CD ROM drives? Sometimes the boot will only work from one of them.

Does your keyboard work this early in the boot process? Can you arrow up and down in the grub menu?

Grub will not help you with booting from the disk - the boot from CD ROM has to happen before the grub menu appears.

fuzzyworm 12-28-2007 11:25 PM

It sounds like your keyboard being awkward - the CD is being accessed before GRUB, but for some reason not acknowledging your key press and referring the computer back to GRUB.

I think it's a fault in the USB drivers included in the early stages of the WinXP setup - I've experienced it before. Are you using the PS/2 adaptor already? If so, try without it, if not, try with it again. Otherwise, see if you can borrow a pure PS/2 keyboard from somewhere.

The more I see of this, the less it seems like a GRUB problem and more like a Windows XP setup issue. However, I don't think that option appears at all if you have a clean HDD, try formatting it first, once you've backed up your data.

hot01 12-28-2007 11:29 PM

OK. I can get into CMOS and the CD-ROM drive is the primary device. I don't know why it's asking for permission since it's listed like that. The CD is brand new from Newegg.

I guess I'll just format the drive. I won't be losing anything.

OK, so how do I do that - from Ubuntu?

syg00 12-28-2007 11:29 PM

Yep, the "boot from CD" message is from the BIOS - nothing to do with grub. And unfortunately that menu.lst has hiddenmenu set - so you don't get to see that either. Stupid bloody idea.

I suspect XP is actually booting, but bailing out without any messages.
From Ubuntu, on the top menu bar click "Appplications", then "Accessories", then "Terminal". Then enter this command (you'll need to enter your password) and post all the output

sudo fdisk -l
(that a lower case ell, as in list).

hot01 12-28-2007 11:35 PM

I'll give it a try. I suppose I'll be gone for a while. If you don't hear from me again, thank you!

syg00 12-28-2007 11:40 PM

That command I gave you is just giving us a list of your current setup - not doing anything else.
That'll come later ... :p

hot01 12-28-2007 11:42 PM

aclabough@0de1:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0003858c

Device Boot Start End Blocks Id System
/dev/sda1 1 15896 127684588+ 83 Linux
/dev/sda2 * 15897 19083 25599577+ 7 HPFS/NTFS
/dev/sda3 19084 19457 3004155 5 Extended
/dev/sda5 19084 19457 3004123+ 82 Linux swap / Solaris

wit_273 12-29-2007 12:05 AM

Before taking this advice wait for someone else to comment to verify what I am saying to be correct.

I have never duel booted with Windows but from my understanding, and from what is posted previously, Windows will not install on a system already running Linux-- you have to have a clean drive. You stated earlier that you do not have any data to worry about loosing so a format will not hurt anything. If you really have not data to worry about loosing then I would suggest trying to remove the partitions and then try rebooting to the WinXP cd. I find cfdisk easier to use the fdisk. So one option is to boot to an Ubuntu Live CD-- or any other Linux live CD. Using a live CD will get you booted without mounting any partitions. Then once booted open a terminal and run

once in cfdisk delete all partions. Then boot to the WinXP CD and proceed with installing.

My doubt comes in at the below statement--if this statement is correct then I do not know that cfdisk will help--as I am not sure how it handles the MBR.
Jay73 said earlier

Ubuntu has been known in a few cases to leave some bits on the MBR that prevent a windows install cd from running
I would find this odd, but as I have never tried to install Windows after I have a Linux distro loaded I am not sure. I think it goes against the spirit of OSS and Linux to prevent another OS from installing (but if Jay is correct and this is your problem my opinion is irrelevant)

I also have another doubt; your WinXP install CD. I suspect that the WinXP install CD may be your problem, maybe damaged not allowing it to run. If the CD is the problem taking my advice above does not solve your issue and further leaves the system with no OS until you get a good install CD. For this reason and the question on the MBR I stand by my first statement-- Wait for someone else to verify what I am saying is correct before taking this advice.

hot01 12-29-2007 12:28 AM

It needs an argument. It doesn't like cfdisk alone. I guess I'll wander off and see if I can find what other people do to format their hard drives.

syg00 12-29-2007 12:54 AM

Dunno what the problem is - everything looks o.k. with that fdisk listing.

If you *really* want to junk everything on that drive - and I mean everything, get back into a (Linux) terminal and enter this

sudo dd if=/dev/zero of=/dev/sda bs=1 count=510
Then install XP - you'd better hope that XP CD is good, because this will make your disk look unused, and if the install still fails, it ain't the fault of anything done to the disk in the past.

I hate advising this sort of thing without exhausting all other possibilities.
Be it on your own head ...:tisk:

All times are GMT -5. The time now is 05:01 PM.