LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-18-2005, 10:29 AM   #1
jonty-comp
LQ Newbie
 
Registered: Sep 2005
Location: Chesterfield, England
Distribution: Debian Sarge
Posts: 9

Rep: Reputation: 0
GRUB Error 21 when loading Ubuntu for first time


I've just tried installing Ubuntu but when it resterta for the first time, GRUB returns an Error 21. I know this means that it can't find the grub.conf file, but I don't know how to fix this. I used Windows XP's Recovery Console to get back into XP, but I can't access the GRUB files.

Here is my HDD layout:

1Gb IDE Boot Drive (FAT32)
8Gb SCSI drive
- 5Gb Windows XP Professional (FAT32)
- 3Gb Ubuntu (ext3)

I can't install GRUB in Windows, and I can't get the drivers for my SpeedTouch modem onto a Live CD, so I don't know what to do.

Please help!
 
Old 12-18-2005, 01:12 PM   #2
bwog
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Rep: Reputation: 15
Perhaps this helps: http://help.ubuntu.com/starterguide/...html#id2521253
a scsi drive is denoted with sd instead of hd. So, I would try: grub-install /dev/sda or grub-install /dev/sdb if I understand your description well.

Because you have so little space, you could consider buying a drive or installing a light version of ubuntu: https://wiki.ubuntu.com/InstallingXubuntu

Last edited by bwog; 12-18-2005 at 01:15 PM.
 
Old 12-19-2005, 09:37 AM   #3
jonty-comp
LQ Newbie
 
Registered: Sep 2005
Location: Chesterfield, England
Distribution: Debian Sarge
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bwog
So, I would try: grub-install /dev/sda or grub-install /dev/sdb if I understand your description well.
Well, that's what I would do, but the Ubuntu setup program installs GRUB automatically. When it's installing, it says that it's detected Windows XP Professional, Ubuntu Linux and FreeDOS. I don't have FreeDOS! May this be what's causing the problem?

Quote:
Originally Posted by bwog
Because you have so little space, you could consider buying a drive or installing a light version of ubuntu
I was initially planning on using XFCE, but I thought I should get Ubuntu up and running before I tried anything fancy.

Can I download the latest GRUB, save it to my Flash Drive, boot from a Live CD and install it that way?
 
Old 12-22-2005, 07:03 AM   #4
bwog
LQ Newbie
 
Registered: Nov 2005
Posts: 24

Rep: Reputation: 15
Ubuntu installs Grub automatically. With the method I gave above you can reinstall Grub where you want it, so that it starts up at boot. Afterwards you can edit grub if that is necessary.

It doesnt help to download Grub.

Xubuntu is not hard, install server and install ubuntu-desktop, follow this howto: https://wiki.ubuntu.com/InstallingXu...=%28xubuntu%29 . However, I would try to reinstall Grub first.
 
Old 01-27-2007, 12:54 AM   #5
the_quinn
LQ Newbie
 
Registered: Jan 2007
Posts: 1

Rep: Reputation: 0
I got past this - more problems

I installed Ubuntu 6.10 on an older machine (256MB PC100 memory), and I kept getting the 'Error 21' grub error on my first reboot. What got me past it was the discovery that I had put the CDROM drive on the primary IDE channel, and the hard drive on the secondary IDE channel. I swapped these around and then I got past that error.

But now I have a different error: It brings me to a busybox and prompts me with:

/bin/sh: can't access tty; job control turned off
(initramfs)

I'm looking into this last problem now...
 
Old 02-10-2007, 06:15 AM   #6
hardwired2001
LQ Newbie
 
Registered: Mar 2004
Posts: 4

Rep: Reputation: 0
I have a cheeky little fix for the grub Error 21 problem.

I was trying to install Ubuntu on my Dell Inspiron 3500 as I herd it had better wireless support. When I ran into the same problem. Since Ubuntu's Grub is a bit rubbish use another version instead!

The fix is, boot your laptop with a recuse cd , I this case I used one I had for fedora core 5 (I did try knoppix but that wouldn't work). When you boot up let it mount the drive, once your at prompt, type grub , then setup as normal. This takes account that you have /boot.. setup and you grub.conf/menu.1st setup. (go here to find that out - https://help.ubuntu.com/community/In...on/FromKnoppix) ie ->

grub> root (hd0,0)
-> or what every disk you want to install grub on.
then

grub> setup (hd0)

then "quit" grub and reboot.

I did say it was a cheeky fix, but it works!
Job done!

Last edited by hardwired2001; 02-10-2007 at 06:16 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub Loading, Please Wait......Error 18 Braytac Linux - Hardware 19 06-16-2013 02:16 AM
GRUB loading Error 17 cmlal Slackware - Installation 38 11-27-2010 03:21 AM
Error after loading Ubuntu from GRUB rapaport Ubuntu 7 06-09-2008 05:27 AM
Grub error 21 ubuntu devojo Linux - Newbie 5 03-17-2005 08:16 PM
GRUB loading statge2read error rollerhl Linux - General 2 03-05-2005 08:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 08:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration