-   Ubuntu (
-   -   Grub 1.5 Error 17 (

Cyphnar 12-31-2007 04:27 AM

Grub 1.5 Error 17
Ok, I had a dual core AMD Acer computer with xp media centre on it, The hard drive was pre-partitioned in two 60 gig chunks. I took the opertunity to play around with linux and ubuntu was the one i went for (seemed easiest). I Installed t and played a bit. Couldn't get my usb wireless thing to work thus it had no net access and i stopped using it.

Now I've built myself a new computer and it's all good, running fista :S but its going ok atm. My old computer has gone to be the family computer as the other family one needs a fresh install of the OS which can't be done due to special circumstances... ;) so they now have my old comp but it still had ubuntu on. I couldn't get in ubuntu as i didn't know my username or pass... but it was going to the grub 1.5 everytime and if u left it it would default on ubuntu. (I did make some backups for my comp when i first got it, i tried using them but after 91% it was asking for disc 2... i don't have a dsic 2,) however i managed to reinstall windows somehow (via grub.. )

I used Gparted or summit to go in and re-format the partiton making it NTFS(or summit) and deleting ubuntu (thats what i thought formatting would do...). However now i have a problem. It still goes to grub 1.5 however now it comes up with the error 17 message and hangs! What can i do?

Yeah I hope that makes sense, I thought it was best to tell you everything!


MoonMind 12-31-2007 04:48 AM

That error tells you that you indeed did wipe Ubuntu! But you didn't install anything new, so your MBR (master boot record) remained unchanged and still contains GRUB, the boot manager installed by Ubuntu. You can wipe the MBR (instructions here) or simply install something new on your new layout. If you install WinDoze, the MBR will be taken over anyway, if you install something else, make sure that the boot manager goes to the MBR (of the first HD, to be exact).


Cyphnar 12-31-2007 05:00 AM

I have windows installed already. But i can't get into anyhting because GRUB errors and just hangs. The only way i managed to reinstallwindows with no backupdisk was through GRUB1.5 it normally comes up with five options:

Run Ubuntu
Run Ubuntu recover
Mem test
Windows 2000/xp
Windows Media Centre

or something along those lines.. normally to get to windows you need to pick the last one, however if you pick the 2000/xp choice it reinstalls windows.

This is what I've done. I guess i really need to find that mysterious second backup disk, or is there another way?


Cyphnar 01-01-2008 07:16 AM

double post.. sorry.

I tried getting ubuntu to work.. but i didnd't i think i downloaded the wrong iso.. anyway I now have kubuntu working. So I can atleaset get into linux now (it's not installed using th live cd trial thing). I think i found some other info on the net so I'll try that. If you know how to fix my problem from linux, then now would be a good time to post :) thanks guys.

Happy New Year btw.


Cyphnar 01-01-2008 10:29 AM

I got it fixed.

I downloaded free dos ( and by booting from that as a live disk i just put the following

A:\>fdisk \mbr
I'm not sure why it defaulted to A, but that overwrote the mbr file and now the computer doesn't have the grub screen, it loads straight to windows and now has the two partitions.

thanks for your help

All times are GMT -5. The time now is 02:35 PM.