-   Ubuntu (
-   -   GPG error, no public key (

pr5439 07-31-2009 11:59 AM

GPG error, no public key
hi, i earlier had used ubuntu 8.04 earlier, but after upgrade to 8.10, some startup problems occured, so i uninstalled it.
after few months when i m again using 8.04 nd i m getting some problems like:
i) vlc 0.9.2 was not getting installed by apt-get way, although i typed following in the terminal:

sudo wget -O /etc/apt/sources.list.d/medibuntu.list

wget -q -O- | sudo apt-key add - && sudo apt-get update
all i m getiing the message is vlc 0.8.6e is the latest version available, although i used 0.9.2 earlier the same way.

ii)system update always leaves following error:

GPG error: hardy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 71346C8340130828
any help in these matters are are extremely appreciated.......

GrapefruiTgirl 07-31-2009 12:09 PM

I'm not sure of the ins & outs of apt-get, nor how exactly it works as far as keys goes, but perhaps if you manually import the key yourself, it would solve the problem?

Try in a console as root:

gpg --recv-keys 71346C8340130828

.. and then try getting the package(s) you are having trouble with.

Hope this helps for the meantime, until/unless someone can explain exactly why this is happening for you..


PS - you can truncate the first bunch of characters off of that key if you like; gpg only needs the last EIGHT characters to identify the key.

pr5439 07-31-2009 12:28 PM

thanks GrapefruiTgirl for reply, i tried your way but i got following error

root@priyaranjan-laptop:~# gpg --recv-keys 71346C8340130828
gpg: directory `/root/.gnupg' created
gpg: new configuration file `/root/.gnupg/gpg.conf' created
gpg: WARNING: options in `/root/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/root/.gnupg/secring.gpg' created
gpg: keyring `/root/.gnupg/pubring.gpg' created
gpg: no keyserver known (use option --keyserver)
gpg: keyserver receive failed: bad URI
the above was with update manager still on( i m editing my post now). with update manager closed, the key was retrieved, although i dont remember the exact output at that moment, but doing the same again i get the output as:


root@priyaranjan-laptop:~# gpg --recv-keys 71346C8340130828
gpg: requesting key 40130828 from hkp server
gpg: key 40130828: "Launchpad PPA for Christoph Korn" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
but the strange thing is, again on updating the update manager, the errors are same, i have no idea as to what does it mean....

any way thanks......

brjoon1021 08-06-2009 11:30 AM

You are going to love this:

pr5439 08-07-2009 07:27 AM

thanks brjoon1021, but the link does no change in the error, it remains same as it was

brjoon1021 08-07-2009 09:08 AM

You are sure that the script ran in a terminal and displayed the fact that it found all of the keys ?

pr5439 08-08-2009 06:14 AM

sorry, my mistake, the gpg errors got solved magically by that link, must be a network problem earlier. thanks..
may b i m expecting a lot, does anyone anyone has the vlc solution i've posted earlier?

brjoon1021 08-08-2009 12:24 PM

not specifically, but PPAs are a pain in the butt. I have had them change the keys on me for no reason and then updates spit out the no signing key error. Just google for VLC PPA and then download the signing key. It is a guy's name if I remember that one correctly then open synaptic, go to authentication and look for that same key. Assuming that you already have it, but that it is old, you can delete it and then import the new one that you just downloaded. You should be good. That script worked for you, then... I thought it was awesome. I have 9 or ten PPAs and it found them all on my last install, but I can get it to do crap for me now for some reason.

pr5439 08-12-2009 10:32 AM

yup, u were right, i checked the launchpad for vlc here, the source list lines were different from actually what i had been using, i changed those and it worked.
Thanks all.

All times are GMT -5. The time now is 02:19 PM.