LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 06-27-2005, 01:29 PM   #1
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092
Blog Entries: 1

Rep: Reputation: 90
Question Gnome sessiosn doesn't start


Since I installed ubuntu at a computer at the office, I haven't been able to start gnome. I do get the gdm screen asking for the username and the password, and once I "login", it appears just like it's gonna start gnome.... but it doesn't. I get a plain brown screen with the arrow... and that's it. I have to ctrl+alt+backspace in order to be able to go to the gdm main screen again.

What's going on?

Last edited by eantoranz; 06-27-2005 at 02:30 PM.
 
Old 06-27-2005, 02:27 PM   #2
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 49
Can't start GNOME and Screen Resolution are not related as far as I am concerned.
 
Old 06-27-2005, 02:30 PM   #3
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
I never said they were, man.
 
Old 07-01-2005, 09:14 PM   #4
JonesStarr
LQ Newbie
 
Registered: Jul 2005
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Unhappy

I'm having that very same problem. I just recently installed Ubuntu to create a dual-boot system with XP. Ubuntu runs on the master hard drive with XP running as the slave. I had no problems running Ubuntu through its first run (the install and such) but after I updated it and rebooted it's been giving me that blank screen with the arrow. I can't get it to do anything!

I'm new to Linux and this is driving me insane! It was working fine the first time and all I did was update it. Does anyone out there have any ideas? keep in mine I know *nothing* about Linux so I may ask what seem like really dumb questions.

Last edited by JonesStarr; 07-01-2005 at 10:20 PM.
 
Old 07-02-2005, 12:55 AM   #5
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
See the error messages in /var/log/Xorg.0.log and ~/.xsession-errors (in your home directory). If there are any error messages, post them here.
 
Old 07-02-2005, 02:11 AM   #6
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
I have my very own theory.... but haven't been able to prove it: The screen resolution has to be over 640x480 (which is the actual resolution X is getting). Perhaps someone could say wether I'm wrong.

Once I get to run X in 800x600 (or more) I'll tell you... but that won't be soon, I guess. So I won't be confirming in a while.
 
Old 07-02-2005, 11:27 AM   #7
JonesStarr
LQ Newbie
 
Registered: Jul 2005
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Well I got my screen resolution to go over 600x400 and it'll still lock up. Pressing ctrl alt backspace lets me go back to the login screen. It'll let me go back to the login screen and after a few tries I can get in. To fix the resolution I had to get the Nvidia drivers for my machine. No biggie. Once I figure this out and how to get XP to load from Grub I'll be all set. But one problem at a time..

Here is what my xsession error file said:

/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "jonesstarr"
/etc/gdm/Xsession: Beginning session setup...
SESSION_MANAGER=local/Box:/tmp/.ICE-unix/8547

** (gnome-cups-icon:8643): WARNING **: failed request with status 1030

** (gnome-cups-icon:8643): WARNING **: failed request with status 1030

** (gnome-cups-icon:8643): WARNING **: failed request with status 1030
manager.c/925: New Device: /org/freedesktop/Hal/devices/usb_device_4a9_1084_120_-1_307G46
manager.c/925: New Device: /org/freedesktop/Hal/devices/usb_usb_device_4a9_1084_120_-1_307G46_0
manager.c/925: New Device: /org/freedesktop/Hal/devices/usb_usb_device_0_0_206_-1_0000:00:02.0_0
manager.c/925: New Device: /org/freedesktop/Hal/devices/pci_10de_64
manager.c/925: New Device: /org/freedesktop/Hal/devices/pci_10de_60
manager.c/925: New Device: /org/freedesktop/Hal/devices/pci_10de_1ef
manager.c/925: New Device: /org/freedesktop/Hal/devices/pci_10de_1ec
manager.c/925: New Device: /org/freedesktop/Hal/devices/pci_10de_1ed
manager.c/925: New Device: /org/freedesktop/Hal/devices/pci_10de_1ee
manager.c/925: New Device: /org/freedesktop/Hal/devices/pci_10de_1eb
manager.c/925: New Device: /org/freedesktop/Hal/devices/pci_10de_1e0
manager.c/925: New Device: /org/freedesktop/Hal/devices/legacy_floppy_0

** (gnome-cups-icon:8643): WARNING **: failed request with status 1030

** (gnome-cups-icon:8643): WARNING **: failed request with status 1030

And it just kept repeating (gnome-cups-icon:8643): WARNING **:failed request with status 1030 down the rest of the page. There were no errors in Xorg.0.log that I saw.

Any ideas?
 
Old 07-03-2005, 08:06 AM   #8
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
I'm no expert, but it seems this "Hal" is causing some problem. Try unplugging your USB devices and starting gnome.

I wonder why hardware is being detected when you start X
 
Old 07-03-2005, 09:50 AM   #9
ingvildr
Member
 
Registered: Mar 2005
Location: England, South East
Distribution: Fedora
Posts: 358

Rep: Reputation: 30
Quote:
I'm having that very same problem. I just recently installed Ubuntu to create a dual-boot system with XP. Ubuntu runs on the master hard drive with XP running as the slave. I had no problems running Ubuntu through its first run (the install and such) but after I updated it and rebooted it's been giving me that blank screen with the arrow. I can't get it to do anything!
It might be its not starting up services, can u do anything? like right click or get up a terminal?
 
Old 07-03-2005, 03:52 PM   #10
JonesStarr
LQ Newbie
 
Registered: Jul 2005
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Ingvildr, sometimes I can right-click and get a terminal (once or twice) but most of the time it just gives me a whole lot of nothing. I have to hit ctrl + alt + backspace to re-login or I'll have to reboot. Then again, sometimes it'll boot up just fine on the first try! It's all very confusing.
 
Old 07-04-2005, 03:34 AM   #11
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Another suggestion: When you login from gdm, click on "session" and select "Gnome Failsafe"
 
Old 07-04-2005, 10:35 AM   #12
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
I tried that one. It didn't work. :-(
 
Old 07-04-2005, 05:00 PM   #13
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
This is getting better and better. I tried starting gnome in a vnc server. When I get in the VNC session, I only get to see a console. The console is gnome-terminal. The only sign of gnome by the time.

When I try to run gnome-session from that console. I get this output:

Code:
$ gnome-session
_IceTransmkdir: ERROR: Owner of /tmp/.ICE-unix must be set to root
_IceTransSocketUNIXCreateListener: mkdir(/tmp/.ICE-unix) failed, errno = 1
_IceTransMakeAllCOTSServerListeners: failed to create listener for local

** (gnome-session:8258): WARNING **: Cannot establish any listening sockets
This is VNCs log file right after starting:
Code:
$ cat .vnc/proxy\:1.log
04/07/05 16:47:39 Xvnc version 3.3.tight1.2.9
04/07/05 16:47:39 Copyright (C) 1999 AT&T Laboratories Cambridge.
04/07/05 16:47:39 Copyright (C) 2000-2002 Constantin Kaplinsky.
04/07/05 16:47:39 All Rights Reserved.
04/07/05 16:47:39 See http://www.uk.research.att.com/vnc for information on VNC
04/07/05 16:47:39 See http://www.tightvnc.com for TightVNC-specific information
04/07/05 16:47:39 Desktop name 'X' (proxy:1)
04/07/05 16:47:39 Protocol version supported 3.3
04/07/05 16:47:39 Listening for VNC connections on TCP port 5901
Font directory '/usr/X11R6/lib/X11/fonts/Speedo/' not found - ignoring
xrdb: No such file or directory
xrdb: can't open file '/home/antoranz/.Xresources'
Advertencia del gestor de ventanas: Log level 32: could not find XKB extension.
La opción --login ya no es soportada en esta versión de gnome-terminal; quizá deba crear un perfil con la opción que desea configurar y usar la opción «Ventana nueva con perfil»
The last message says something like: The option --login is no longer supported in this version of gnome-terminal; perhaps you should create a profile with the option you wish to configure and use the option <<New window with profile>>".

Do you think we can solve the whole thing now? :'(
 
Old 07-04-2005, 05:05 PM   #14
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
I tried gnome-wm, but it says there's another WM already started.

I tried with --replace, but It had exactly the same output.
 
Old 07-05-2005, 01:15 AM   #15
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Quote:
Originally posted by eantoranz
This is getting better and better. I tried starting gnome in a vnc server. When I get in the VNC session, I only get to see a console. The console is gnome-terminal. The only sign of gnome by the time.
<snip>
Code:
$ gnome-session
_IceTransmkdir: ERROR: Owner of /tmp/.ICE-unix must be set to root
<snip>
<snip>
Try doing this:
Code:
# chown -R root /tmp/.ICE-unix*
Then try to start gnome in a vnc server.
If it still doesn't work, try renaming the .ICE-unix directory
Code:
# mv /tmp/.ICE-unix /tmp/.ICE-unix_bak
If it still doesn't work, close your eyes, take a deep breath and think of a happy little elf in fairyland
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome-panel won't start after upgrade to GNOME 2.6 computergeek84 Debian 5 08-12-2007 02:37 PM
I want gnome! My gnome doesnt start anymore! :( maginotjr Slackware 2 07-09-2005 04:06 PM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 09:53 PM
How do you start Gnome under X? Ekim Gram Linux - Newbie 1 04-10-2004 05:03 PM
why start always with gnome? prowlerxpla Linux - Software 0 09-11-2003 10:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 06:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration