-   Ubuntu (
-   -   gcc will not execute, responds with 'no such file or directory' and 'no input file' (

nckeecho 01-06-2009 08:33 PM

gcc will not execute, responds with 'no such file or directory' and 'no input file'
I am running Ubuntu 8.04 LTS on a Dell 1525n laptop. I don't know what I have to do to get gcc to execute. I have several utility programs written in 'C' that I want to compile on my laptop but each invocation yields 'no such file or directory' and 'no input file' error messages.

I have a desktop computer running Fedora 8 with KDE and I have never
encountered problems of this sort. Gcc executes just fine and has starting with the first version of Linux I installed (Red Hat version 5 or something like that as I recall).

I am strongly tempted to replace Ubuntu with Fedora 10 but don't want to run the risk of voiding the warranty on my laptop.

To be candid, I'm not thrilled with Ubuntu but will try to muddle on.

Thanks in advance for any and all advice.

Keith Haslip

{BBI}Nexus{BBI} 01-06-2009 09:02 PM

Do you have the package build-essential installed?

knudfl 01-06-2009 11:18 PM

Welcome to Linux Questions.

sudo apt-get build-essential

will get you the most.

Good luck !

nckeecho 01-07-2009 11:26 AM

build-essential is installed, still no joy

knudfl 01-08-2009 02:04 AM

Well, try this command : gcc -v
If you get an output, gcc is probably working.

Being no "search machine" , gcc needs to know,
where the file to handle is located.

Either with the command 1) ' cd /home/nckeecho/my_c_programs/ '
( or wherever the source file is located. )
And next 2) ' gcc codename.c ' .

Or the full path : gcc /home/nckeecho/my_c_programs/c_code.c
Please use actual names for directories and files and without
the quote marks.

nckeecho 01-08-2009 06:53 PM

Thanks for all your help. Problem solved.

{BBI}Nexus{BBI} 01-08-2009 07:37 PM


Originally Posted by nckeecho (Post 3401734)
Thanks for all your help. Problem solved.

Please post the solution (to help others) if it is not already present in this thread.

knudfl 01-09-2009 11:17 AM

Or may be click the blue "Thumb up" in the post
with the solution ??

nckeecho 01-10-2009 01:18 PM

To be honest, I don't know exactly what fixed the problem.
I did the following:
1. Confirmed that build-essential was installed.
2. Executed gcc -v which pumped out some output.
3. Invoked gcc with one of my 'c' programs and it worked - I had an executable! That was the resulted I wanted, don't know why gcc worked the last time.

Spoke too soon. This morning Ubuntu informed me updates were available so I installed them. Apparently something in the update package broke gcc so now I have to install the fixes that restore audio and, hopefully, fix my gcc problem. As I stated in an earlier post, I'm becoming less than thrilled with Ubuntu.

nckeecho 07-24-2016 01:04 PM

Sorry for the delay of my reply. Problem is fixed. Fix probably occurred somewhere along the upgrade path from Ubuntu 8.04 to Xubuntu 16.04 LTS. Once again, thanks to all who responded.

All times are GMT -5. The time now is 05:55 PM.