-   Ubuntu (
-   -   Flash Player Plugin w/ Firefox (

opticks 11-25-2011 01:29 PM

Flash Player Plugin w/ Firefox
before I go on to describe my problem, let me first illustrate how much energy I have spent that I have nothing to show for so that you may understand my frustration:

BFRWBNFB 'OHJBb'kjncbfshbofjharlngmdsiovhrbg

I hope from this you can infer that I both know Google exists and that I have exhausted that resource. I prefer Google because its faster than waiting for human response, but human response is often much more valuable than what Google has to offer. Please dont prove me wrong by telling me to do a search.
now that we are on the same page...

here is the situation:
I am running a 64 bit version of Ubuntu, with what I believe is a 64 bit version of Firefox.
I cant tell you for sure that Firefox is 64 bit as I dont know the proper command. I actually had someone tell me that if Im running 64 bit Ubuntu, all my programs are 64 bit...

I have never had a working Flash Player on this distro.
I had a version of flashplugin-nonfree installed, as well as nspluginwrapper.
I ended up removing both of these in my quest.
I had tried to use that add-on "flash-aid" version 2.2.1 which is supposed to automatically detect and remove old or incorrect flashplayers for linux and download the correct ones.
All it did was give me a pop-up in the corner upon first launch telling me it was outdated, and then gave me nothing to click on, no link, no action. Nothing in the preference in the add-on tab for it either.
I have downloaded Flashplayer 11 from Adobe, extracted, and added it to half a dozen directories, all some variant of mozilla/plugins in one suggested location or another. None of that yielded any results.
"About : plugins" shows nothing detected/enabled
The plugins tab on the Add-ons menu shows the same.

I have tried this all under FF7, and after failing at all of these I retried them under FF8. My next step is going to be to post this, update my kernel and FF from the repositories, and see if I can get some helpful feedback on here.

I have seen many tutorials, some of them are hard to follow even for a tech like me, but most refer to firefox 3.x, and im really trying to avoid that route. I really like my cornucopia of add-ons and their configurations and if I could keep them all it would be amazing. Thanks in advance for any help or suggestions,


Roken 11-25-2011 03:46 PM

First and foremost, let's check that you have tried the latest release of Flashaid - latest version is 2.2.1 and is available from

If your version is older, remove it and reinstall from that website. Once installed, restart FF and you should have the icon on a toolbar somewhere (not sure if I moved mine, so I don't want to say where it will be exactly).

Once you locate the icone, clicking and holding on the icon should pop up a menu, whilst clicking and releasing will open the window. I recommend click and hold, then choose wizard mode for the first go.

See how far that gets you.

eSelix 11-25-2011 03:58 PM

First check that you have 64 bit version with "about:buildconfig". In "Target" you should see something like "x86_64". Next quit Firefox and remove old flash related stuff, check these directories:


Next check "nspluginwrapper -l". If something with "flash" in name is there delete it. Next copy extracted "" from Adobe site (be sure to select 64 bit version) to "/usr/lib/firefox-addons/plugins". Start Firefox and check "about:plugins".

opticks 11-25-2011 04:13 PM

I had 2.2.1, tried to reinstall anyways from the link you gave me, but instead of firefox handling it beautifully it wanted me to save the .xpi and i really didnt want to open a second can of worms (if i cant install a plugin manually i dont want to try to install an add-on manually) but thankfully version 2.2.1 is on the firefox site and it did its beatiful thing for me.

Same thing happened but i clicked customize on the context menu on the add-on bar and the FlashAid icon just hadnt populated itself, so all I had to do was drag it over and fire up the wizard, it seems to be handling EVERYthing rather beautifully (in progress).

My firefox is 64, I had thought it was because that "x86_64" was in my user agent. FlashAid deleted from the /usr/lib/firefox-addons/plugins directory that i created and installed the new one, so I'm assuming I was close to your solution eSelix, I just missed something with the nspluginwrapper.. either way, thanks to both of you! I will post back with what happened and what worked/didnt and mark as solved if all goes well so others can learn from my adventure

Roken 11-25-2011 04:29 PM

For future reference, add ons are a doddle from xpi (provided they are compatible). You just go to menu/ Add Ons, click the little menu on the add ons page and select "Install from file". Find the downloaded xpi and voila.

Just for info. :)

opticks 11-25-2011 04:40 PM

thanks for the .xpi tip, ill keep that in mind.

I did have a minor complication, the script FlashAid generated/executed wasnt able to move to /home/.mozilla/plugins because the directory wasnt there. you would think it would create it, but it wasnt a big deal to close it all out, create it, and re-run the wizard. Worked like a charm, watched a funny youtube video "things that ruin thatnksgiving" to celebrate.

Thanks again you guys! I still cant forget when i typed "about: plugins" and hit enter and it was THE SEXIEST THING I HAVE EVER SEEN!!!

Roken 11-25-2011 08:42 PM

Glad you got there :) - if you really want to celebrate watch Life in a Day on YT - much better than you would think, but more than 1.5 hours.

All times are GMT -5. The time now is 07:34 PM.