-   Ubuntu (
-   -   fglrx + xgl + compiz = crash (

jimerickso 09-06-2007 08:36 AM

fglrx + xgl + compiz = crash
when i run xgl from gdm, compiz will run for about 2 seconds then it kicks me back out to gdm. if i "/etc/init.d/gdm restart" and run "sudo startxgl" compiz will run fine except i am root which is not good. if i "etc/init.d/gdm restart" and run "startxgl" it gives the error "xf86OpenConsole: cannot access /dev/tty0: no such file or directory". can anyone explain what is going on? i will gladly post any requested data. thank you for your consideration in this matter. i am using:
msi k7n2 motherboard
visiontek radeon x1600 xt gamer edition agp video card
fglrx 8.40.4

davesmith 09-06-2007 02:48 PM

Hmm, ok

There has been issues with ATI and xgl. As far as I'm aware, they aren't resolved. I have to disable xgl on my debian distro cause it wouldn't play videos at all, X would just crash.

Can't explain what you're seeing... I have this link to the Unofficial ATI wiki,, so have a quick check around there too.

jimerickso 09-06-2007 03:43 PM

thanks for the suggestion but there is not much about it there. i still don't understand why compiz will run as root and not user in xgl. if one works shouldn't the other?? i'm stumped...

davesmith 09-06-2007 03:58 PM

yes, you're right there. I'm suprised. I've not tried it on my computer though... Maybe I will tonight. (if I can stand breaking my computer!)

anything in the kernel log (dmesg) when X stops?

jimerickso 09-06-2007 04:19 PM

just the following:

[ 906.088854] [fglrx] PCIe has already been initialized. Reinitializing ...
[ 906.120106] [fglrx] total GART = 134217728
[ 906.120123] [fglrx] free GART = 118226944
[ 906.120128] [fglrx] max single GART = 118226944
[ 906.120132] [fglrx] total LFB = 268304384
[ 906.120135] [fglrx] free LFB = 215863296
[ 906.120139] [fglrx] max single LFB = 215863296
[ 906.120142] [fglrx] total Inv = 268435456
[ 906.120146] [fglrx] free Inv = 268435456
[ 906.120150] [fglrx] max single Inv = 268435456
[ 906.120153] [fglrx] total TIM = 0

keep in mind my card is agp not pcie.

All times are GMT -5. The time now is 09:46 PM.