LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 11-15-2005, 04:31 PM   #1
iainagray
Member
 
Registered: Sep 2003
Location: Aberdeenshire, Scotland
Distribution: Ubuntu Hardy
Posts: 64

Rep: Reputation: 15
Angry Failure of sound and PCMCIA modem after Kernel compile


Help me please, I have an old Sony VIAO laptop PCG-735 with a Pentium MMX processor. I run Hoary Hedgehog and have installed Ice as my window manager to increase response times from the old hardware. I was a Mandrake 9.2 user before and with the standard 2.4 kernel my sound card worked after using the RH "sndconfig" comand with the sound being Soundblaster compatible. With Mandy I never successfully compiled a kernel (either 2.4 or 2.6) from source.

I followed the kernel howto on the ubuntu wiki site with some success, though the new kernel image I am still unable to get my sound card to work with the 2.6 kernel and even though the PCMCIA was compiled in my Xircom modem is not recognised and does not work.

I know this is 2 separate problems, but having a processor specific kernel might eek out some extra performance, I can almost live without sound, but cannot live without my internet connection.

Cheers all
 
Old 11-29-2005, 11:40 AM   #2
ankscorek
Member
 
Registered: Mar 2003
Distribution: Slackware10.2,SUSE,FC,RHL,Vector Linux,WHAX,PHLAK,bt4,ubuntu,debian,aptosid,backtrack,blackbuntu
Posts: 529

Rep: Reputation: 31
i think u have not built the sound modules in your kernel properly..
 
Old 11-29-2005, 12:20 PM   #3
ssfrstlstnm
Member
 
Registered: Dec 2004
Location: IN, USA
Distribution: debian etch
Posts: 402

Rep: Reputation: 30
Either you don't have the modules loaded or you do not have support for the devices in the kernel. Please post the output of lsmod and lspci.

In the kernel, you will need support for alsa compiled into the kernel and also alsa-oss, alsa-mixer, alsa-sequencer, and the driver for your sound card compiled as modules. You don't want OSS support (which is not the same as alsa-oss).

Also check to see if there is support in the kernel for your modem.
 
Old 11-29-2005, 03:16 PM   #4
iainagray
Member
 
Registered: Sep 2003
Location: Aberdeenshire, Scotland
Distribution: Ubuntu Hardy
Posts: 64

Original Poster
Rep: Reputation: 15
Hi,

In addition to what you asked for the output to:

sudo cardctl status

returns:

no pcmcia driver in /proc/devices

The output to lsmod:

Module Size Used by
ipv6 228608 8
proc_intf 4100 0
freq_table 4100 0
cpufreq_userspace 4572 0
cpufreq_ondemand 6172 0
cpufreq_powersave 1920 0
video 16260 0
button 6800 0
ac 4996 0
battery 10244 0
ipt_state 2048 38
ipt_REJECT 6528 4
ipt_limit 2688 6
ipt_LOG 6656 6
ip_conntrack_ftp 72496 0
ip_conntrack 43540 2 ipt_state,ip_conntrack_ftp
iptable_filter 3840 1
ip_tables 17408 5 ipt_state,ipt_REJECT,ipt_limit,ipt_LOG,iptable_filter
analog 10784 0
ns558 5632 0
gameport 4608 2 analog,ns558
pcspkr 3816 0
rtc 12088 0
yenta_socket 19584 1
i2c_piix4 8464 0
i2c_core 21136 1 i2c_piix4
uhci_hcd 30224 0
usbcore 107640 2 uhci_hcd
dm_mod 54780 1
tsdev 7488 0
evdev 9088 0
psmouse 19336 0
mousedev 11160 1
lp 10792 0
ide_cd 38404 0
cdrom 36380 1 ide_cd
md 43728 0
ext3 120968 1
jbd 54040 1 ext3
ide_generic 1664 0
piix 9988 1
ide_disk 18048 3
ide_core 118732 4 ide_cd,ide_generic,piix,ide_disk
unix 26036 264
thermal 13576 0
processor 22708 1 thermal
fan 4612 0

The output to lspci:

0000:00:00.0 Host bridge: Intel Corp. 430TX - 82439TX MTXC (rev 01)
0000:00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:08.0 VGA compatible controller: Neomagic Corporation NM2160 [MagicGraph 128XD] (rev 01)
0000:00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c478 (rev 03)
0000:00:0a.1 CardBus bridge: Ricoh Co Ltd RL5c478 (rev 03)

Since posting I have upgraded to Breezy, but would still like the 2.6.10 kernel to work as an experiment, with a view to upgrading to a compiled 2.6.12 kernel when I can spare the bandwidth to download.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound after kernel compile? Erik_the_Red Linux - Newbie 5 08-14-2005 02:30 PM
no sound after 2.6.9 kernel compile necbrownie Slackware 4 11-04-2004 05:22 PM
Sound lost after kernel compile oneandoneis2 Slackware 31 05-21-2004 05:03 AM
Kernel 2.6.3-rc2 compile error/Failure- Any Ideas? wrc1944 Linux - General 2 02-15-2004 04:38 PM
sound after kernel compile e1000 Slackware 5 10-24-2003 01:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 08:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration