LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Closed Thread
 
Search this Thread
Old 07-13-2010, 02:38 PM   #1
w00ly
Member
 
Registered: Aug 2009
Posts: 31

Rep: Reputation: 15
External HD wont dismount


I have a 100gb external USB hard drive. I downloaded about 50gb of files to it. I had transmission downloading a torrent to it but it was taking a long time so I stopped it about 2 hours ago.

I closed transmission a half hour ago and tried to dismount the drive. Now I'm getting "Writing data. To prevent data loss wait until this has finished before removing or disconnecting media". It's been sitting at this for about half an hour now and I need the drive! I have no idea what it's writing but it shouldnt be writing anything...there wasnt anything that was being transfered to/from the drive. How do I safely dismount this thing? It seems like the "safe dismount" is stuck

Basically fresh installation of 10.04. Any help whatsoever is greatly appreciated!!
 
Old 07-13-2010, 03:34 PM   #2
jtarin
Member
 
Registered: May 2010
Location: Vladivostok, Russia
Distribution: Slackware 13.0, Linux Mint 17.0
Posts: 97

Rep: Reputation: 22
You have tried right-clicking the icon for the drive on the desktop and it has no effect?

You cannot unmount from the desktop by right clicking the icon if the drive was manually mounted.

Assuming your device is labeled /dev/sdb1 mounted at /media/external, you can either unmount using the device or the mount point:

Code:
sudo umount /dev/sdb1
or:

Code:
sudo umount /media/external
 
Old 07-13-2010, 03:44 PM   #3
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
W00ly,

This is a double post of your existing thread here: http://www.linuxquestions.org/questi...smount-819660/
which already has many suggestions.

Please don't double-post, it's very annoying.

Reported for merging /closure
 
Old 07-13-2010, 04:11 PM   #4
w00ly
Member
 
Registered: Aug 2009
Posts: 31

Original Poster
Rep: Reputation: 15
I tried both of those. Someone in another forum suggested shutting down so I shutdown with the icon in ubuntu. It closed all programs and stopped at the wallpaper. I was able to SSH into the system and I tried killing processes that might be associated with it. Also tried sync. Neither worked. So I issued "sudo shutdown now". Finally got the system to go off. After rebooting I could see the files appeared to be in tact.

However when i unmounted (cleanly this time) and connected the drive to my windows PC, windows would not mount the drive nor could I see any data! It appears something has been corrupted :\ Any suggestions on how to fix my drive?
 
Old 07-13-2010, 04:13 PM   #5
w00ly
Member
 
Registered: Aug 2009
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tredegar View Post
W00ly,

This is a double post of your existing thread here: http://www.linuxquestions.org/questi...smount-819660/
which already has many suggestions.

Please don't double-post, it's very annoying.

Reported for merging /closure
Sorry for double posting...it's just time is somewhat of an issue so I was hoping to get it seen as much as possible. I also posted over at ubuntuforums :\
 
Old 07-13-2010, 04:23 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,763

Rep: Reputation: 719Reputation: 719Reputation: 719Reputation: 719Reputation: 719Reputation: 719Reputation: 719
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.

Continue here
http://www.linuxquestions.org/questi...smount-819660/
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
replaced DLT drive caused Sol 9 to dismount /d02, dsironi Solaris / OpenSolaris 0 10-30-2009 04:01 PM
Windows dismount for fresh Linux start? SmilerUK Linux - Newbie 5 07-13-2008 11:53 AM
external hd wont mount. tyfobpo Linux - Hardware 2 10-12-2007 05:58 AM
-zxvf stair dismount .tar.gz- now what? phreakshew Linux - Games 8 04-15-2007 05:34 AM
CD Dismount error TuxToaster Fedora - Installation 3 09-19-2006 10:36 PM


All times are GMT -5. The time now is 01:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration