LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (https://www.linuxquestions.org/questions/ubuntu-63/)
-   -   external firewire hard drive is read only (https://www.linuxquestions.org/questions/ubuntu-63/external-firewire-hard-drive-is-read-only-621174/)

roofninja 02-14-2008 05:48 PM

external firewire hard drive is read only
 
I am having problems with my external hard drive. It is a firewire drive. When I turn it on and the PC sees it, all the files are read only. What am I doing wrong? Thanks for any help.

mtab:
/dev/sdb1 /media/disk vfat rw,nosuid,nodev,shortname=mixed,uid=1000,utf8,umask=077,usefree 0 0

biophysics 02-14-2008 06:13 PM

This is what I have in mine:
/dev/sda2 /media/disk rw,uid=1000,gid=1000 0 0

Can see if your uid is 1000 ? Type in a console

$ id

and see. Otherwise can you post

$ cd /media
$ id
$ ls -l

jschiwal 02-14-2008 07:37 PM

Quote:

Originally Posted by roofninja (Post 3057303)
I am having problems with my external hard drive. It is a firewire drive. When I turn it on and the PC sees it, all the files are read only. What am I doing wrong? Thanks for any help.

mtab:
/dev/sdb1 /media/disk vfat rw,nosuid,nodev,shortname=mixed,uid=1000,utf8,umask=077,usefree 0 0

The usefree option is one I'm not familiar with. According to your posted mtab entry, it is read-write for the user with a uid of 1000.

When I searched on Google for the "usefree" option, I found this patch. It sounds like Ubuntu is using a new mount option but didn't update the HAL fdi policies to accommodate the change.
Code:

diff -Nur -x '*.orig' -x '*~' ubuntu/fdi/policy/10osvendor/20-storage-methods.fdi ubuntu.new/fdi/policy/10osvendor/20-storage-methods.fdi
--- ubuntu/fdi/policy/10osvendor/20-storage-methods.fdi    2007-08-27 17:34:05.000000000 +0200
+++ ubuntu.new/fdi/policy/10osvendor/20-storage-methods.fdi    2007-10-23 11:18:49.000000000 +0200
@@ -202,6 +202,7 @@
      <append key="volume.mount.valid_options" type="strlist">fmask=</append>
      <append key="volume.mount.valid_options" type="strlist">uid=</append>
      <append key="volume.mount.valid_options" type="strlist">flush</append>
+      <append key="volume.mount.valid_options" type="strlist">usefree</append>
    </match>
    <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="FreeBSD">
      <append key="volume.mount.valid_options" type="strlist">longnames</append>

You might grep for "usefree" on your system and see if that is the case.
Code:

locate '/fdi/policy/10osvender/'
# cd to the located folder
grep -R usefree *

If you don't find it, check if you have updated your system. If you have, you might want to submit a bug.

In the meantime, you could either decide whether this patch is correct and apply it yourself, or manually mount the drive without the "usefree" option.

----

Also check your "/var/log/messages" logfile. If there is a problem mounting a filesystem, the problem should be logged.

roofninja 02-16-2008 02:25 PM

Quote:

Originally Posted by biophysics (Post 3057322)
This is what I have in mine:
/dev/sda2 /media/disk rw,uid=1000,gid=1000 0 0

Can see if your uid is 1000 ? Type in a console

$ id

and see. Otherwise can you post

$ cd /media
$ id
$ ls -l

I checked my id and Yes my id is 1000.

roofninja 02-16-2008 04:26 PM

jschiwal:

I checked the system and yes it has the "usefree" stuff in the fdi files. It took me a while to find what you were talking about, but it was fun learning something new. You also asked me to check my logfiles and that is what I get:

Feb 16 16:10:57 nc-ub64 kernel: [ 289.121061] sdb: sdb1
Feb 16 16:10:57 nc-ub64 kernel: [ 289.128953] sd 6:0:0:0: [sdb] Attached SCSI disk
Feb 16 16:10:57 nc-ub64 kernel: [ 289.128975] sd 6:0:0:0: Attached scsi generic sg1 type 0

I didn't get any errors and the system keeps seeing it as read only.

roofninja 02-16-2008 04:41 PM

I ran a dmesg | tail and this is what I got.

[ 790.762350] sd 7:0:0:0: [sdb] Got wrong page
[ 790.762352] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[ 790.762354] sdb: sdb1
[ 790.767448] sd 7:0:0:0: [sdb] Attached SCSI disk
[ 790.767470] sd 7:0:0:0: Attached scsi generic sg1 type 0
[ 816.979080] FAT: Filesystem panic (dev sdb1)
[ 816.979083] fat_get_cluster: invalid cluster chain (i_pos 0)
[ 816.979086] File system has been set read-only
[ 851.053137] ieee1394: Node changed: 0-01:1023 -> 0-00:1023
[ 851.053143] ieee1394: Node suspended: ID:BUS[0-00:1023] GUID[0001a39500030316]

Maybe this is why the drive has been read only. How do I fix this?


All times are GMT -5. The time now is 07:41 PM.