-   Ubuntu (
-   -   eth0 connects to router but not to Internet(e.g. (

MadHatter21 07-25-2009 12:39 PM

eth0 connects to router but not to Internet(e.g.

I have been trying to get any sort of networking to run for the past 3 weeks trying every tutorial and how to on the web and these forums to no success. I am trying to get the ethernet to work on my netbook. I am running backtrack 4, not ubuntu, but since backtrack is completely based off of ubuntu now i thought you guys could help I have set up a connection to the router, but that is as far as i get. I can connect to and change the configurations on my router, but when I try google or anything else, i am not connected. Suprisingly I was looking at my ifconfig and i noticed that my eth0 has both ipv4 and ipv6,

Ifconfig eth0

eth0      Link encap:Ethernet  HWaddr 00:23:8b:d9:e1:b6
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::223:8bff:fed9:e1b6/64 Scope:Link
          RX packets:964 errors:0 dropped:0 overruns:0 frame:0
          TX packets:766 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:205766 (205.7 KB)  TX bytes:62703 (62.7 KB)
          Interrupt:26 Base address:0x8000

I am not really sure what to try next.

Any help is appreciated,

repo 07-25-2009 12:44 PM

Can you ping?

If that works, you probably need to add the DNS servers in /etc/resolv.conf.



MadHatter21 07-25-2009 12:52 PM

tried pinging google with no success.

About resolv.conf, tried to use cat on it and nothing was in it. Will it still work if i try that?

repo 07-25-2009 12:56 PM


doesn't work?
If you can't ping on IP, there is a problem with the configuration of the router or the gateway.
What is the output from

route -n
(as root)

MadHatter21 07-25-2009 12:56 PM


I love you, ha sorry for that just had to get it out!!!!!
It works! thank you sooooooooo mch!!!!
I swear to god, i just fell out of my chair. I love you!
WOW sucess thanks to REPO!!!

MadHatter21 07-25-2009 12:58 PM

I have one more question for you if you have time. How would i go about getting wifi to work if i have a atheros card. Madwifi? or ath5k?

Thank you soooooooooo much

repo 07-25-2009 01:05 PM

Did you tried to blacklist, as proposed in this thread?
To blacklist, add the module to

repo 07-25-2009 01:07 PM

For ubuntu, here is a guide

MadHatter21 07-25-2009 01:10 PM

Well i think it actualy might be a little easier then that. In iwconfig, i already have wlan0 so isnt there just some code like the ethernet to type in to get it working now? or do i have to do all of the blacklisting?

repo 07-25-2009 01:15 PM

Try to install wicd
To install WICD do the following: (for gutsy, edgy, or dapper replace feisty as needed)
as root:

echo 'deb feisty extras' | sudo tee -a /etc/apt/sources.list
sudo apt-get update
sudo apt-get install wicd

MadHatter21 07-25-2009 01:24 PM gave me a error 302 temporarily moved.
Failed to download?


Thankyou so much

repo 07-25-2009 01:31 PM

Seems to me the archive doesn't exist anymore
Try to download and install manually
open a terminal

sudo dpkg -i wicd_1.5.9-2_all.deb

You can remove the line you added to /etc/apt/sources.list

MadHatter21 07-25-2009 01:38 PM

Who ever you are i now idolize you. It worked and my network showed up. Tried to connect and it says required encryption enabled. How would i go about enabling it.

How did you learn all of this? You are very skilled, have you written a guide to linux? WOuld you consider writing one for me? haa.

repo 07-25-2009 01:42 PM

Click on the network you want to connect to.
Then click on properties.
Use encryption, choose the encryption you setup on the access point or wireless router, and give the key

MadHatter21 07-25-2009 01:46 PM

I am now completely on line, what took me 21 days took you an hour. Thank you so much, I was serious about the tutorial though, where did you learn or do you teach, Once again thank you for everything.

All times are GMT -5. The time now is 10:03 AM.