Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 07-03-2012, 08:53 AM   #1
LQ Newbie
Registered: Apr 2012
Location: China
Distribution: ubuntu
Posts: 5

Rep: Reputation: Disabled
error occured when i installed wine

hi everyone:
The error is as below. Can you explain these code for me.
jianglu@jianglu-K43SJ:~/wine-1.5.7$ ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking for cpp... cpp
checking whether gcc -m32 works... no
configure: error: Cannot build a 32-bit program, you need to install 32-bit development libraries.
Old 07-03-2012, 03:28 PM   #2
Registered: Jun 2011
Distribution: Arch Linux
Posts: 151

Rep: Reputation: 34
this is a simple problem, you appear to be running a 64-bit operating system, but wine is a 32-bit program, and therefore depends on 32-bit libraries. In order to properly build wine you will need to install the 32-bit versions of all its dependencies (the packages will probably look something like lib32-whatever). However, it is likely that whatever distribution you are using has a package for wine that will take care of all the dependencies for you. What distribution are you using?



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] An Error Occured While Mounting peterrust99 Linux - Newbie 8 07-01-2012 04:18 AM
[SOLVED] An unhandled error occured jamesubuntufan Linux - Desktop 15 03-27-2011 01:18 PM
an error occured ramlirudi Linux - Newbie 1 08-24-2010 11:24 AM
error occured when installing wine-1.1.9 cricketlong Linux - Software 3 12-07-2008 12:51 PM
An Error Occured jjorloff1 Linux - Hardware 0 10-14-2005 10:59 AM

All times are GMT -5. The time now is 11:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration