LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 08-21-2005, 11:41 AM   #1
blastradius
Member
 
Registered: Oct 2004
Location: Cheshire, England
Distribution: Debian Stable
Posts: 269

Rep: Reputation: 39
enabling DMA problems


Ok, now as i've actually got a DVD to play, (gave up on Ubuntu64 and went to i386 so i could run the add-on cd). Ive tried to enable DMA with;-

sudo hdparm -d1 /dev/hdc

Unfortunately i get this error:-


/dev/hdc:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)

Anyone know why this is, and if there's another way to set DMA?

Thanks

Eric
 
Old 08-21-2005, 05:00 PM   #2
ghrellin
Member
 
Registered: Dec 2004
Location: USA
Distribution: Gentoo Linux
Posts: 41

Rep: Reputation: 15
As it happens, I had exactly this problem. First, do
Code:
lspci
and look for a line that looks something like this:
Code:
0000:00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
So on my computer, the IDE controller is SiS5513. Then look in your kernel config (usually /usr/src/linux/.config) for a line with that in it, something like CONFIG_BLK_DEV_SIS5513=y. You want to set it to y, because then it doesn't have to be modprobe'd each time you want the DMA on (e.g. all the time). If it's not there, recompile your kernel so your chipset is supported. That should fix all problems.
 
Old 08-22-2005, 02:22 AM   #3
blastradius
Member
 
Registered: Oct 2004
Location: Cheshire, England
Distribution: Debian Stable
Posts: 269

Original Poster
Rep: Reputation: 39
This is the line i think you mean? it's the only one which mentions IDE.

0000:00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)

I looked for the .config fle but can't find it, (i should mention that i'm a newbie and don't know how to recompile the kernel).


Any further help would be appreciated.

Why the hell isn't it switched on by default???
 
Old 08-22-2005, 09:55 AM   #4
ghrellin
Member
 
Registered: Dec 2004
Location: USA
Distribution: Gentoo Linux
Posts: 41

Rep: Reputation: 15
First of all, if you haven't heard it before, it's not that hard to recompile a kernel. Really. It's pretty bizarre that you don't have a .config file in /usr/src/linux...Is it that you can't find /usr/src/linux, or that you're there and don't see the .config?
 
Old 08-22-2005, 10:37 AM   #5
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,240

Rep: Reputation: 60
if there is no support for your motherboard chipset or ide controller built into your kernel, then dma will not work.
a file with a . in front like .config is hidden by the normal ls command. ls -a will show them.
 
Old 08-22-2005, 12:21 PM   #6
blastradius
Member
 
Registered: Oct 2004
Location: Cheshire, England
Distribution: Debian Stable
Posts: 269

Original Poster
Rep: Reputation: 39
all i've got in /usr/src is an RPM directory!! Can't find a linux directory.
 
Old 08-22-2005, 12:44 PM   #7
blastradius
Member
 
Registered: Oct 2004
Location: Cheshire, England
Distribution: Debian Stable
Posts: 269

Original Poster
Rep: Reputation: 39
Sorted it!

I did a :- sudo gedit /etc/modules

and included the lines:- amd74xx and via82cxxx

above the ide-cd line, and it all works great now.

Thanks for your help, i'm just settling back to watch Lord of the Rings (again!)
 
Old 08-22-2005, 07:08 PM   #8
ghrellin
Member
 
Registered: Dec 2004
Location: USA
Distribution: Gentoo Linux
Posts: 41

Rep: Reputation: 15
enabling dma on VT82C586A/B/VT82C686/A/B/VT823x - RESOLVED

Cool! I'm glad I could help.
 
Old 08-30-2005, 09:42 AM   #9
trex_dk
LQ Newbie
 
Registered: Aug 2005
Distribution: Ubuntu
Posts: 6

Rep: Reputation: 0
Hey blastradius!

I wonder if you could help me, now when you got your problem solved

I'm running ubuntu i386 as you, and can't find any .config files in my /usr/src/ directory.

Did you just specify a driver module to load, or did you do any more?
My chipset is a Nforce4, so I really don't know what to add in /etc/modules (if I have to add anything at all??)

And again, when I do a lspci I see this:
0000:00:06.0 IDE interface: nVidia Corporation: Unknown device 0053 (rev a2)

I really hope that any of you can help me - because my computer is running real slow when doing something 'demanding' from the harddrive(s).

Best regards
trex_dk
 
Old 08-30-2005, 01:13 PM   #10
blastradius
Member
 
Registered: Oct 2004
Location: Cheshire, England
Distribution: Debian Stable
Posts: 269

Original Poster
Rep: Reputation: 39
This is where i found the information which helped me to enable the DMA.

https://wiki.ubuntu.com/DMA

I just followed the instructions and everything worked great.

Also, in case you haven't already, go here:-

http://www.mrbass.org/linux/ubuntu/

and download and run the zip add-on file. It installs lots of stuff for you, ex: multimedia codecs e.t.c.

Good Luck
 
Old 09-07-2005, 01:49 AM   #11
budman85
LQ Newbie
 
Registered: Sep 2005
Location: Montreal Canada
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
Talking THANKS!

Thanks ghrellin!!!!


I've been struggling with this for a few years. Searching web sites... cannot tell you how many sites I read to finally see that simple solution here. Compile the driver into the kernel! I remember issues with multiple nic's, but never thought about the chipset driver.

I've been stuck with this vt82c686c chipset for more than 2 years. Every now and then I would try again, fail, give up for a month or so, try again.... same old... I updated kernels hoping it was addressed in the driver, mentioned it numerous places, but noone knew what was causing it!

I recently picked up a DVD writer, and ran into choppy responses, and 1x speed burning DVDs. So I thought it was the drivers, tried a 3rd IDE card (nice thing about Linux, even Windows95/98 allowed 4 IDE controllers, NT however, would only two. LOL - I spoke to Windows Tech staff - Why Do You need more than 2 IDE controllers! I said I have 7 IDE devices moron .. anyway! ). Still no luck!


I chose to recompile the kernel, rebooted and viola!
The onboard IDE was ATA100 -AND- the DVD writer had DMA working!
I did a quick test - Bingo! The DVD Movie played nicely - no jumping.


I currently run Slackware 10.1 with a custom kernel. Since the vt82xxxx driver was a module, would placing it in rc.modules or module.conf have solved it as well or would it need to be added as an append option?

What also helped, I found another article that showed the generate-modprobe.conf foo 2.6 kernels. I must of overlooked this in the docs, I didn't realize modules.conf is decom'd in 2.6. I see it added "options ide-cd dma=1" which was good.


Oh well, off to see how well the burner works now. The player works great!

Thanks again!

budman
 
Old 09-07-2005, 02:22 AM   #12
budman85
LQ Newbie
 
Registered: Sep 2005
Location: Montreal Canada
Distribution: Slackware
Posts: 20

Rep: Reputation: 0
Hi,

This site has a patch for the 2.6.11.x kernel - you may want to download a newer kernel which may have the updates for the amd74xx module:

http://lwn.net/Articles/141286/




Quote:
Originally posted by trex_dk
[B]Hey blastradius!

I'm running ubuntu i386 as you, and can't find any .config files in my /usr/src/ directory.
Sometimes the config file is location somewhere on the distro install disks. Otherwise, crank up "make menuconfig" in the /usr/src/linux dir and select all the options you want - takes a while to go thru all the menus. ie. Slackware includes the config file in the kernels/xxxx/ directory, same with RedHat. Run a find . -name "*config*" on your install cdrom or install dir to see if config files exist. copy this to the /usr/src/linux directory and rename it to .config - saves you some time, sets most of defaults - you can customize it to your liking now, just remember to save it for future updates. when I update to a new kernel, I always copy the .config to the next kernel source and run make menuconfig - when you save it, new entries for that version will be added. You can then scroll thru the menus selecting what you want.


Quote:
Did you just specify a driver module to load, or did you do any more?
My chipset is a Nforce4, so I really don't know what to add in /etc/modules (if I have to add anything at all??)
Looks like you will need to get a kernel version that either supports your new chipset amd8111 or patch an existing kernel with an amd74 patch for nVidia IDE. This is the 0053 device - its not in amd74 module, so its unknown.

Patching the kernel is not hard either - goto ftp.kernels.org and download the latest kernel. copy it to /usr/src, and then decompress it. its better to keep "linux" in the /usr/src as a symlink. Now just recreate the link: ln -s /usr/src/linux-2.6.12 linux
cd into the drivers/ide/pci directory - grep nVidia see if its in the amd74xxx module.

If it is, you are all set, just setup the config recompile and install the new kernel.

follow the docs in the kernels directory, it will walk you thru the compile.
Always remember to save .config before running make mrproper it will be wiped... I usually copy it as config-2.6.12 with the version appended to the file name and remove the leading dot so its not hidden - then copy it to a safe spot.

This will help you compile 2.6 step by step:

http://www.linuxquestions.org/questions/answers.php?action=viewarticle&artid=408


hope it helps.
budman

Last edited by budman85; 09-07-2005 at 02:24 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems permanently enabling DMA blastradius Ubuntu 1 10-27-2005 01:07 PM
Enabling DMA Problems. ShoCkwave Slackware 7 02-07-2005 12:29 PM
Enabling DMA DeadlyMuffin Slackware 4 07-19-2004 10:24 PM
problems enabling dma in kernel 2.6-test11 snoble Linux - Hardware 10 12-09-2003 02:20 PM
Enabling DMA bizzikid Linux - Newbie 4 08-06-2003 06:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 08:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration