-   Ubuntu (
-   -   DVD ROM issues with DVD-R (

al451f 02-07-2007 01:39 AM

DVD ROM issues with DVD-R
I'm running Ubuntu Dapper with Totem-xine as my movie veiwer. My DVD burner is a LG HL-DT DVD RAM GSA-H22N. It copies and burns dvds just fine, but I can't watch DVD-Rs. I get the "source could be encrypted" error just before the menu comes up all the way. If I keep trying to replay the same disk the drive locks up and will not eject the disk without a hard shutdown of the entire system. After the shut down the dvd is good as a coaster.

Is my problem with -xine or is it a hardware issue? I don't have access to another OS with DVD playing software.

vangelis 02-07-2007 07:38 AM

libdvdcss needed then..
Welcome to the world of patent issues my friend.
Playing a DVD you legally purchased with free software you are considered a "criminal" and you are "stealing" intellectual property from MPAA and RIAA.

To your question know..
You need the package named libdvdcss but since you are using ubuntu I would suggest you the easiest way of all.
Go to follow the instructions, pretty simple and straight forward. In no time you will have also support for mp3, multimedia, and other stuff.



al451f 02-07-2007 11:01 AM

I forgot to mention I can watch all the store bought dvds I want. I've already installed libdvdread and the css. My problem is watching the DVDs I've backed up without the DVD drive erasing them.

After looking at the easyubuntu link though, it seems I've done everything the hard way.

vangelis 02-08-2007 02:04 AM

If you backed them up on your hard disk, then the only player I've found easy to do this is Kaffeine, where you can load a directory and change the subs and choose menu.
I see you are using Ubuntu, I won't tell you to install kde but VLC is a very very good player which I think can do this work for you.

For installation help check here.

Hope this helps


EDIT: Oops! I just realised that above you metnioned you are making a copy of the dvd to another dvd-r and not in the hard disk. Have tried to write to maybe a dvd+r and see if it works? Or maybe another brand of dvd-r's. Try copying the disks on a slower speed, or even not on the fly.
Also please post the last lines of the command dmesg after the lock-up of the drive happens.

hansalfredche 02-08-2007 08:31 AM

Kaffeine sucks in playing backed up DVD's. Just see if your DVD get mounted correctly, then try opening a .vob (if I remember correctly) file on your DVD. If it plays fine it's Kaffeine, but I didn't find a way to correct it.

al451f 02-22-2007 01:41 AM

I've tried burning not on the fly and that has made the disks more durable. They don't get blanked when they're locked up in the ROM when they won't play. I'll get the dmsg info when I get a chance, haven't had the time to recreate the crash...

thanks for your help!

al451f 03-15-2007 01:01 PM

Should be DVD-R issues with DVD ROm
I broke down and tried the DVD player on my Windows HD using VLC. The ROM played all my DVD-Rs just fine. I apt-got VLC for Ubuntu and no dice still won't play the burned DVDs.

dmesg prints thusly:

[17183445.380000] hdc: command error: error=0x50 { LastFailedSense=0x05 }
[17183445.380000] ide: failed opcode was: unknown
[17183445.380000] end_request: I/O error, dev hdc, sector 256
[17183445.380000] Buffer I/O error on device hdc, logical block 64
[17183445.380000] lost page write due to I/O error on hdc
[17183488.744000] UDF-fs: No VRS found
[17183488.900000] ISO 9660 Extensions: Microsoft Joliet Level 3
[17183488.904000] ISOFS: changing to secondary root
[17183639.540000] UDF-fs: No VRS found
[17183639.712000] ISO 9660 Extensions: Microsoft Joliet Level 3
[17183639.716000] ISOFS: changing to secondary root

All times are GMT -5. The time now is 11:49 AM.