LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-27-2008, 04:49 PM   #1
sharky
Member
 
Registered: Oct 2002
Posts: 510

Rep: Reputation: 73
dvd playback has scramble video


When I run gmplayer the video portion is scramble or distorted. The audio seems fine.

If I run mplayer from the command line I get excellent video and no sound.

I can't get totem or xine to work either.

I don't see any errors messages anywhere.
 
Old 12-27-2008, 05:03 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,837

Rep: Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984
Try using different video and audio drivers. Some will work better than others. Since you get different outputs from the gui and cli versions of the same program, that seems like the most likely reason.
 
Old 12-27-2008, 05:07 PM   #3
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
This may not help but look in /usr/share/doc/packages/MPlayer/TOOLS/ for a binary_codecs.sh script. If you have this script, it will download binary codecs you may need. It works on Debian systems.

Is it possible that the two programs, mplayer and gmplayer were installed separately, and one is "mp3/dvd media enabled" while the other isn't.

Also, check for different settings between ~/.mplayer/config and ~/.mplayer/gui.conf. I think that the sound system used is different between the two.
 
Old 12-29-2008, 09:42 AM   #4
sharky
Member
 
Registered: Oct 2002
Posts: 510

Original Poster
Rep: Reputation: 73
It's working now

Had to install libdvdcss and some codecs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer Crashes on Current Video Suddenly on Data DVD Playback mrmike503 Linux - Software 1 11-15-2008 01:22 PM
Video Playback Audio without Video xine openSUSE bahbahthelamb Linux - Software 5 09-09-2008 10:54 AM
Video in DVD Playback unnatural miickEe. Ubuntu 1 05-14-2008 09:50 PM
Mplayer=useless? I need a DVD player and other video playback support servnov Linux - General 6 12-27-2005 01:13 PM
Video Playback-speeded up audio & video howone SUSE / openSUSE 1 10-20-2005 02:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 05:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration