-   Ubuntu (
-   -   Dual Install Windows 7 & Kubuntu 10.04 / 10.10-RC boot problem (

jay_pablo_69 10-08-2010 04:36 PM

Dual Install Windows 7 & Kubuntu 10.04 / 10.10-RC boot problem

i know you might think that this problem is solved and refer me to a similar thread with this problem solved, but mine is a bit different.

i've installed Kubuntu 10.04 on one of my partitions. But when i try to boot into linux after the installation i get this:


Check root=bootarg cat /proc/cmdline
or missing modules, devices: cat /proc/modules ls /dev
Alert! /dev/disk/by-uuid/xxxxxxxx-xxxx-xxxx-xx$ does not exist. Dropping to a shell!
i've tried all web solutions but still not good. i changed the uuid number to /dev/sdax (the partition where i installed Kubuntu) but still not working. i tried this on both the 10.04 & 10.10 editions. i tried the "apt-get upgrade", grub upgrade, etc but no way.

here's the thing (or should i say another thing), whenever i want to run live-cd of any linux distro (tried puppylinux, ubuntu and kubuntu) i have to enter the command "nolapic" or simply check it in ubuntu/kubuntu before my hdd can be detected when in live mode. if not, it's just like i have no hdd when running live-cd. this setting is from my BIOS, my motherboard does not have the 'IDE mode' under the SATA mode' option. it has just SATA, AHCI & RAID mode options. if i switch to any other mode apart from SATA, my windows 7 installation will not boot and it just keeps restarting the system. i had to check "nolapic" before i installed kubuntu.

is it that linux does not detect my hdd to boot or what? when i turn on my pc it loads GRUB, prompting me to choose which OS (windows 7 or kubuntu) to boot.

i really want to leave windows and 'dine' with linux but this problem is making my 'dinner date' impossible. :) right now i'm posting this via kubuntu live-cd.

help me pls! someone...... anyone......!

thank you in advance.

*** and also, maybe someone has encountered this error on kubuntu 10.10 browser 'rekonq' and filed a bug report, but the browser keeps crashing as soon as i start typing in the address bar. after hitting any 3 keys, it crashes. i can't file any bug-report now 'cos this installation problem has got my head spinning. this is a little BUG-REPORT.

yancek 10-08-2010 06:50 PM

Boot your Kubuntu Live CD and open a terminal and run the command: blkid

Check this output and compare the UUIDs to the one you got in your error message to see if it does exist.

While you are on the live CD, run the command: sudo fdisk -l which will give partition information. Have you changed your partitions?

jay_pablo_69 10-08-2010 09:55 PM

i have done that already (run 'blkid' command) and compared the output to the uuid string and they match. i installed kubuntu on /dev/sda9 partition, i even changed the uuid string to /dev/sda9 but still nothing. i haven't changed my partitions at all, i just created these partitions yesterday.

when on BusyBox shell, i typed 'ls' command and it showed all the files but when i do an 'ls /root' or 'cd root' and then 'ls' nothing comes up. it's like the folder is just blank. honestly i don't know what else to do.

i frankly appreciate your prompt response Yancek. thank you very much!

more help needed. thanks!

yancek 10-10-2010 02:24 PM

Boot with the Kubuntu Live CD. Mount sda9 and look at its files and get the /boot/grub/grub.cfg file and post it. Make sure you don't post the one off the CD (Don't actually know if one exists, not an Ubuntu user) and also run the command: sudo fdisk -l (lower case Letter L in the command) and post that partition information. You might also post the results of the blkid command. I don't use Ubuntu or Grub 2 but someone here should be able to help.

verndog 10-10-2010 11:12 PM

The fastest and easiest way for us to help is for you to download a small script and run it from the livecd. Its called boot_info_script. that way we can see all your boot info.

It will dump a file named RESULTS.txt in the same folder where you ran boot_info_script.

jay_pablo_69 10-27-2010 06:55 AM

hi everybody!

sorry i took a long time to respond. school stuff. but thanks for your patience.
i haven't solved the problem though.

verndog, i downloaded and ran the script you told me and this is what it displayed (besides, i'm running ubuntu 10.10 live cd, with no boot parameters, so my hdd is not showing):


DATE="February 15th, 2010"
#to use this script:
# sudo bash
# su -
# bash
### last-modified
#author Ulrich Meierfrankenfeld (aka meierfra.)
# with contributions from caljohnsmith
# (both members of
# and Gert Hulselmans
#hosted at:
#The birth of the boot info script:
#Looks at all MBRs and identifies the boot loader.
# For Grub and Supergrub: displays the controlling partition.
# If the MBR is unknown, displays the whole MBR.
#Looks at all partitions:
# Determines their type
# Identifies their boot sectors.
# For grub: displays the controlling partition and the offset
# of the stage2 file as recorded in the boot sector.
# For NTFS and Fat, examines the Boot Parameter Block for errors.
# Identifies the operating system
# Lists boot programs.
# Displays the partition table
# Displays "blkid -c /dev/null"
# Finds boot directories and displays their contents.
# Looks in "/" and "NST" for bootpart codes and displays the offset
# and boot drive it is trying to chainload
# Looks on "/" and "/NST" for stage1 files and displays the offset
# and bootdrive of the stage 2 files is trying to chainload.
# Displays boot configuration files.
# Is able to search LVM partitions if the LVM2 package is install
# ("apt-get install lvm2" in debian based distros)
# Is able to search Linux Software Raid partitions (MD Raids) if
# the "mdadm" package is installed.
# If dmraid is installed, searches all raid drives, detected by dmraid.
#All information is written to the file "RESULTS.txt" in the
# same folder as the script. But when run from /bin, /sbin, /usr/bin,
# or other system folder the file "RESULTS.txt" is written to the
# home directory of the user who runs this script.

jay_pablo_69 10-27-2010 06:59 AM

this post has been deleted by me bcos it's not necessary.

jay_pablo_69 10-27-2010 06:59 AM

this post has been deleted bcos it's not necessary.

yancek 10-27-2010 10:25 AM

You posted the contents of the script which doesn't help. Go to the site below which tells you what to do to run this Bash script to get the information requested earlier:

jay_pablo_69 10-27-2010 08:45 PM

sorry, here's the RESULT.txt content:


Boot Info Script 0.55 dated February 15th, 2010

============================= Boot Info Summary: ==============================

=========================== Drive/Partition Info: =============================

no valid partition table found
blkid -c /dev/null: ____________________________________________________________


/dev/loop0 squashfs
error: block: No such file or directory
error: devices: No such file or directory
error: /dev/mapper/no: No such file or directory
error: found: No such file or directory

============================ "mount | grep ^/dev output: ===========================

Device Mount_Point Type Options

aufs / aufs (rw)
/dev/sr0 /cdrom iso9660 (ro,noatime)
/dev/loop0 /rofs squashfs (ro,noatime)

=======Devices which don't seem to have a corresponding hard drive==============

no block devices found
***ps: ubuntu booted without without the boot parameter 'NOLAPIC' which makes my hdd discoverable. i don't know how to set this boot parameter in this version (ubuntu 10.10) bcos it goes straight to the "try ubuntu" / "install ubuntu" screen unlike the previous versions. (i also need an assistance here :( )

thanks for your assistance.

yancek 10-27-2010 10:11 PM

I don't know what to make of your Results.txt file. There is nothing there. Usually outputs partition information, grub menu files and much, much more. The only information seems to refer to the CD? Did you follow the instructions exactly on the page I linked to?

jay_pablo_69 11-04-2010 08:55 AM

i did it accordingly. remember i told you that before linux detects my hdd, i must use the "NOLAPIC" parameter during booting process. but since the new ubuntu 10.10 it does not show the screen where one can choose the boot option (very unlike the previous versions) and i do not know how to enter the boot parameters in this new version. that is why the RESULT.txt is only referring to the CD. pls how do i enter the boot command (e.g. NOLAPIC, NOAPIC, DMRAID-OFF, etc) before boot-up in this new version?

thank you.

yancek 11-04-2010 10:28 AM

I would suggest you go to this link which explains Grub2 on Ubuntu. If you scroll down the page to the section "Command Line and Rescue Mode" there is a section under that which explains in detail "Editing Menus during boot".

This would be a good link for you to bookmark if you will be using Ubuntu.

jay_pablo_69 11-07-2010 12:41 AM

hi Yancek,

i finally managed to solve the main problem. remember i said that my problem was that i must use 'NOLAPIC' parameter before my hdd is detected by GRUB; and ubuntu 10.10 didn't display the screen for me to choose parameters (nalapic, noapic, dmraid=off, etc). this was how i solved it:-
after inserting the ubuntu 10.10 cd, at the loading screen i pressed F2 and it showed the familiar screen where i choose the display language, with the options to run ubuntu as a live-cd or install or boot from hard disk. i press F6 and chose the NOLAPIC parameter, then highlight 'install ubuntu' and hit 'enter'.
after installation, on the GRUB screen where to choose the OS i wish to run:


ubuntu xxxxx
ubuntu xxxxx (recovery mode)
memtest xxxx
memtest xxxx (xx-xxx)
windows 7 loader
i highlight the 1st ubuntu and press 'e' to make a temporary edit to the GRUB boot option menu. i go down to the line where you have:

LINUX /BOOT/VMLINUZ-xxxxxxxxx ro quiet splash
after the QUIET SPLASH i leave a space and write NOLAPIC (i believe one can enter any boot parameter here) and pres 'CTRL' & 'X' key to boot as it says below the screen. and then "VOILA!" GRUB detects my hdd and boots the installed ubuntu on it.
the next thing for me to do now is find a way to make this NOLAPIC constant so that i do not have write it everytime i want to run ubuntu. can you help me with the procedure?

i sincerely thank you and verndog for your great assistance.

*** i had to make my steps as descriptive as possible for other newbies, i'm sure you already know that.

but all in all, THANK YOU!

jay_pablo_69 11-07-2010 01:01 AM


i did it!!! everything is now alright! i've added NOLAPIC to GRUB and can now boot without any problem.
i simply issued this command from the terminal.

sudo gedit /etc/default/grub
then added the parameter NOLAPIC to the GRUB_CMDLINE_LINUX_DEFAULT line:
old: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
new: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nolapic"

now all is A-OK!


All times are GMT -5. The time now is 02:24 PM.