-   Ubuntu (
-   -   Dual Boot-Lost Windows (

impeteperry 10-27-2005 07:07 PM

Dual Boot-Lost Windows
This may not fit here, but I don't know here else to go. None of my friends know anything about computers and are sick and tired of me touting Linux.
I am using 5.04 on my main computer and it works fine!!
I have separate hard drives for Windows and Linux on my backup computer
I wanted to compare Kubuntu 5.10 with Mepis 3.3 on this computer ( runs Windows ME)
I was using SystemCommander to do this multiple installation. The net result was that I screwed everything up. The people at SystemCommander tried to help me, but whatever I tried the mess got worse. I decided that I really didn't need to install Mepis so went back and installed Ubuntu 5.10 with all the KDE stuff. That works fine. I got rid of SystemCommander and installed Grub in the MBR of the windows disk.
Now when I select Windows in the grub loader all I get is "Starting Windows Millennium Emergency Boot". I don't know where to go from here.
When I go back to Linux, I can see the all the Windows stuff is there in /dev/hda1. I have 3 diferent recovery CDs and two recovery disketts, but none work.

Any help and/or suggestions would be appreciated.

syg00 10-27-2005 09:05 PM

You again .... :D
Is the message you are seeing from Winows itself, or does it look like a grub message ??.
Let's have a look at your menu.lst - or grub.conf, whichever you are using.
And the output of

fdisk -l
(that's ell, as in list).

impeteperry 10-27-2005 10:58 PM

When I reboot, I get the standard Grub list of options. When I select "Windows ME" I get the message I listed and I get the "C:" prompt. I am able to "dir /p" and get files and directories. I can use the "edit" to look at the files. It behaves as thou I was stuck in "DOS" mode.
I have gone into the "windows" snd the "windows\system" directories and scaned thru the various files. I tried a few likely suspects, but got "can't run this in DOS mode" or "can't run this in windows". I am able to go into the "D" directory which has "Data".

I am also able to open "A:" drive and read files from there. I have not tried to run any programs from the A: drive as I don't have any dos program disketts. I really haven't messed around too much as that is what got me in trouble in the first place.

syg00 10-27-2005 11:18 PM

What about the other info I asked for ???.

impeteperry 10-29-2005 10:22 AM


Originally posted by syg00
What about the other info I asked for ???.
I hope I can get this right
The message looks like a Grub message

Booting 'Windows 95/98/me'
Root (hd0,0)
File system type is fat partition type 0.xc
Save default
make active
chain loader +1
and the Grub menu list

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

# examples
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hdb1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## nonaltoption boot targets option
## This option controls options to pass to only the
## primary kernel menu item.
## You can have ONLY one nonaltoptions line
# nonaltoptions=quiet splash

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## ## End Default Options ##

title Ubuntu, kernel 2.6.12-9-386
root (hd1,0)
kernel /boot/vmlinuz-2.6.12-9-386 root=/dev/hdb1 ro quiet splash
initrd /boot/initrd.img-2.6.12-9-386

title Ubuntu, kernel 2.6.12-9-386 (recovery mode)
root (hd1,0)
kernel /boot/vmlinuz-2.6.12-9-386 root=/dev/hdb1 ro single
initrd /boot/initrd.img-2.6.12-9-386

title Ubuntu, memtest86+
root (hd1,0)
kernel /boot/memtest86+.bin


# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title Windows 95/98/Me
root (hd0,0)
chainloader +1
and then the "fdisk l" (I can't add images so I have copied the list)

pete@ubuntu:~$ sudo fdisk -l

Disk /dev/hda: 30.0 GB, 30020272128 bytes
24? heads, 63 sectors/track, 3877 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

Degice Boot Start End Blocks Id System
/dev/hda1 * 1 3499 26452408+ c W95 FAT32 (LBA)
/dev/hem2 3500 3877 2857680 f W95 FAT'd (LBA)
/dev/hda5 3500 3877 2857648+ c W95 FAt32 (LBA)

Disk /dev/hdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinedrs
Units = cylinders of 16065 * 512 = 8225280 bytes

Degice Boot Start End Blocks Id System
/dev/hdb1 * 1 9612 77208358+ 83 Linux
/dev/hdb2 9613 9729 939802+ 5 Extended
/dev/hdb5 9613 9729 939771 82 Linux swap / Solaris
I'm thinking that maybe I should erase everything on the first disk and start over. My Compaq Quick restor disks won't work because of the stuff on the drive. What do you think?

syg00 10-29-2005 09:03 PM

I'm not big on "starting over" .... ;)
Can't see anything obviously wrong with the menu.lst or partition tables.

Google on the ME message turned this up. As I have never used ME, I'm loathe to suggest anything - but that is M$ofts knowledgebase.

Search around and see what you find.

impeteperry 10-29-2005 11:20 PM

my io.sys is 114.0
my autoexec.bat does not run, but Autoexec.bat is [QUOTE]@if exist c:\checkmbr.exe c:\checkmbr quiet (Validate MBR, not a TSR)
while Autoexec.bak i [QUOTE]@if exist c:\checkmbr.exe c:\checkmbr quiet (Validate MBR, not a TSR)
SET winbootdir=C:\WINDOWS
I haxe 2 snapshots that might shed some light on the problem, but I can't attach them.
The first one is :
tiled mbr-boot
Whole bunch of numbers and symbols ant the the following text:
No active OS partitiond. Run Fdisk to make a partition active.
BIOS error xx reading hard disk. Missing OS or unformatted active partition.
Press any key to boot floppy.
I shall look some more at the site you refered me to as well as a 1625 page book "Upgrading and Repairing PCs" which has a lot of studff in it.

Whether we solve this or not, I appreciate your time and efforts. Even at 80 I'm still trying to learn and as I said it is really the backup for my linux programming I need this machine for. (I'm rewriting 4 of my pre-dos, dos, c++ and VB programs for the precast concrete industry.) i'm anti AutoCAD and anti M$. Thanks again

syg00 10-30-2005 12:17 AM

Without meaning to sound rude, I have heard Windows ME was a bastard child - might be true.

What makes you think the autoexec isn't running ???.

If it was my system, I rename the c:\checkmbr.exe to something else. I've not looked at the ME loader, but in general M$oft has some inane checks.
Do it from Ubuntu - it should mount the partitions read/write. Then try booting again. If still fails, then try the solution from the MSoft kb - that "sys c:" command just recreates the minimal system files to boot the C: disk.

aysiu 10-30-2005 12:44 AM

Have you tried just reinstalling Grub on the MBR?

hackerarchangel 10-30-2005 12:48 AM

ok man

does ME have a file in C: called msdos.sys? if it does, type edit msdos.sys and see if you can modify it. Change the line that has GUIsomething=0 to GUIsomething=1. The line isn;t exact as i havent messed with it in a awhile but that is how 98 boots soley into DOS mode.

Oh, BTW, if you can't edit it, you need to change the attributes of it to make it not read only. Bit i can';t remember how to do that. ;)

impeteperry 10-30-2005 02:53 AM


Originally posted by hackerarchangel
ok man

does ME have a file in C: called msdos.sys? if it does, type edit msdos.sys and see if you can modify it. Change the line that has GUIsomething=0 to GUIsomething=1. The line isn;t exact as i havent messed with it in a awhile but that is how 98 boots soley into DOS mode.

Oh, BTW, if you can't edit it, you need to change the attributes of it to make it not read only. Bit i can';t remember how to do that. ;)

Hackerarchangel you are an angel. I changed the BootGUI to a "1" and re-booted. My bastard child is sweet and pure this morning. Boy you guys are great.

Thanks to all!!!!

Bonzodog 10-30-2005 07:25 AM

just a quick note to say:
If you insist on keeping windows, either roll back to 98se or upgrade to 2000.
I used to know someone that worked for M$ in their florida office, and they had banned usage of ME simply because it was so fscked up that it kept on taking down M$'s own networks. M$ people with it found on their systems were sacked after recieving warning to remove all instances of it within the corporate structure. This is from the mouth of an MS developer: DO NOT use ME. It is buggy, and is so faulty that it is dangerous to use.

I personally have never found a stable computer with it on. Seriuosly dude, get windows 2000.

impeteperry 10-30-2005 08:41 AM

Thanks for the suggestion. I agree with you about ME, but I won't be using it except to compare some comercial programs I wrote with the new Linux version I am writing.on an XP computer. If I ever had a need to do work in windows I would do it on the XP box, and since I don't have 98-2ed or 2000 I will stay with ME.


All times are GMT -5. The time now is 01:17 PM.